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Welcome to Frontline NetDecoderAsync
Welcome to Frontline Test Systems (FTS). The design of Frontline allows you to conduct data analysis of protocols
using your personal computer. The Frontline interface is easy to use without training, but we recommend you
read the online Help to take maximum advantage of all the features.
We designed the online Help with complete explanations and easy to use systematic instructions. Access the
online Help by choosing Help Topics from the Help menu, or by pressing the F1 key on any window.
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Chapter 1 Getting Started: The Control Window
The analyzer displays information in multiple windows, with each window presenting a different type of
information. The Control window provides access to each window as well as a brief overview of the data in the
capture file. Each icon on the toolbar represents a different data analysis function.
Because the Control window can get lost behind other windows, every window has a Home icon

that brings

the Control window back to the front. Just click on the Home icon to restore the Control window.

1.1 Control Window Toolbar
Table 1.1 - NetDecoder Async Control Window Toolbar Icons
Icon

Description
Start Capture - Begins data capture to disk.
Stop Capture - Available after data capture has started. Click to stop data capture. Data
can be reviewed and saved, but no new data can be captured.
Save - Saves the file the capture file.
Clear - Clears or saves the capture file.
Signal Display - Opens The Signal Display dialog.
Breakout Box - Opens the Breakout Box dialog.
Transmit - Opens the Transmit dialog.
Network View - Opens the Network View Window.
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Chapter 1 Getting Started: The Control Window

Table 1.1 - NetDecoder Async Control Window Toolbar Icons (Continued)
Icon

Description
Dashboard - Opens the Dashboard dialog
Signal Display - Opens The Signal Display dialog.
Breakout Box - Opens the Breakout Box dialog.
Transmit - Opens the Transmit dialog.
Network View - Opens the Network View Window.
Dashboard - Opens the Dashboard dialog.

1.2 Menus
The menus that you see on the Control Window and dialogs like Frame Display and Event Display vary depending
on whether the data is being captured live or whether you are looking at a .cfa file. You will see File, Edit, View,
Filter, Bookmarks, Live, Options, Window, and Help. Most of the options are self explanatory.
l

l

l

Recreate Companion File: This option is available when you are working with decoders. If you change a
decoder while working with data, you can use Recreate Companion File to recreate the .frm file, the
companion file to the .cfa file. Recreating the .frm file helps ensure that the decoders will work properly.
Reload Decoders: When Reload Decoders is clicked, the plug-ins are reset and received frames are decoded
again.

l

Under the View menu you can choose which Frontline windows are available to open.

l

Live contains commands that are used in capturing data.

l

Under Options you have opportunities to set/modify various system settings. These include:

l

Hardware Settings

l

I/O Settings

l

System Settings

l

iv

Many of the File/Edit menu items are standard Windows type commands: Open, Close, Save, Recent Files, etc.
There are, however, several of these menu items that have unique functionality:

Check for New Releases at Startup: When this is enabled, the application automatically checks for the latest
Frontline releases. If a new version is detected, the following dialog appears.
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Figure 1.1 - New Release Available Dialog
l

l

The Window menu displays the open Frontline dialogs and standard options like Cascade, Minimize, Tile, etc.
Within the Help menu you can open the electronic Help file, About Frontline , and access the Frontline web
site for additional help.

1.3 Configuration Information on the Control Window
The Configuration bar (just below the toolbar) displays the hardware configuration and may include I/O settings.
It also provides such things as name of the network card, address information, ports in use, etc.

1.4 Status Information on the Control Window
The Status bar located just below the Configuration bar on the Control window provides a quick look at
current activity in the analyzer.

l

Capture Status displays Not Active, Paused or Running and refers to the state of data capture. It will also
display whether you are capturing to a series of files or capturing to a single file.

l

Not Active means that the analyzer is not currently capturing data.

l

Paused means that data capture has been suspended.

l

Running means that the analyzer is actively capturing data.

l

% Used

l

l

l

The next item shows how much of the buffer or capture file has been filled. For example, if you are capturing
to disk and have specified a 200K capture file, the bar graph tells you how much of the capture file has been
used. When the graph reaches 100%, capture either stops or the file begins to overwrite the oldest data,
depending on the choices you made in the System Settings.
Utilization/Events
The second half of the status bar gives the current utilization and total number of events seen on the network.
This is the total number of events monitored, not the total number of events captured. The analyzer is always
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monitoring the circuit, even when data is not actively being captured. These graphs allow you to keep an eye
on what is happening on the circuit, without requiring you to capture data.

1.5 Opening NetDecoder
On product installation, the installer creates a folder on the windows desktop labeled “Frontline NetDecoder
[Version #]”.
1. Double-click the Frontline NetDecoder desktop folder.
This opens a standard Windows file folder window.

2. Double-click on Frontline NetDecoder and the system displays the Select Data Capture Method dialog.
Note: You can also access this dialog by selecting Start > All Programs > Frontline
NetDecoder (Version #) > Frontline NetDecoder.
This dialog lists all the protocols NetDecoder supports in a tree control. See Protocol List
Three buttons appear at the bottom of the dialog; Run, Cancel, and Help. When the dialog first opens, Cancel
and Help are active, and the Run button is inactive (grayed out).
starts NetDecoder using the selected protocol stack.
closes the dialog and exits the user back to the desktop.
takes the user to this help file as does pressing the F1 key.

Select a Protocol
Expand the folder containing the desired protocol and select the protocol that matches your configuration.
Note: If you don't need to identify a capture method, then click the Run button to start the
analyzer.

Data Capture Method
This pane is located on the Choose Protocol to Analyze dialog just below the protocol list, and lists the methods by
which Frontline can capture data.
The following selections appear in this list:

vi
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Serial Ports

l

RS-232 ComProbe

l

Ethernet Card

l

LiveImport
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These selections are exclusive radio buttons and are inactive (grayed out) until a protocol selection is made.
If the protocol selection has only one method of data capture, then the system automatically selects that capture
method and the buttons remain inactive (grayed out).
If the selected protocol has more than one capture method, then the selection buttons that correspond to the
possible capture methods become active, allowing you to make a selection. When multiple selections are
available, the system defaults to Serial Ports.
After making a capture method selection, click the Run button to start the analyzer.

Creating a Shortcut
A checkbox labeled Create Shortcut When Run is located near the bottom of the dialog. This box is un-checked by
default.
Select this checkbox, and the system creates a shortcut for the selected protocol, and places it in the NetDecoder
desktop folder and in the start menu when you click the Run button.
This function allows you the option to create a shortcut icon that can be placed on the desktop. In the future,
simply double-click the shortcut to start the analyzer in the associated protocol.

Predefined Stacks, Rules and Decoders
Each Datasource type loads all decoders appropriate for that type. All Predefined Stacks and Traversal Rules
associated with those decoders are also loaded.
Ethernet selections load the “Ethernet with autotraverse” predefined stack. All rules and Ethernet decoders are
also loaded.
Async and sync selections have all predefined stacks available for all appropriate protocols. The stack selected on
start up is the one specified by the selection made in the Choose Protocol to Analyze dialog.
Making all appropriate predefined stacks available allows you to switch stacks if you need to after start up.

1.6 NetDecoder Protocol List
In the list below, folder names are in bold type, and protocol shortcuts are in normal type. Selecting any of the
protocol shortcuts activates the “Run” button at the bottom of the dialog.
l

A folder icon precedes all folder names in the dialog

l

An icon precedes all protocol selections in the dialog

See:Choosing a Protocol
The Protocols available for selection include:
ABB Automation - Use NetDecoder to capture and analyze COMLI communications.
l

COMLI
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Bristol Babcock - Use NetDecoder to analyze Bristol Babcock network communications.
l

BSAP

Building Automation and Control Networks - Use NetDecodr to capture and analyze BACNet communications.
l

BACnet MSTP Frame

l

BACnet PTP

l

BACnet/IP

CC Link - Use NetDecoder to analyze CC-Link network communications
l

CC - Link IE

l

CC - Link Serial

Controller Area Network (CAN) - Use NetDecoder to analyze CAN network communications.
l

CAN 2.0A using SST's interface cards

Distributed Network Protocol - Use NetDecoder to analyze DNP3 network communications.
l

DNP3 Ethernet

l

DNP3 Serial

Emerson Process Management - Use NetDecoder to capture and analyze Emerson-ROC protocol
communications.
l

ROC Plus Master

l

ROC Plus over Ethernet

l

ROC Plus Slave

l

ROC Master

l

ROC Slave

Ethernet Analyzer - Use NetDecoder to capture and analyze Ethernet communications.
l

Ethernet

Generic Asynchronous Serial Protocols - Use NetDecoder to capture and analyze Asynchronous RS-232/422/485
Serial Communications.
l

Asynchronous Point-to-Point Protocol

l

RS-232 ComProbe II without stack

l

RS-422/485 ComProbe without stack

l

Serial Line Internet Protocol

International Electrotechnical Commission (IEC) - Use NetDecoder to analyze IEC 60870 networking technologies.

viii
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l

IEC-60870-5-101

l

IEC-60870-5-102

l

IEC-60870-5-103

l

IEC-60870-5-104
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Modbus - Use NetDecoder to analyze any of these Modbus networking technologies.
l

ASCII

l

2 Wire

l

Master

l

Slave

l

Modbus TCP
Capture and analyze Modbus TCP communications over Ethernet.

l

RTU

l

2 Wire

l

Master

l

Slave

l

TANO

ODVA - Use NetDecoder to analyze these ODVA networking technologies.
l

ControlNet using 1784-PCC card

l

ControlNet using 1784-U2CN

l

DeviceNet using SST's interface cards

l

DeviceNet using the 1784-U2DN device

l

Ethernet/IP

PROFINET - Use NetDecoder to analyze PROFINET networking technologies.
l

PROFINET

Rockwell Allen Bradley - Use NetDecoder to analyze any of these Rockwell Automation networking technologies.
l

CSP

l

DFI

l

Full Duplex

l

DF1 Full-Duplix/Radio Modem with BCC

l

DF1 Full-Duplix/Radi0 Modem with CRC
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Half Duplex

l

DF1 Half Duplex with BCC

l

DF1 Half Duplex with CRC

l

DH+ using the 1784-U2DHP Cable

l

DH+ with a DHM-3500

l

DH+ with Allen Bradley Manchester Decoder

l

DH-485
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Saia-Burgess S-Bus - Use NetDecoder to analyze S-Bus Protocols, including Parity Mode, Data Mode, and Secure
Mode.
l

Data Mode

l

Parity Mode (RS-232)

l

Parity Mode (RS-485)

l

Secure Mode

1.7 RS-232 ComProbe II Driver Installation
Note: The following process supposes that NetDecoder has already been installed.
When first connecting the USB ComProbe to your PC you will be directed to install the required Frontline
interface driver.
1. Connect the USB cable into the back of the RS-232 ComProbe II.
2. Connect the other end to a USB port on the computer with Frontline software installed.
The Found New Hardware Wizard dialogue box appears which may ask you if you want to connect to
Windows Update to search for software.
3. Choose No, not this time and click Next.
4. Choose Install from a list or specific location and click Next.
Now you have to locate the USB driver.
5. Click the Browse button.
6. Locate the directory where you installed NetDecoder (the default is C:\Program Files\Frontline Test
System II\NetDecoder [version #]\Drivers\RS-232 ComProbe II)
7. Select the appropriate directory and click OK.
8. Click the Next button to finish the installation.
9. If you get a dialog box indicating that the software has not passed Windows logo test, don’t worry—click
Continue Anyway.

x
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Your computer will now install the USB ComProbe II driver from the directory you selected; you’ll get a dialog box
saying that the installation is finished.
10. Click the Finish button to close the wizard.
The installation of the RS-232 ComProbe II driver is now complete. Your computer will remember this USB
application. The next time you plug in the RS-232 ComProbe II, it will automatically find the appropriate interface
driver.
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Chapter 2 NetDecoderAsync Configuration Settings
2.1 Hardware Settings
2.1.1 NetDecoderAsync Hardware Settings
The Hardware Settings dialog is used to select a device to sniff/scan.
To access the Hardware Settings dialog:
1. Select Hardware Settings from the Options menu on the Control window.

NetDecoderAsync Hardware Settings Dialog
Note: This dialog is used for both RS-232 and RS 422/485.
2. Select a device from the drop-down list.
3. Select OK.
If no devices are found, the list will be blank. You can also select Refresh List to make sure the list is complete.

2.1.2 CC-Link Hardware Settings
When establishing CC-Link settings, if you have multiple ComProbes you must select which device to sniff. You do
that with CC-Link Hardware Settings.

NetDecoder Async User Manual
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Note: We do not recommend running more than one CC-Link sniffing session at a time on the
same PC. CC-Link runs at a maximum baud rate of 10 Mbps. At that rate the PC will have
significant performance issues while trying to capture data from multiple CC-Link ComProbes.
1. Connect the CC-Link ComProbe to an available USB port.
2. Start the analyzer.
3. Select Hardware Settings from Options menu on the Control Window.

Figure 2.1 - CC-Link Hardware Settings Dialog
4. Choose a ComProbe device to use from the drop-down list. If you have only one ComProbe connected to
your PC, that device is used automatically and you don't need to select it.
5. Select OK to save the settings, Cancel to close the dialog without saving the settings, or Help to access the
electronic help file.

2.2 I/O Settings
2.2.1 Bit Order
Choose LSB (least significant bit) first or MSB (most significant bit) first. LSB first is normal, while MSB first is
considered "reversed" from normal. This option reverses the order of the bits within each byte.
All options on the I/O Settings window are valid when in MSB mode except for parity. The parity must be None
when using MSB bit order.
Bit reversal occurs when monitoring and transmitting data. For example, if the analyzer is monitoring data in LSB
mode and sees 0000 0001 on the circuit, it displays this as hex 01. In MSB mode, the analyzer reverses the order
of the bits as they come in and display this byte as 1000 0000, or hex $80.
When transmitting data, the analyzer reverses the bits before they are sent out over the circuit. For example, if
you are transmitting data in LSB mode and you enter the pattern $01, the analyzer sends out 0000 0001. If you are
transmitting in MSB mode and you enter the pattern $01, the analyzer bit reverses this and transmit 1000 0000.
The analyzer remembers what bit order was used to capture the data with. If you create a capture file with the bit
order set to MSB, the data always is displayed in that form.
If you are monitoring HDLC or SDLC data and the bit order is set to MSB, it is probable that the CRC's is not
calculated correctly.

xiv
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2.2.2 Selecting a Custom Protocol Stack
To change the protocol stack:
1. Click on the Custom Protocol Stack button

to start the Protocol Stack Wizard.

If you are capturing framed data but did not select a protocol stack before capturing, your data needs to be
framed. To frame your data, complete the following steps:
1. Select a protocol stack.
2. Go to the Control window and choose Reframe from the File menu. See Reframing a Function for more
information.

2.2.3 I/O Settings Dialog in Capture File Viewer
The I/O Settings dialog only appears when viewing serial data. It displays the settings that were in effect when the
file was captured. The window looks different depending on whether you are viewing asynchronous or
synchronous data.
When using capture file viewer, the I/O Settings dialog is grayed out except for the Custom Protocol Stack button
and the Names button.
The analyzer knows which protocols were used when the file was captured, and automatically decodes the data in
the file according to those protocols. If you need to change the protocol, click the Custom Protocol Stack button to
create a custom stack.
Click the Names button to change the labels for errors, control signals and the sides displayed in the other
windows of the analyzer.

2.2.4 RS-232 ComProbe II I/O Settings
Before you can begin capturing data, you must set the data rate and several other variables. You provide this
information in the I/O Settings window.
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RS-232 ComProbe II I/O Settings Dialog
1. Click on the I/O Settings icon
Options menu.

on the Control window toolbar, or choose I/O Settings from the

2. For the Data Rate (bps), select a rate from 300 to 921,600 or enter a unique data rate up to 954,861.

xvi
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I/O Settings Options
Selections

Option

Data Rate Select a rate from 300 to 921,600 or enter a unique data rate up
(bps)
to 954,861.
Data Rates supported
300 - 220000
220353 - 238715
240385 - 260416
264424 - 286458
293804 - 318287
330529 - 358072
377748 - 409226
440706 - 477430
528847 - 572916
661058 - 716145
881411 - 954861
Parity

None (Default)
Odd
Even
Mark

Data Bits

5
6
7
8 (Default)

Stop bits

2
1.5
1 (Default)

Disable
Active when checked.
Control
Signal
Interrupts
Monitor

Capture DTE (Data Terminal Equipment)
Capture DCE (Data Communications Equipment)
Both (DTE & DCE)
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Click the OK button when finished configuring the ComProbe.
Once you have configured the I/O Settings, you can save those settings. Click here to see how to save
configuration settings.

2.2.5 Defining RS-232 ComProbe I/O Settings
Before you can begin capturing data, you must set the data rate and several other variables. You provide this
information in the I/O Settings window.
1. Click on the I/O Settings icon
Options menu.

on the Control window toolbar, or choose I/O Settings from the

2. In the Operating Mode box, choose Monitor Both. If you want to transmit data, select either Source DTE or
Source DCE.
3. If your circuit is asynchronous, set your Communication Mode to Async.
4. If your circuit is synchronous, set the Communication Mode to either Sync (NRZ External Clock) or Sync
(NRZI External Clock). Do not choose Internal Clock when monitoring synchronous data. Set the Sync Mode
to Monosync, Bisync, or HDLC/SDLC. Choose HDLC/SDLC if you are monitoring HDLC, SDLC, Frame Relay or
other protocol that uses hex 7e as the framing byte. If your circuit is Monosync or Bisync, you also need to
set the parity and sync characters, and tell Frontline when to strip sync characters and when to drop sync.
5. Set the baud, parity, word length and stop bits to the correct settings for both sides of the circuit.
6. [optional] Click the Custom Protocol Stack button to select a protocol stack. Select the correct stack (stacks
are usually named by their base layer) and click Finish. To set up a stack not listed, select the "Build Your
Own" option from the top of the list and click Next. For more information on how to set up a custom stack
see Creating and Removing a Custom Stack.
7. Click the Close button on the I/O Settings window.

2.2.6 CC-Link I/O Settings
The I/O Settings dialog is used to set the data rate for a CC-Link device.
1. Connect the CC-Link ComProbe® to an available USB port.
2. Start the analyzer.
3. Select I/O Settings from the Options menu on the Control Window.

Figure 2.2 - CC-Link I/O Settings Dialog
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4. Select a data rate from the drop-down list.
The options conform to standard CC-Link Baud Rates and include:
l

156 Kbps

l

625 Kbps

l

2.5 Mbps

l

5 Mbps

l

10 Mbps

5. Select Set to save the rate, Cancel to close the dialog without saving the rate, or Help to access the
electronic help file.

2.2.7 Saving Configurations
2.2.7.1 Saving a Configuration to a File
1. Set up your configuration on the I/O Settings window.
2. If a configuration is already open and you have altered it, go to the File menu and choose Save As;
otherwise, click on the Save Settings icon.
3. In the File name box, type a name for your configuration. You do not need to add an extension. the system
adds a .cfg extension automatically.
4. By default, the analyzer saves the configuration in the My Configurations directory. Choose a different
directory to save the configuration elsewhere. Click here to see how to change the default location for
configurations.
5. Click on Save.
If you make a new configuration and do not save it, the system asks you if you want to save your configuration
when you exit the program. If you want to save your configuration, choose Save and the Save File dialog box
appears. If you do not want to save your configuration, choose Cancel.

2.2.7.2 Opening a Saved Configuration File
1. Click on the Open Configuration icon, or choose Open Configuration from the File menu on the I/O Settings
dialog. If other configurations have been used recently, a menu listing the last four configurations used is
displayed.
2. Select a recent configuration file, or choose Open to load an unlisted configuration.
3. If you have saved your configurations in the default directory, they are listed in the window. Choose a
different directory if your configurations are saved elsewhere.
4. Select the configuration you want to use, and click on Open.
Configurations are saved with a .cfg extension, and are located in the C:\Program Files\Common Files\FTE\My
Configurations directory by default.
The name of the open configuration file is displayed at the top of the Set I/O Configuration window. If no
configuration file is open, "Untitled" is displayed.
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2.2.7.3 Saving I/O Settings configurations for RS-422/485 ComProbe
Saving a new configuration
If you have never saved the I/O Settings configuration before:
1. Make changes to the existing settings on the I/O Settings window.
2. Select Save from the File menu.
3. In the File name box, type a name for your configuration. You do not need to add an extension. the system
adds a .cfg extension automatically.
4. By default, the analyzer saves the configuration in the My Configurations directory. Choose a different
directory to save the configuration elsewhere. Click here to see how to change the default location for
configurations.
5. Click on Save.

2.2.7.4 Saving an existing configuration:
1. Make changes to the existing settings on the I/O Settings window.
2. Select Save from the File menu.

Saving a configuration with a new file name:
1. Make changes to the existing settings on the I/O Settings window.
2. Select Save As from the File menu.
3. In the File name box, type a name for your configuration. You do not need to add an extension. the system
adds a .cfg extension automatically.
4. By default, the analyzer saves the configuration in the My Configurations directory. Choose a different
directory to save the configuration elsewhere. Click here to see how to change the default location for
configurations.
5. Click on Save.
If you make a new configuration and do not save it, the system asks you if you want to save your configuration
when you exit the program. If you want to save your configuration, choose Save and the Save File dialog box
appears. If you do not want to save your configuration, choose Cancel.

2.2.8 NetDecoder - RS-232 ComProbe II Setup (USB Interface)
The NetDecoder analyzer is moving to the RS-232 ComProbe II, which is a USB flash drive sized interface to a PCs
USB port. With the ComProbe II you do not lose timing and control signal information.
Monitoring serial communications by NetDecoder analyzer is passive. Some serial analyzers receive the data from
one side of the circuit under test and retransmit it to the other side. NetDecoder does not work that way.
NetDecoder taps the circuit under test using a simple "Y" cable and there are no active electronics inserted into
the communication path.
To assist customers in tapping into Async RS-232 bus configurations, Frontline provides customers with a lot of
flexibility to address different monitoring situations. The RS-232 ComProbe II can be used directly in-line, or

xx

NetDecoder Async User Manual

Chapter 2 NetDecoderAsync Configuration Settings

TELEDYNE LECROY

connected via a combination of a provided Y-cable and/or an RS-232 extension cable. Some monitoring situations
may require a pair of 25-pin to 9-pin adapters.

Figure 2.3 - Monitoring Connection Option 1 – ComProbe II Only

Figure 2.4 - Monitoring Connection Option 2 – ComProbe II with Y-Cable

Figure 2.5 - Monitoring Connection Option 3 – ComProbe II with Y-Cable and Extension

2.2.9 Port Assignments: Adding and Changing
TCP and UDP are Transport layer protocols in the IP protocol suite. These transport layer protocols use ports to
establish communication between application layer protocols. For example, all Web traffic uses the HTTP
protocol. HTTP is an application layer protocol that uses the standard TCP/UDP port 80. The Internet Assigned
Numbers Authority (IANA) is responsible for maintaining the list of standard port numbers and their assignments.
For an up-to-date listing of all standard TCP/UDP port assignments, visit www.iana.org.
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When the analyzer reads a TCP, UDP or IPX packet, it infers the upper layer protocols by using pre-defined rules of
traversal. For example, if the packet has a TCP source or destination port number 80, then the upper layer
protocol is HTTP. These rules, which are built in to the software, determine the upper layers of the protocol stack
based on the source or destination port numbers in the packet. The built-in rules are based on the standard port
assignments. However, it is quite common to come across network systems in which upper layer protocols use
user-defined port numbers for both standard and custom protocols. In such cases, the analyzer users can tell the
software which port numbers are assigned to which protocols.
The analyzer autotraverses the stack from TCP, UDP and IPX based on the source or destination port number.
Many systems use user-defined port numbers for both standard and custom protocols. Here’s how to tell the
analyzer about a custom port assignment on the system you are monitoring.

Add a New Port Assignment
1. Choose Set Initial Decoder Parameters from the Options menu on the Control

window.

2. Click the TCP tab (or UDP or IPX for those protocols).
3. Choose the Single Port radio button
4. Enter the port number in the Port Number box.
5. In the Protocol drop-down list, choose the protocol to traverse to.
6. Click the Add button.
The system adds the new entry to the bottom of the port number list.

Modify an Existing Port Assignment
1. Choose Set Initial Decoder Parameters from the Options menu on the Control window.
2. Click the TCP tab (or UDP or IPX for those protocols).
3. Select (click on and highlight) the port assignment to modify.
4. Change the port number and/or choose the protocol to traverse to.
5. Select the Port Range radio button and specify the starting and ending port numbers. The range is
inclusive.
6. Click the Modify button.
The system displays the changes in port assignment.

Delete a Port Assignment
1. Choose Set Initial Decoder Parameters from the Options menu on the Control window.
2. Click the TCP tab (or UDP or IPX for those protocols).
3. Select (click on and highlight) the port assignment to delete.
4. Select Delete. The system deletes the port assignment.
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Move a Port Assignment
If you need to move an entry to ensure it is processed before or after another entry, select the entry in the list
and then click the Move Up or Move Down buttons.
Two considerations are:
l

The analyzer traverses an entry if either the source or destination port match.

l

The analyzer processes port number entries in order from top to bottom.

2.2.10 Using the Node Database Manager
Modbus TCP and ROC Plus over Ethernet protocols are designed around a Master-Slave communication model. In
order to correctly decode these protocols, the analyzer needs to know which IP addresses are Master devices and
which IP addresses are Slave devices. When the analyzer reads an IP packet from the wire, it automatically
decodes the IP addresses in the packet. However, it is not always possible to automatically determine whether a
particular IP address is a Master device or a Slave device. For such cases, the software provides an interface that
allows the user to define the IP addresses and node types (Master or Slave) of devices on their network. This
information about the nodes and their roles are stored in a node database.
Node Assignment: The process of designating a particular IP address as either Master or Slave device (on a
Modbus TCP or ROC Plus over Ethernet network) is called node assignment. For example, in a Modbus TCP
network, a node with the IP address 192.168.0.2 could be the Master device and a node with the IP addresses
192.168.0.8 could be the Slave device.
Templates: The software allows the user to define any number of IP Addresses and Node Type combinations and
save them in a Template for later use. The Template function lets you create multiple templates that contain
different node assignments. This capability allows the user to maintain individual templates for each network that
is being monitored.

2.2.10.1 Selecting and Applying a Node Assignment Template
This procedure demonstrates how to select and apply a Node Assignment Template. A template is a collection of
node assignments required to completely decode communications between multiple devices.
To learn more about node assignments and templates, go here.
1. Select Set Initial Decoder Parameters from the Options menu on the Control
Frame Display

window or the

window to display the Set Initial Decoder Parameters dialog.

2. Click on the tab of the desired protocol (Modbus TCP or ROC Plus over Ethernet).
The dialog displays the most recently selected template and the associated node assignments in the middle
of the dialog. If the template displayed is the desired template , then skip to step 4. If it is not, then
continue with step 3.
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3. If you want to select a different another template, then click the Open File icon and select the desired
template from the Popup list.

4. Click the OK button to apply the selected template and exit the Set Initial Decoder Parameters dialog.

2.2.10.2 Adding a Node Assignment Template
This procedure adds a Node Assignment Template to the system and saves it for later use. A template is a
collection of node assignments required to completely decode communications between multiple devices.
To learn more about node assignments and templates, go here.
1. Select Set Initial Decoder Parameters from the Options menu on the Control
Frame Display

window or the

window to display the Set Initial Decoder Parameters dialog.

2. Click on the tab of the desired protocol (Modbus TCP or ROC Plus over Ethernet).
The dialog displays the most recently selected template and the associated node assignments in the middle
of the dialog.
3. Click the Reset to Defaults

icon at the top of the dialog to clear the list.

4. Enter the IP Address in the IP Address text box.
5. Select the Node Type.
6. Click the Add button above the list.
The system displays the new node assignment in the list window. Repeat steps 4 and 5 until all desired
node assignments are added.
7. Click the Save icon at the top of the dialog to display the Template Manager dialog.
8. Enter a name for the new template
9. Click OK.
The system saves the template and closes the Template Manager dialog.
10. Click the OK button on the Set Initial Decoder Parameters dialog to apply the template and close the
dialog.

2.2.10.3 Deleting a Node Assignment Template
This procedure deletes a Node Assignment Template from the system. A template is a collection of node
assignments required to completely decode communications between multiple devices.
To learn more about node assignments and templates, go here.
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window or the

window to display the Set Initial Decoder Parameters dialog.

2. Click on the tab of the desired protocol (Modbus TCP or ROC Plus over Ethernet).
The dialog displays the most recently selected template and the associated node assignments in the middle
of the dialog.
3. Click the Delete Template

icon at the top of the dialog.

The system displays the Delete dialog with a list of saved templates.
4. Select (click on and highlight) the template marked for deletion
5. Click the Delete button on the Delete dialog.
The system removes the selected template from the list of saved templates.
6. Click the Ok button on the Delete dialog to complete the deletion process and close the Delete dialog.
7. Click the Ok button on the Set Initial Decoder Parameters dialog to apply the deletion and close the
dialog.

2.2.10.4 Adding a Node Assignment
This procedure adds one or more node assignments to an existing Node Assignment Template.
To learn more about node assignments and templates, go here.
1. Select Set Initial Decoder Parameters from the Options menu on the Control
Frame Display

window or the

window to display the Set Initial Decoder Parameters dialog.

2. Click on the tab of the desired protocol (Modbus TCP or ROC Plus over Ethernet).
The dialog displays the most recently selected template and the associated node assignments in the middle of the
dialog.
3. If you want to add the node assignment to a different another template, then click the Open File icon and
select the desired template from the popup list.

4. Enter the IP Address in the IP Address text box.
5. Select the Node Type.
6. Click the Add button above the list.
The system displays the new node assignment in the list window.
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7. Repeat steps 4, 5, and 6 until all desired node assignments are added.
8. Click the Save icon at the top of the dialog to display the Template Manager dialog.
9. Ensure that the name of the template is listed in the Name to Save Template As text box and click OK.
The system displays a dialog asking for confirmation of the change to the existing template.
10. Click the Yes button.
The system saves the new node assignment to the template and closes the Save As dialog.
11. Click the OK button on the Set Initial Decoder Parameters dialog to apply the template and close the
dialog.

2.2.10.5 Modifying a Node Assignment
This procedure modifies a node assignments to an existing Node Assignment Template.
To learn more about node assignments and templates, go here.
1. Select Set Initial Decoder Parameters from the Options menu on the Control
Frame Display

window or the

window to display the Set Initial Decoder Parameters dialog.

2. Click on the tab of the desired protocol (Modbus TCP or ROC Plus over Ethernet).
The dialog displays the most recently selected template and the associated node assignments in the middle
of the dialog.
3. If the node assignment you want to modify is in another template, then click the Open File icon and select
the desired template from the popup list.

4. Edit the IP Address in the IP Address text box and/or Select the Node Type.
5. Click the Modify button above the list.
The system displays the modified node assignment in the list window. Repeat step 4 until all desired node
assignments are modified.
6. Click the Save icon at the top of the dialog to display the Template Manager dialog.
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7. Ensure that the name of the template is listed in the Name to Save Template As text box and click OK.
The system displays a dialog asking for confirmation of the change to the existing template.
8. Click the Yes button.
The system saves the new node assignment to the template and closes the Save As dialog.
9. Click the OK button on the Set Initial Decoder Parameters dialog to apply the template and close the
dialog.

2.2.10.6 Deleting a Node Assignment
This procedure deletes a node assignments from an existing Node Assignment Template.
To learn more about node assignments and templates, go here.
1. Select Set Initial Decoder Parameters from the Options menu on the Control
Frame Display

window or the

window to display the Set Initial Decoder Parameters dialog.

2. Click on the tab of the desired protocol (Modbus TCP or ROC Plus over Ethernet).
The dialog displays the most recently selected template and the associated node assignments in the middle
of the dialog.
3. If the node assignment you want to delete is in another template, then click the Open File icon and select
the desired template from the Popup list.

4. Select (click on and highlight) the node assignment that you want to delete.
5. Click the Delete button above the list.
The system removes the selected node assignment from the list. Repeat steps 4 and 5 until all desired
node assignments are deleted.
6. Click the Save icon at the top of the dialog to display the Template Manager dialog.
7. Ensure that the name of the template is listed in the Name to Save Template As: text box and click
OK.
The system displays a dialog asking for confirmation of the change to the existing template.
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8. Click the Yes button.
The system saves the changes to the template and closes the Save As dialog.
9. Click the OK button on the Set Initial Decoder Parameters dialog to apply the template and close the
dialog.

2.2.11 Decoder Parameters
Some protocol decoders have user-defined parameters. These are protocols where some information cannot be
discovered by looking at the data and must be entered by the user in order for the decoder to correctly decode
the data. For example, such information might be a field where the length is either 3 or 4 bytes, and which length
is being used is a system option.
If you have decoders loaded which require decoder parameters, a window with one tab for every decoder that
requires parameters appears the first time the decoder is loaded.
For help on setting the parameters, click the Help button on each tab to get help information specific to that
decoder.
If you need to change the parameters later,
l

l

Choose Set Initial Decoder Parameters from the Options menu on the Control or Frame Display
windows.
Each entry in the Set Initial Decoder Parameters dialog takes effect from the beginning of the capture
onward or until redefined in the Set Subsequent Decoder Parameters dialog.

The Set Subsequent Decoder Parameters dialog allows the user to override an existing parameter at any
frame in the capture where the parameter is used.
If you have a parameter in effect and wish to change that parameter
l

Select the frame where the change should take effect

l

Select Set Subsequent Decoder Parameters from the Options menu, and make the needed changes.

l

Each entry in the Set Subsequent Decoder Parameters dialog takes effect from the specified frame onward or
until redefined in this dialog on a later frame.

If you do not have decoders loaded that require parameters, the menu item does not appear and you don't need
to worry about this feature.

2.2.11.1 Decoder Parameters for IEC 60870-5-101/-102/-104 Protocols
Note: These instructions apply to IEC 60870-5-101, IEC 60870-5-102 and IEC 60870-5-104
protocols only. IEC 60870-5-103 does not require any additional setup. For the remainder of
the setup instructions, IEC 60870-5-101, IEC 60870-5-102 and IEC 60870-5-104 are referred
to as simply IEC 60870.

Decoder Parameters
An interesting attribute of IEC 60870 is that the sizes of certain fields and the mode of transmission (balanced or
unbalanced) must be specified by the user. Such values are called decoder parameters. Decoder parameters are
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set by the user in the Decoder Parameters window. To open this window, choose Set Initial Decoder
Parameters from the Options menu on the Control window.
This window pops up automatically the first time that a capture file is loaded. The two tabs are titled "[protocol]
Application Layer" and "[protocol] Link Layer" where “[protocol]” refers to the specific protocol.

IEC 60870-5-101 & IEC 60870-5-104 Application Layer Parameters
l

l

l

"Does Originator Address exist?" specifies whether the application layer "Originator Address" field exists.
Permissible values are Yes and No. The field is 1-byte long if it exists.
"Size of the ASDU address field in bytes" specifies the number of bytes in the application layer "ASDU Address"
field. The permissible range is 1-2.
"Size of info object address" specifies the number of bytes in the application layer "Information Object
Address" field. The permissible range is 1-3.

IEC 60870-5-102 Application Layer Parameters
l

"Size of the Integrated Total address field in bytes" specifies the number of bytes in the application layer
"ASDU Address" field. The permissible range is 1-2.

IEC 60870-5-101 & IEC 60870-5-102 Link Layer Parameters
l

"Is transmission balanced?" specifies whether transmission is balanced or unbalanced.

l

Permissible values are Yes and No.

l

Balanced transmission mode is when two devices can both send at the same time.

l

Unbalanced transmission mode is when only one device can send at a time.

l

In the decode, three fields are affected by the transmission mode, and all are in the control byte of the link
layer.

o

Bit 8 is labeled "Direction" in balanced mode and "Reserved" in unbalanced mode.

o

Bit 6 for secondary-to-primary is labeled "Reserved" in balanced mode and "Access Demand for Class 1 Data
Transmission" in unbalanced mode. (For primary-to-secondary, the label is always "Frame Count Bit"
regardless of transmission mode.)

o

Bits 1-4 are always labeled "Function Code", but have different values for balanced mode versus unbalanced
mode.

l

"Size of the address field in bytes" specifies the number of bytes in the link layer "Address" field. The
permissible range for the protocol itself is 0-2 in balanced mode and 1-2 in unbalanced mode, but the dialog
accepts a range of 0-2 regardless of mode.

2.2.11.2 About ROC Decoder Parameters
There may be times when the context for decoding a frame is missing. For example, if the analyzer captured a
response frame, but did not capture the command frame, then the decode for the response may be incomplete.
The Set Initial Decoder Parameters dialog provides a means to supply the context for any frame. The system
allows the user to define any number of parameters and save them in Parameter Templates for later use.
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1. Select Set Initial Decoder Parameters from the Options menu on the Control
Frame Display

window or the

window to display the Set Initial Decoder Parameters dialog.

For more on setting parameters, see Selecting and Applying a ROC Parameter Template.
The Parameter Template function provides the capacity to create multiple Parameter Templates that contain
different parameters. This capability allows the user to maintain individual Parameter Templates for each Remote
Operations Controller (ROC) network monitored. Applying a Parameter Template containing only those
parameters necessary to decode transmissions particular to an individual network, enhances the efficiency of the
analyzer to decode data.
Each entry in the Set Initial Decoder Parameters dialog takes effect from the beginning of the capture onward or
until redefined in the Set Subsequent Decoder Parameters dialog.
The ROC Set Initial Decoder Parameters dialog requires the following user inputs to complete a parameters:
Device Address
l

Device Address Complete the following fields to identify the device address:
o

Unit - The 1-byte unit code of the individual device

o

Group - The 1-byte group code of the group that contains the individual device identified in the "Unit" field

o

Device - Type Select the device type from the following:
n

FlashPAC

n

FloBoss 2xx

n

FloBoss 407

n

FloBoss 503

n

FloBoss 504

n

RegFlo 2xx

n

ROC 809

n

ROCPAC

Sort and order the parameters list using the Sort Order and Sort Direction drop down fields at the top of the
dialog.
2.2.11.2.1 Adding a ROC Parameter Template
This procedure adds a Parameter Template to the system and saves it for later use. A Parameter Template is a
collection of parameters required to completely decode communications between multiple devices. To add a
parameter to an existing Parameter Template, see Adding a Parameter.
1. Select Set Initial Decoder Parameters from the Options menu on the Control
Frame Display

window or the

window to display the Set Initial Decoder Parameters dialog.

2. Click on the ROC tab.

xxx

NetDecoder Async User Manual

Chapter 2 NetDecoderAsync Configuration Settings

TELEDYNE LECROY

The dialog displays the most recently selected Parameter Template content in the list at the bottom of the
tab.
3. Click the Reset to Defaults icon at the top of the dialog to clear the list.
4. Enter the Device Address as follows:
l

l

l

Enter the 1-byte unit code of the individual device in the Unit field
Enter the 1-byte group code of the group that contains the individual device identified in the "Unit"
field in the Group field
Select the Device Type from the list

5. Click the Add button
The system displays the new parameter in the list at the bottom of the tab. Repeat steps 4 and 5 until all
desired parameters are added.
6. Click the Save icon at the top of the dialog to display the Save As dialog.
7. Enter a name for the new Parameter Template and click OK.
The system saves the Parameter Template and closes the Save As dialog.
8. Click OK button on the Set Initial Decoder Parameters dialog to apply the Parameter Template and
close the dialog.
2.2.11.2.2 Selecting and Applying a ROC Parameter Template
1. Select Set Initial Decoder Parameters from the Options menu on the Control
Frame Display

window or the

window to display the Set Initial Decoder Parameters dialog.

2. Click on the ROC tab
The dialog displays the content of the most recently selected Parameter template in the list at the bottom
of the tab. If the Parameter Template displayed is the desired Parameter Template , then skip to step 4. If it
is not, then continue with step 3.
3. Click the Open File icon at the top of the dialog and select the desired Parameter Template from the
popup list.
The system displays the content of the selected Parameter Template in the list at the bottom of the dialog.
4. Click the OK button to apply the selected Parameter Template and exit the Set Initial Decoder
Parameters dialog.

2.2.11.2.3 Deleting a ROC Parameter Template
1. Select Set Initial Decoder Parameters from the Options menu on the Control
Frame Display

window or the

window to display the Set Initial Decoder Parameters dialog.

2. Click on the ROC tab.
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The dialog displays the most recently selected Parameter Template content in the list at the bottom of the
tab.
3. Click the Delete icon at the top of the dialog.
The system displays Delete dialog with a list of saved Parameter Templates.
4. Select (click on and highlight) the Parameter Template marked for deletion and click the Delete button on
the Delete dialog.
5. The system removes the selected Parameter Template from the list of saved Parameter Templates.
6. Click the OK button on the Delete dialog to complete the deletion process and close the Delete dialog.
7. Click the OK button on the Set Initial Decoder Parameters dialog to apply the deletion and close the dialog.
2.2.11.2.4 Adding an ROC Parameter
This procedure adds one or more parameters to an existing Parameter Template. To create a new Parameter
Template, see Adding a Parameter Template.
1. Select Set Initial Decoder Parameters from the Options menu on the Control
Frame Display

window or the

window to display the Set Initial Decoder Parameters dialog.

2. Click on the ROC tab.
The dialog displays the most recently selected Parameter Template content in the list at the bottom of the
tab. If the parameter must reside in another Parameter Template, then click the Open File icon and select
the desired Parameter Template from the Popup list.
3. Enter the Device Address as follows:
l

l

l

Enter the 1-byte unit code of the individual device in the Unit field
Enter the 1-byte group code of the group that contains the individual device identified in the "Unit" field in the
Group field
Select the Device Type from the list
4. Click the Add button
The system displays the new parameter in the list. Repeat steps 3 and 4 until all desired parameters are
added.
5. Click the Save icon at the top of the dialog to display the Save As dialog.
6. Ensure that the name of the Parameter Template is listed in the Save As text box and click OK.
The system displays a dialog asking for confirmation of the change to the existing Parameter Template.
7. Click the Yes button.
The system saves the new parameter to the Parameter Template and closes the Save As dialog.
8. Click the OK button on the Set Initial Decoder Parameters dialog to apply the Parameter Template and
close the dialog.
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2.2.11.2.5 Editing a ROC Parameter
1. Select Set Initial Decoder Parameters from the Options menu on the Control

window or the

window to display the Set Initial Decoder Parameters dialog.

Frame Display
2. Click on the ROC tab.

The dialog displays the most recently selected Parameter Template content in the list at the bottom of the
tab. If the Parameter marked for edit resides in another Parameter Template, then click the Open File icon
and select the desired Parameter Template from the Popup list.
3. Double click to select the Parameter marked for edit from the list.
Double clicking the Connection Statement populates the edit fields.
4. Edit the values in the fields as needed.
5. Click the Modify button above the list
6. Click the Save icon at the top of the dialog to display the Save As dialog.
7. Ensure that the name of the Parameter Template is listed in the Save As text box and click OK.
The system displays a dialog asking for confirmation of the change to the existing Parameter Template.
8. Click the Yes button.
The system saves the new Parameter to the Parameter Template and closes the Save As dialog.
9. Click the OK button on the Set Initial Decoder Parameters dialog to apply the Parameter Template and
close the dialog.

2.2.11.2.6 Deleting a ROC Parameter
1. Select Set Initial Decoder Parameters from the Options menu on the Control
Frame Display

window or the

window to display the Set Initial Decoder Parameters dialog.

2. Click on the ROC tab.
The dialog displays the most recently selected Parameter Template content in the list at the bottom of the
tab. If the Parameter marked for edit resides in another Parameter Template, then click the Open File icon
and select the desired Parameter Template from the Popup list.
3. Select (click on and highlight) the Parameter marked for deletion from the Initial Connection list and
click the Delete button above the list
The system removes the selected Parameter from the list.
4. Click the Save icon at the top of the dialog to display the Save As dialog.
5. Ensure that the name of the Parameter Template is listed in the Save As text box and click OK.
The system displays a dialog asking for confirmation of the change to the existing Parameter Template.
6. Click the Yes button.
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The system saves the Parameter Template and closes the Save As dialog.
7. Click the OK button on the Set Initial Decoder Parameters dialog to apply the Parameter Template and
close the dialog.

2.2.12 CAN 2.0 Special Instructions
This section contains hardware and software setup information for using the Frontline NetDecoder to analyze CAN
2.0 networks.
This section contains the setup instructions for CAN 2.0 using the Molex SST-DN4-USB interface card.

2.2.12.1 CAN I/O Device Setup
CAN Device setup configures a specific Molex module to use for the capture.

Figure 2.6 - CAN Device Setup
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Table 2.1 - CAN I/O Device Setup Fields
Sections

Field

Use
Prescale
These
Settings
Prop Seg
Phase Segs

Description
This value is multiplied by the minimum time quantum of 125 nsec to
produce the time quantum.
This value is multiplied by the time quantum to produce the propagation time
segment that compensates for physical network delays.
This value is multiplied by the time quantum to produce phase buffer
segment 1 and phase buffer segment 2 that may be lengthened or shortened
to compensate for phase errors.
The nominal bit time is the sum of the synchronization segment (one time
quantum), propagation time segment, and phase buffer segments. The
nominal bit rate is the inverse of the nominal bit time.

Synchronization Each bit is sampled at the end of phase buffer segment 1. The
Jump Width
synchronization jump width is the number of time quanta by which phase
buffer segment 1 is lengthened, or phase buffer segment 2 shortened, to
resynchronize upon detection of a phase error.

With
this
device

Sample 3 times
per bit

When checked, this feature enables two additional samples to be taken, one
ahead of the normal sample point and one behind it to eliminate detection of
false bit values on noisy networks.

Device drop
down list

Select an SST-DN4-USB device from the list of aliases. See Adding SSTDN4-USB Card Alias on page lvi.

2.2.12.2 Capture Filter Toolbar
Toolbar Icons
Icon

Description
Clears the current filter settings
Loads a filter from disk
Saves the current filter to disk
Opens the Add Message dialog
Expands all nodes in the filter display
Collapses all nodes in the filter display

2.2.12.3 CAN I/O Capture Filter Settings
The CAN I/O Settings Capture Filter tab displays the CAN node IDs from which NetDecoder will capture data.
In this tab CAN IDs can be created, added, and deleted to configure a unique capture scenario. The displayed CAN
IDs is the current filter. The user must have prior knowledge of the network CAN node IDs.
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Figure 2.7 - CAN Filter Settings Tab
Tool

Icon

CAN Filter Toolbar Tools
Description

Create Filter

Deletes the currently displayed CAN IDs.

Load Filter

Loads a previously saved filter with the .csFilter file extension.

Save Filter

Saves the current filter to a Windows file with the .csFilter file extension.

Add CAN IDs

Adds one or more CAN IDs to the current filter. The range of IDs is 0x00 to 0xFF

Delete CAN
IDs

Delete one or more CAN IDs from the current filter. The range of IDs is 0x00 to
0xFF.

Delete
Selected

Delete the CAN ID selected in the current filter.
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Create Filter
1. Click on the Create Filter tool

. If the current filter has not been saved a warning will appear, otherwise

the filter displayed in the Capture the following: field is erased. This step must be followed with Load
Filter
or Add CAN ID
.

Load Filter
1. Click on the Load Filter tool

. If the current filter has not been saved a warning will appear, otherwise

the loaded filter will overwrite the currently displayed filter.

Save Filter
1. Click on the Save Filter tool

. A Windows Save As dialog will open.

2. Once the filter is saved, the filter will remain in the Capture in the following field.

Add CAN IDs
1. Click on the Add CAN IDs tool

. The ADD CAN IDs dialog opens.

Figure 2.8 - Add CAN IDs dialog
2. In the From (hex) field and the To (hex) field, enter a starting node and ending node value from 0x00 to
0xFF in ascending order from start to end. If you are entering only one node enter the same value into
both fields.
3. Enter a decimal number in the Every field to represent the ID interval. For example, entering "1" will add
every ID in the entered range, and entering 2 will enter every other ID beginning at the From (hex) field
ID, that is, 00, 02, 04,...0E from Add CAN IDs dialog on page xxxviii.
4. Click on OK and all the CAN IDs between and including the ID values in the From and Start fields are added
to the Capture in the following field.
5. If your filter will not include contiguous CAN IDs, repeat this process for various ranges, or use the Delete
CAN ID tool
or the Delete tool
after a contiguous range has been entered to deleted specific IDs.
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Delete CAN IDs
1. Click on the Delete CAN IDs tool

. The Delete CAN IDs dialog opens.

Figure 2.9 - Add CAN IDs dialog
2. In the From (hex) field and the To (hex) field, enter a starting node and ending node value from 0x00 to
0xFF in ascending order from start to end. If you are entering only one node enter the same value into
both fields.
3. Enter a decimal number in the Every field to represent the ID interval. For example, entering "1" will
delete every ID in the entered range, and entering 2 will enter every other ID beginning at the From
(hex) field ID.
4. Click on OK and all the CAN IDs between and including the ID values in the From and Start fields are
deleted from the Capture in the following field.

Figure 2.10 - Deleted Can IDs.
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Delete Selected
1. Click on a CAN ID in the current filter. Click on the Delete Selected tool

. The ID will be erased from the

filter list. Because the filter has changed you must save it with the same name or another name.

Using the Filter in a CAN capture
To use the filter in a CAN capture, you must first save the filter, then click on the OK button.
All of the CAN IDs in a filter are an inclusive capture. That is, data is captured only from those network nodes listed
in the filter and excludes all data from nodes not listed. In a very large network, creating an inclusive filter could
be demanding. The Exclude checkbox will make the CAN IDs in the filter exclude data from those node and
include data from all other nodes.

2.2.12.4 Adding SST-DN4-USB Card Alias
Card aliases are used by an application to access Molex DeviceNet scanner modules. Each DeviceNet channel that
exists in a system must be assigned a unique name.
1. From the Window Start, SST, DeviceNet Software Suite, DeviceNet Remote Diagnostics.
2. Click on the Config tab.

Figure 2.11 - DeviceNet Remote Diagnostics Config Tab.
3. Click on the Search USB Adapter button to locate the connected USB scanner.
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Figure 2.12 - DeviceNet Remote Diagnostics Search USB Adapter
4. In the Found Remote Scanners list click on the USB device, and click on the Add to Config button.
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Figure 2.13 - DeviceNet Remote Diagnostics Add to Config
5. The ADD USB Remote Scanner Serial dialog opens. In the Card Alias enter an alias for the
connected USB scanner. The alias can be any name. In this example, this is the second DN4-USB to be
configured.

Figure 2.14 - DeviceNet Remote Diagnostics Set Alias
Click the OK button when finished and the USB device is added to the Current Configuration list.
The SST-DN4-USB is now installed and named on your computer or system and is ready to be used to capute
DeviceNet data.

2.2.13 ControlNet Instructions for the 1784-PCC
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2.2.13.1 Capturing ControlNet Data
Before you begin, ensure that a 1784-PCC hardware interface card is connected to the analysis computer and that
it is connected to the node you wish to monitor.
1. Start the analyzer and select ControlNet from the Choose Protocol to Analyze dialog.
2. (Optional) Choose Hardware Settings from the Options menu on the Control window and check the
status of the 1784-PCC card.
3. Choose I/O Settings from the Options menu on the Control window and select the start and stop
triggers or times, and capture filters to use.
4. Once the start trigger (or time) is detected, data capture begins and continues until the stop trigger (or
time) is detected, or the buffer or file becomes full.

2.2.13.2 ControlNet I/O Settings
2.2.13.2.1 ControlNet Hardware Settings
The Hardware Settings display provides the current status of the installed 1784-PCC card in the following fields:
ControlNet Hardware Settings Fields
Filed
Sniffer
Hardware

Identifies the card
currently installed. If this
field is blank, then no
card is installed.

Memory
Address

Identifies the dual-port
memory address

IRQ
Number

Identifies the number of
the protocol analyzer
application

Card
Status

Indicates whether any
application has "locked"
the card

Application If the card status is
Using the "Locked", then this
Card
indicates the application
using the card.
Firmware
Version

Identifies the firmware
version of the card

The 1784-PCC card is also used by other applications such as RSLinx. Only one application can have access to the
1784-PCC card at a time. When one of these applications is running, it locks the card and prevents other
applications from accessing it.
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2.2.13.2.2 ControlNet I/O Settings
Use the I/O Settings

dialog to select a buffer size, set and apply start and stop times or triggers to the capture

session, and apply any capture filters to the data on the network. Selections made in the I/O Settings dialog are
persistent during the analyzer session, but revert to the defaults when the analyzer is shutdown and re-started.
The default settings are 32 Mbyte buffer size, no start or stop triggers selected, and no filters selected.
To Access the I/O Settings Dialog
1. Choose I/O Settings from the Options menu on the Control window.
2. Select a buffer size from the BUFFER SIZE list, or accept the default value.
3. If you want the capture to begin and end based on triggers, then select the start and stop triggers in the
START TRIGGERS and STOP TRIGGERS panes by checking the boxes to the left of the trigger definitions.
If the triggers you want to use are not in the list, then you must define them. See Defining and Maintaining
ControlNet Start and Stop Triggers
For more information on triggers see About Triggers
4. Select the filters you want to use in the CAPTURE FILTERS pane by checking the boxes to the left of
the filter definitions.
If the filters you want to use are not in the list, then you must define them. See Defining and Maintaining
ControlNet Capture Filters
5. Click the OK button at the bottom of the I/O Settings dialog, and start the analyzer.

2.2.13.2.3 Defining and Maintaining ControlNet Start and Stop Triggers
Start and Stop triggers are defined on the frame conditions.
See About Triggers for more information on making entries in the following dialogs.
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Defining a Start Trigger

Start Trigger Dialog
1. Choose I/O Settings from the Options menu on the Control window.
2. Click on the Add Start Conditions button to display the Set Start Trigger Conditions dialog.
3. Enter the Producer MAC ID in the MAC Frame section. If you do not enter a value or values in this
field, the full range (0-255) becomes the default value.
4. Select the Status in the MAC Frame Definition section. One or more of these statuses may be
selected, however, at least one must be selected. Good is the default.
5. Select the Type in the MAC Frame Definition section. One or more of these types may be selected,
however, at least one must be selected. Scheduled and Unscheduled is the default selections.
6. In the L-Packet section, enter the Prod/Cons MAC ID that you want to trigger in each LPacket . If you
do not enter a value or values in this field, the full range (0-255) becomes the default value.
7. Click the OK button.
The Set Start Trigger Conditions dialog closes and the new start trigger definition appears in the START
TRIGGERS list on the I/O Settings dialog. This start trigger can now be selected and applied to the next capture
session.
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Defining a Stop Trigger

Stop Trigger Dialog
1. Choose I/O Settings from the Options menu on the Control window.
2. Click on the Add button to the right of the STOP TRIGGERS pane in the middle of the I/O Settings
dialog to display the Set Stop Trigger Conditions dialog.
3. Enter the Producer MAC ID in the MAC Frame section. If you do not enter a value or values in this
field, the full range (0-255) becomes the default value.
4. Select the Status in the MAC Frame Definition section. One or more of these statuses may be
selected, however, at least one must be selected. Good is the default.
5. Select the Type in the MAC Frame Definition section. One or more of these types may be selected,
however at least one must be selected. Scheduled and Unscheduled is the default selections.
6. In the L-Packet section, enter the Prod/Cons MAC ID that you want to trigger in each LPacket . If you
do not enter a value or values in this field, the full range (0-255) becomes the default value.
7. Click the OK button.
The Set Stop Trigger Conditions dialog closes and the new stop trigger definition appears in the STOP
TRIGGERS list on the I/O Settings dialog. This stop trigger can now be selected and applied to the next capture
session.
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Edit Trigger Definitions
1. Choose I/O Settings from the Options menu on the Control window.
2. Highlight the trigger you want to change in the list pane.
3. Click the Edit button to the right of the list pane with the highlighted trigger definition.
The system displays the appropriate edit screen with the definition of the highlighted trigger.
4. Edit the fields you want to change and click the OK button.

Deleting Trigger Definitions
1. Choose I/O Settings from the Options menu on the Control window.
2. Highlight the trigger you want to change in the list pane.
3. Click the Delete button to the right of the list pane with the highlighted trigger definition.
The system deletes the highlighted trigger from the list.

2.2.13.2.4 About Triggers
In this topic we define in greater detail the inputs to the Start and Stop triggers dialogs. Except for the dialog titles,
the Start and Stop trigger dialogs have identical fields and the range of inputs are identical.
Start and Stop triggers are defined on the frame conditions. Selections for frame parameters on which to trigger
are outlined in the following table.
Start/Stop Trigger Settings
Setting
Producer
MAC ID1

Description
A single producer ID

Value/Selection
Example: "123"
range 0-255

A group of IDs, separated by a hyphen

Example: "2-88"
Values in the
range of 0-255

Multiple IDs separated by a semicolon

Example::
"2;9;27"
Values in the
range of 0-255

A group and multiple IDs

Example: "27;3;8"
Values in the
range of 0-255
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Start/Stop Trigger Settings (continued)
Setting

Description

Value/Selection

Status

A frame correctly received by the Traffic Analyzer tool.

Good

Select all
that apply

The Traffic Analyzer tool has detected a problem with this frame (e.g. a
CRC problem).

Bad

A frame without any data.

Null

Type
Select all
that apply

Every scheduled node in sequential order is guaranteed one opportunity Scheduled
to transmit. Information that is time-critical is sent during the scheduled
part of the interval. The bandwidth is reserved in advance to support
real time data transfers. Real time data transfers include:
l

real time control data (I/O updates)

l

analog data

l

peer to peer interlocking

All nodes transmit on a rotating basis in sequential order. This rotation
repeats until the time allocated for the unscheduled portion is used up.
The amount of time available for the unscheduled portion is determined
by the traffic load of the scheduled portion. ControlNet guarantees at
least one node will have the opportunity to transmit unscheduled data
every interval. The starting node for each NUT rotates to guarantee
each node will have an unscheduled transmit time. The remaining
bandwidth supports non time-critical data transfers. Non time-critical
data transfers include:
l

connection establishment

l

peer to peer messaging

l

programming (uploads and downloads)

The node with the lowest MAC ID (node address) assumes the moderator
role. The moderator frame is transmitted to keep the other nodes
synchronized. This moderator frame is sent in the guardband.
Prod/Cons A single producer/consumer ID
MAC ID1, 2
A group of IDs, separated by a hyphen

Unscheduled

Moderator

Example: "123"
range 0-255
Example: "2-88"
Values in the
range of 0-255

A group and multiple IDs

Example: "27;3;8"
Values in the
range of 0-255
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Start/Stop Trigger Settings (continued)

Setting

Description

Value/Selection

1. If you do not enter a value in this field, the full range (0-255) becomes the default value.
2. LPacket:
a. Generic = Produccter Consumer ID
b. Fixed = Destination ID
c. Broadcast ID = 255

2.2.13.2.5 Defining and Maintaining ControlNet Capture Filters
Capture filtering allows frames that meet a specified condition to pass from the network to the buffer. If the
frame does not satisfy the filter criteria, it is thrown away. Data that is filtered out using a capture filter cannot be
recovered. For example, you may set up a capture filter that only allows frames with a source MAC ID of 10 to
pass from the network to the collection buffer. Frames from all source MAC IDs other than 10 are discarded.
After capturing frame data (filtered or unfiltered), the buffer or file can be filtered further by using a display filter.
A display filter looks at frames that have already been captured. It looks at every frame in the capture buffer or
file and displays those that match the filter criteria. Frames that do not match the filter criteria are not displayed.
Unlike a capture filter, where data that does not match is thrown away, all the data is kept when using a display
filter. The filter just displays a subset of the data. Multiple display filters can be used simultaneously, and different
windows can be displaying data using different filters.

2.2.13.3 ControlNet Statistics: Network Monitoring
The network information corresponds to dynamic data collection over the ControlNet network. The following
information is contained within the Network Information dialog box:
l

l

Network Grid - displays the active nodes on the network.
Network Attributes - the network attribute commands analyze the current moderator frames and display the
following attributes:

l

Network Update Time (ms)

l

Scheduled Max. Node

l

Unscheduled Max. Node

l

Slot Time (ms)

l

Blanking Time

l

Guard Band Start (ms)

l

Guard Band Center (ms)

l

Guard Band Prestart (ms)

l

Interval Modulus (NUTs)
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Additional network information that does not come from the moderator. This information corresponds to
Scheduled and Unscheduled elements, for which the following information is provided:
Scheduled information in the Interval Modulus average bandwidth used and maximum bandwidth used
Average available unscheduled information and average used unscheduled information in the Interval
Modulus, both expressed in bytes per second

2.2.14 ControlNet Instructions for 1784-U2CN
2.2.14.1 ControlNet 1784-U2CN Hardware Settings
The 1784-U2CN Hardware Settings dialog allows you to
select a device to sniff/scan. You access the Hardware
Settings dialog by selecting Hardware Settings from the
Options menu on the NetDecoder Control window.
Frontline software automatically scans and identifies all the
1784-U2CN devices plugged into the PC. These devices,
identified by their Serial Numbers, are displayed in the
drop-down list of Available Sniffers.
1. Select a device from the drop-down list
2. Click the OK button.
Selecting Cancel overrides all the selections and returns the user to the Control window.
Note: You can select Refresh List to update the list of devices.
2.2.14.2 ControlNet 1784-U2CN I/O Settings

The ControlNet 1784-U2CN I/O Settings Dialog provides the user options for setting Capture Filters, as well
as START and STOP triggers.
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CAPTURE Filters
While capturing ControlNet traffic, the I/O Settings Dialog in the 1784-U2CN indicates the MAC Frame Status and
the MAC Frame Type of each of the captured frames.
Table 2.2 - Capture Filter Settings
Setting
MAC
Frame
Status

Description
A frame correctly received by the Traffic Analyzer tool.

Good (default

The Traffic Analyzer tool has detected a problem with this frame (e.g.
a CRC problem).

Bad

Select all that A frame without any data.
apply
Accepting Null frames can cause loss of other data frames.

l

Value/Selection

Null
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Table 2.2 - Capture Filter Settings (continued)
Setting

Description

MAC
Frame
Type

Every scheduled node in sequential order is guaranteed one
opportunity to transmit. Information that is time-critical is sent during
the scheduled part of the interval. The bandwidth is reserved in
advance to support real time data transfers. Real time data transfers
Select all that include:
apply
l
real time control data (I/O updates)
l

analog data

l

peer to peer interlocking

Value/Selection
Scheduled
(default)

All nodes transmit on a rotating basis in sequential order. This rotation Unscheduled
repeats until the time allocated for the unscheduled portion is used up. (default)
The amount of time available for the unscheduled portion is
determined by the traffic load of the scheduled portion. ControlNet
guarantees at least one node will have the opportunity to transmit
unscheduled data every interval. The starting node for each NUT
rotates to guarantee each node will have an unscheduled transmit
time. The remaining bandwidth supports non time-critical data
transfers. Non time-critical data transfers include:
l

connection establishment

l

peer to peer messaging

l

programming (uploads and downloads)

The node with the lowest MAC ID (node address) assumes the moderator Moderator
role. The moderator frame is transmitted to keep the other nodes
synchronized. This moderator frame is sent in the guardband.
Disable
You can also choose to disable timestamps. When you activates
Timestamps Disable Time Stamps, the values in the place holders for the
timestamps are random and the Frame Display will show incorrect
values for the timestamps. You should ignore those values if
timestamping is disabled.

Checked
disables
timestamps.
Unchecked is
default.

START and STOP Triggers
A START Triggers is defined as the event that starts data capture. The capture engine ignores all frames prior to
the specified start trigger. All subsequent frames are captured until either a user-defined stop trigger occurs or
the user manually stops data capture.
A STOP Triggers is defined as the event that stops data capture. The capture engine stops capturing all frames
after the specified stop trigger is reached.
You can define the START Triggers and STOP Triggers according to the contents of the source and
destination MAC IDs in the ControlNet frame.
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Table 2.3 - START/STOP Triggers Settings
Trigger

MAC Frame ID1

Description
A single producer ID

and
Prod/Cons MAC ID1

Setting
Example: "123"
range 0-255

A group of IDs, separated by a
hyphen

Example: "2-88"

Multiple IDs separated by a
semicolon

Example::
"2;9;27"

Values in the
range of 0-255

Values in the
range of 0-255
A group and multiple IDs

Example: "27;3;8"
Values in the
range of 0-255

1. If you do not enter a value in this field, the full range (0-255) becomes the
default value.
The Start/Stop Clear Triggers buttons will remove all ID values.

2.2.15 Data Highway Plus Special Instructions
2.2.15.1 Data Highway Plus Setup for DL3500-DHM
The DL3500-DHM (Data Highway Monitor) adapter for use with NetDecoder is a special version of the product that
was developed for Frontline Test Equipment, Inc. It includes firmware that allows the unit to promiscuously
capture the data passing on a Data Highway Plus (DH+) network. The unit supports capturing data at 57.6k, 115.2k
or 230.4kbps. The DL3500-DHM hardware automatically senses the DH+ data rate and set the serial port interface
to twice the DH+ rate. Apply power to the DL3500-DHM and then connect the network cable in order for the unit
to automatically sense the network data rate.
There are two basic steps to beginning data capture:
l

Connecting the DL3500-DHM hardware to the DH+ circuit and the PC running NetDecoder

l

Configuring the I/O Settings in NetDecoder.

The following items are included with the DL3500-DHM:
l

DL3500-DHM hardware

l

Power supply

l

9-pin cable

You have to acquire a Blue Hose 3-wire cable.

lii

NetDecoder Async User Manual

Chapter 2 NetDecoderAsync Configuration Settings

TELEDYNE LECROY

Connecting the DL3500-DHM
1. If you have not already done so, install the NetDecoder software and decoders on the PC you use to
monitor the DH+ network.
2. Obtain a Blue Hose 3-wire cable. Attach one end of the Blue Hose to the DL3500-DHM’s CHA Network
interface and then attach the other end to the DH+ Port on one of the PLCs located on the DH+ network
you wish to monitor.
3. Attach one end of the 9 pin cable supplied with the DL3500-DHM to the CHB/RS-232 interface on the
DL3500-DHM and then attach the other end to a serial port on the PC you are running the NetDecoder
software on.
4. Wire-up the power supply to the DL3500-DHM and plug it into a wall outlet.

Configuring NetDecoder
1. If you have not already done so, connect the DL3500-DHM hardware.
2. Start NetDecoder and select from the Rockwell Allen Bradley folder.
3. Choose I/O Settings from the Options menu on the Control window, or click the I/O Settings icon to
open the I/O Settings window.
4. In the Baud box, set the rate to twice the rate of the DH+ network. This is the rate at which data is
received from the DL3500-DHM. The default value is 115.2K.
In the DH+ Network box, set the rate to match the rate of the DH+ network. This network rate is used for
calculation of some statistics in NetDecoder. The default value is 57.6k.
See the online Help for information on the other settings in the I/O Settings window and how to save the
configuration.
Now you are ready to capture data with NetDecoder! See the accompanying Quick Start Guide or the online Help
to learn how to capture and review data using the NetDecoder software.
Changes to Header Bytes as a Result of Using the DL3500-DHM
The DL3500-DHM changes some of the data seen on the Data Highway Plus network in order to convert it to a
form Frontline can use.
First, the DL3500-DHM converts the data from synchronous to asynchronous. Second, it formats the frame as a
DF1 full duplex with CRC message, which means it strips off 5 bytes from the original message and adds 6 DF1
bytes. A 0x1002 is placed at the beginning of the message, and a 0x1003, followed by two CRC bytes, is placed at
the end. The CRC is an error check between the DL3000-DHM and Frontline only, NOT an error check between
any DH+ devices or the DH+ network and Frontline.

2.2.15.2 1784-U2DHP Special Instructions
2.2.15.2.1 Data Highway Plus Set up Information for the 1784-U2DHP
In order to use the 1784-U2DHP with NetDecoder, you need to perform the following steps:
l

Install the 1784-U2DHP on your analysis PC

l

Update the firmware version on the 1784-U2DHP to version 1.7
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l

Shutdown RS-Linx completely before using NetDecoder

l

Configure Hardware Settings in NetDecoder

Install the 1784-U2DHP on your analysis PC
Please follow the installation instructions provided by Rockwell Automation to install your 1784-U2DHP. An
instruction booklet is included in your 1784-U2DHP shipping box. The instructions are also available on Rockwell
Automation’s website: http://literature.rockwellautomation.com/idc/groups/literature/documents/in/1784in045_-en-p.pdf

Update the firmware version on the 1784-U2DHP to version 1.7
1. If you bought the 1784-U2DHP from Frontline, then the device is already updated with firmware version
1.7. You do not need to do anything else.
2. If you bought your 1784-U2DHP from some other source, then you must update your firmware.
a. Go to http://compatibility.rockwellautomation.com/Pages/MultiProductDownload.aspx?crumb=112 and
download the ControlFlash upgrade kit from Rockwell Automation.
b. Extract the zip file and run ‘ControlFLASH.msi’. This will install the ControlFLASH utility.
c. Run ControlFLASH and follow instructions on the wizard to update your firmware to version 1.7.

Shutdown RS-Linx completely before running NetDecoder
The 1784-U2DHP installs itself as a serial port (COM port) on your PC. To prevent port conflict, RS-Linx must be
completely shut down before starting NetDecoder. It is not enough to simply close the RS-Linx window. Right click
on the RS-Linx icon on your system tray and select: Shutdown RS-Linx.
Note: To identify the COM port number used by the 1784-U2DHP, open your PC’s Device
Manager and look under the Ports (COM & LPT) section.

Configure Hardware Settings in NetDecoder
1. Start NetDecoder.
2. In the start-up wizard, choose Rockwell Allen Bradley -> Data Highway Plus using 1784-U2DHP.
3. Click Run.
This brings up the NetDecoder Control Window.
4. Select Hardware Settings in the Options menu.
5. Enter the correct COM Port number and the data rate.
6. Click OK.
You are now set to use the NetDecoder analyzer software with the 1784-U2DHP.
2.2.15.2.2 1784-U2DHP Hardware Settings
The 1784-U2DHP installs itself as a Serial COM Port on your PC. The Hardware Settings dialog allows you to set the
COM Port number and the data rate that your device is using.
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Note: Before starting data capture with the 1784-U2DHP, you must: 1) Shut down RSLinx,
and 2) Set the correct COM Port number in this dialog.

Access the U2DHP Hardware Settings dialog by selecting
Hardware Settings from the Options menu on the
NetDecoder Control window.

There are two values you have to set: COM Port Number and
Data Rate.
To identify the COM port number, open your PC’s Device
Manager and look under the “Ports (COM & LPT)” section. Enter
that number in this dialog. If the correct number is not set, then
the data capture fails because NetDecoder will not be able to read the right data.
DH+ can run at baud rates of 57.6K, 115.2K or 230.4K. The 1784-U2DHP has a knob to set the data rate. Make
sure that the setting on your 1784-U2DHP matches your DH+ networks data rate. Then choose the right value in
the drop down menu on the Hardware Settings dialog.
1. Enter the U2DHPCOM Por Number .
2. Select a DH Plus Data Rate from the drop-down list.
3. Select OK to accept the values and close the dialog or Cancel to disregard the settings and close the
dialog.

2.2.15.2.3 DH Plus 1784-U2DHP I/O Settings
The DH Plus analyzer, using the 1784-U2DHP, allows users to select what type of packets are captured. This type of
filtering eliminates capturing unnecessary frames and allows the user to quickly pin-point the source of the
network problem. You select which frames to capture using the I/O settings dialog.
You access the I/O Settings dialog by selecting IO Settings
from the Options menu on the NetDecoder Control
window.
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Select the kind of DH+ frames you need to capture by clicking the appropriate check boxes.
l

If more than one box is checked, then the selection is treated as a logical AND condition.

l

The default setting is to capture all traffic.

l

If none of the items are checked on the dialog, the program defaults to a ‘capture-all’ state.

2. Select OK to accept the values and close the dialog or Cancel to disregard the settings and close the
dialog.

2.2.16 DeviceNet Instructions for the Woodhead SST
2.2.16.1 Software and Driver installation
Download the Molex software and driver from
http://www.molex.com/molex/mysst/searchBrad.action?partnumber=SST-DN4-USB. Download version 13.10 or
higher.
Follow the manufacturer's instructions to install the software and drivers.

2.2.16.2 Hardware Setup
1. Connect the Molex SST-DN4-USB module to the USB TypeB connector on the module's cable.
Note: The DeviceNet software should be installed prior to connecting the interface
module on the computer.
2. Connect the other end of the USB cable to a High-Speed USB 2.0 Type A port on the host computer.
3. Connect the Molex SST-DN4-USB module to a DeviceNet network.

2.2.16.3 SST Interface Card Setup to Capture DeviceNet Data
To capture DeviceNet data using the Frontline NetDecoder, the DeviceNet I/O must be configured followed by
setting DeviceNet capture filters.
Note: You must complete Software and Driver installation on page lvi before starting this
procedure.

2.2.16.3.1 Adding SST-DN4-USB Card Alias
Card aliases are used by an application to access Molex DeviceNet scanner modules. Each DeviceNet channel that
exists in a system must be assigned a unique name.
1. From the Window Start, SST, DeviceNet Software Suite, DeviceNet Remote Diagnostics.
2. Click on the Config tab.
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Figure 2.15 - DeviceNet Remote Diagnostics Config Tab.
3. Click on the Search USB Adapter button to locate the connected USB scanner.
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Figure 2.16 - DeviceNet Remote Diagnostics Search USB Adapter
4. In the Found Remote Scanners list click on the USB device, and click on the Add to Config button.
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Figure 2.17 - DeviceNet Remote Diagnostics Add to Config
5. The ADD USB Remote Scanner Serial dialog opens. In the Card Alias enter an alias for the
connected USB scanner. The alias can be any name. In this example, this is the second DN4-USB to be
configured.

Figure 2.18 - DeviceNet Remote Diagnostics Set Alias
Click the OK button when finished and the USB device is added to the Current Configuration list.
The SST-DN4-USB is now installed and named on your computer or system and is ready to be used to capute
DeviceNet data.
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2.2.16.3.2 NetDecoder DeviceNet Capture Settings
1. If the DeviceNet I/O Settings dialog is already open proceed to step 2, otherwise, from the Windows
Start select All Programs, Frontline NetDecoder <version#>, Frontline NetDecoder.

Figure 2.19 - Choose the DeviceNet (Molex) Protocol
a. In the Choose Protocol to Analyze, select ODVA (ControlNet, DeviceNet, EtherNet/IP).
b. Select DeviceNet (Molex)and then click the Run button.
c. Then choose Hardware Settings from the Options menu on the Control window.
2. Then choose Hardware Settings from the Options menu on the Control window.

Figure 2.20 - Device Net Capture Control Window
3. In the DevicNet I/O Settings dialog, select the Capture Filter tab.
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s
Figure 2.21 - NetDecoder DeviceNet I/O Settings Capture Filter Tab
4. Filters are defined as the combination of a node identifier and the messages to incude with that node.
Filters are created in the Node and Conversation: section of the Capture Filter Tab. In this section the
nodes are defined in the Client MAC and Server MAC and the messages for thos nodes is set in the check
boxes.

Figure 2.22 - DeviceNet I/O Settings Node and Conversation Section
Client MAC - When a number is added to this box, messages associated witht he client side of the
conversation are added for this MAC ID. In Figure 1.4 on page 1, node 0 is selected for the Client MAC. if
the node box is empty Client MAC is not included in the filter.
Server MAC - When a number is added to this box, messages associated with the server side of the
conversation are added for this MAC ID. In Figure 1.4 on page 1, node 54 is selected for the Server MAC.
if the node box is empty Server MAC is not included in the filter.
Messages to include in the conversation are listed below the Client and ServerMACs. The group of
messages can have two states.
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l

All boxes unchecked: All messages are include in the node conversation.

l

Some boxes checked: Only the checked messages are included int he node conversation.

If the Offline Conn. Set is checked Group 4 messages are included in the filter but there is no associated
MAC.
To add, delete, or change a filter:
l

Add: To add the node and conversation filter selection to the DeviceNet I/O Settings click on the
button.

l

Delete: To delete or remove the node and conversation filter from the DeviceNet I/O Settings click on
the
button, or clidk on the node in the Capture the following: pane and click ont he the
button.

l

Change: Delete the filter, then change the node and conversation settings, and add the new filter.

To exclude certain messages from the conversation (a NOT function), set the note and conversation as
described in previous steps, and check the
box, then click the
button.
5. Once the node and conversation filters are set , click on the Save filter icon

in the toolbar. A

Windows Save As dialog opens. Set a filter file name and location and click Save. Click on the Capture
FilterOK button. Refer to Capture Filter Toolbar below.
The NetDecoder is now ready to capture and analyze network data using the SST-DN4-USB scanner.

2.2.16.3.2.1 Capture Filter Toolbar
Toolbar Icons
Icon

Description
Clears the current filter settings
Loads a filter from disk
Saves the current filter to disk
Opens the Add Message dialog
Expands all nodes in the filter display
Collapses all nodes in the filter display

2.2.17 DeviceNet Using Rockwell Automation 1784-U2DN
NetDecoder also supports Rockwell Automation’s 1784-U2DN DeviceNet interface. The 1784-U2DN interfaces to
the host computer through a USB port. You can analyze your DeviceNet network using the 1784-U2DN interface.
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Refer to Rockwell Automation’s documentation for installing the 1784-U2DN. The instructions may be
downloaded from Rockwell Automation’s online document library. There are no additional installation instructions
for using the 1784-U2DN as the sniffer interface.

2.2.17.1 DeviceNet Hardware Settings
The Hardware Settings dialog allows you to select a device to sniff/scan. You access the 1784-U2DN Hardware
Settings dialog by selecting Hardware Settings from the Options menu on the NetDecoder Control window.

Figure 2.23 - 1784-U2DN Hardware Settings
Frontline NetDecoder software automatically scans and identifies all the 1784-U2DN devices plugged into the host
computer. These devices, identified by their serial numbers, are displayed in the drop-down list of Available
Sniffers.
1. Select a device from the Available Sniffers drop-down list.
2. Click the OK button.
Clicking the Cancel button overrides all the selections and returns the user to the Control window.
Click on the Refresh List button to update the list of connected devices.
For additional information about the 1784-U2DN device, please refer to the documentation from Rockwell
Automation (RA). The relevant RA document numbers are:
l

Publication: 1784-IN046

l

MM (PN): PN-25191

l

DIR: 10000017341/PUB

l

Knowledge Base Tech Note: http://www.rockwellautomation.com/knowledgebase/ , ID 53280.

2.2.17.2 START and STOP Triggers for the 1784-U2DN Interface
NetDecoder allows you to define START and STOPTriggers while using the 1784-U2DN interface module. The
triggers can be accessed through the NetDecoder Control window Options menu I/O Settings.
The user defines the START and STOPTriggers according to the contents of the Controller Area Network
(CAN) Identifier field in the DeviceNet frame. The CAN ID of a DeviceNet frame consists of three parts: the Group
Number, the MAC ID and the Message ID.
l

A START Trigger is defined as the event that starts data capture. The capture engine ignores all DeviceNet
frames prior to the enabling of the specified START trigger. All subsequent frames are captured until either a
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user-defined STOP Trigger fires or the user manually stops data capture.
l

A STOP Trigger is defined as the event that stops data capture. The capture engine stops capturing all
frames after the specified STOP Trigger event is enabled.

The START or STOPTrigger is enabled when an incoming DeviceNet frame has a CAN ID value equal to the
value in the Simple or Compound trigger. If user has defined multiple CAN IDs, then the condition is met if the
CAN ID of the incoming frame matches any one of the defined IDs. If the user enters a blank field in the trigger
dialog, then that implies that the trigger condition is met on any value of CAN ID.
In the case of a START Trigger, the particular frame matching the condition will be the first frame in the
capture and all subsequent frames will be captured. In the case of a STOP Trigger, the particular frame
matching the condition will be the last frame in that capture session.
The user can define and store multiple START or STOPTriggers. The triggers are displayed in the list control
boxes shown in Figure 1.1 on page 1. Though multiple triggers can be created and saved, only a single set of
START or STOPTriggers can be selected at a time.

Figure 2.24 - NetDecoder 1784-U2DN I/O Settings
The triggers are saved in a NetDecoder .ini file. The saved triggers appear in the I/O Settings dialog the next time
the application is opened.
The I/O Settings option is not available during the middle of a data capture. Only when the data capture is stopped,
the user will be able to select the I/O settings menu and bring up the triggers.

2.2.17.2.1 Adding Simple Start/Stop Triggers
The user can add a new set of START or STOPTriggers by clicking on the Add button to the right of the
triggers control boxes (See 2.2.17.2 on the previous page). Clicking the Add button opens the Set Start/Stop
Trigger Conditions dialog. The process for creating a Start Trigger or a Stop Trigger is identical.
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Figure 2.25 - Example: Set START Trigger Conditions
To create a simple start trigger, for example,
1. Select the Simple CAN ID Trigger radio button. Only the Simple CAN ID Trigger Definition
section is active.
2. In the CAN ID(s) field enter CAN IDs formatted using the following rules:
l

All values are hexadecimal.

l

Value range is 0x000 to 0x7FF.

l

Enter a single value, such as 12, or

l

Enter multiple values separated by a semicolon, such as 34;12;AB;fc;;2, or

l

Enter a range of values, such as 12-29, or

l

Enter a combination of individual values and ranges, such as 12;34;56-7a;1.

3. Click the OK button when finished.
If all the trigger values are valid, then the values are stored in the list control box on the I/O Settings dialog. The
last trigger created is shown at the bottom of the list.
Clicking on the Cancel button overrides all the CAN IDs and returns the user to the I/O Settings dialog.
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2.2.17.2.2 Adding Compound Start/Stop Triggers
The Compound CAN ID Trigger option allows you to define triggers based on the exact values of group
numbers, MAC IDs and Message IDs. There are four groups to choose from. Figure 1.1 on page 1, taken from the
official DeviceNet specification, shows how the 11 bits of the CAN ID are used by the DeviceNet messaging
protocol and the values in the four groups.

Figure 2.26 - CAN ID Groups

The process for setting a START Trigger or a STOP Trigger is identical.

Figure 2.27 - Example, Set Compound Start Trigger Conditions
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To set up a compound trigger:
1. Select the Compound CAN ID Trigger radio button. Only the Compound CAN ID Trigger
Definition section is active.
2. In the Str/Dst ID(s) field, enter the source destination MAC ID(s) using the following rules.
l

Values are decimal.

l

Value range is from 0 to 63.

l

Enter a single value,such as 12, or

l

Enter multiple values separated by a semi-colon, such as 34;12;22;34;61, or

l

Enter a range of values, such as 12-28, or

l

Enter a combination of individual values and ranges, such as 12;34;56-59;61.

3. Select a radio button for Group 1, Group 2, Group 3, or Group 4. The messages associated with the
selected group will appear in the Message IDs field. Check one or more messages to associate with the
trigger. The compound trigger will activate when one of the messages associated with the MAC ID(s)
appears on the network, that is the when messageID1 OR messageID2 OR messageID3 OR ...nessageIDn
occurs.

Figure 2.28 - Example: Compound Trigger Group Message Selection
When the compound filter is completed, click on the OK button. The I/O Settings dialog appears with the
Trigger Type field = Compound, Group field = Group Name, and MAC Id(s) = Source/Destination settings.
Not all columns will have data. For example, Group = Four will not have a MAC ID field value.
Clicking on the Cancel button overrides all the selection and returns the user to the I/O Settings dialog.

2.2.17.2.3 Editing a Trigger
To edit a simple or compound trigger:
1. From the 1784-U2DN I/O Settings dialog do one of the following actions:
l

Double-click on the trigger in the trigger list control box.

l

Select the trigger in the list control box and click on the Edit button.

The Set START/STOP Trigger Conditions dialog opens populated with the selected trigger's stored
values.
2. Make changes to the trigger.
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3. When changes are complete, click on the OK button. If all the changes are valid, the new trigger values
are stored in the same position in the 1784-U2DN I/O Settings dialog trigger list control box. If the
values are not valid, an error message appears. Selecting Cancel overrides any changes and returns to the
1784-U2DN I/O Settings dialog and the selected filters appears unchanged.

2.2.17.2.4 Delete a Trigger
To delete a simple or compound filter:
1. From the 1784-U2DN I/O Settings dialog, select the trigger in t he list control box and click on the
Delete button.
2. The trigger is deleted from the list.

2.2.17.2.5 Selecting a Trigger for Capturing
Once START and STOP Triggers are set, select a trigger for use during the network capture. These
procuedures are identical for both the START and STOP Triggers.
1. In the 1784-U2DN I/O Settings Dialog select a trigger in the trigger list by clicking on it.
2. Click on the Select button

on the right of the list box. The selected trigger appears in the Selected

START/STOP Triggers field. This is the START/STOP trigger that will be use in the next capture session.
3. To empty the Selected START/STOP Trigger field, click the Deselect button below the field.

2.2.18 IEC 870-5-101/-104 Special Instructions
What To Do When The Correct Values Of Decoder Parameters Are Unknown
It is important to note that in many cases a useful decode can be obtained even if the correct decoder parameter
values are unknown to the user.

Link Layer Values
An incorrect value in the "Size of the address field in bytes" is easy to determine because fixed-length frames are
invalid and shown in red. The length of fixed-length frames is in the range 4-6. They begin with byte 0x10 and
end with byte 0x16 (there can also be bytes with those values elsewhere in the frame). To correct the problem,
you can change the values in "Size of the address field in bytes" field until fixed-length frames no longer appear in
red.
An incorrect value of "Is transmission balanced?" has no effect on the rest of the decode, and it can be left as it is
if the user doesn't care about the three fields directly affected by it (see description above). There is no way to
find the correct value by looking at the data, with the exception if the size of the link layer address field is 0, then
the transmission mode must be balanced.

Application Layer Values
The application layer parameters are Does Originator Address Exist, Size Of ASDU Address Field In Bytes, and Size
Of Info Obj Address Field In Bytes. They apply only to variable-length frames, which can be of almost any size.
Variable-length frames start with byte 0x68, end with byte 0x16 (there can also be bytes with those values
elsewhere in the frame), and come in two forms, identified by the value of the SQ bit, which is contained in the
variable structure qualifier. The spec describes them this way:
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l

SQ=0: There are one or more information objects, each with a single set of information elements.

l

SQ=1: There is only one information object, which contains one or more sets of information elements.

That's equivalent to saying this:
l

SQ=0: There is a separate information object address for each set of information elements.

l

SQ=1: There is one information object address and one or more sets of information elements.

When SQ=1, there is only one instance of the information object address, and finding a combination of values for
the parameters that yields an otherwise valid decode is a generally simple matter of trial-and-error. If the detail
pane indicates that there are extra data bytes (indicated by the presence of the Data field at the end), selectively
increase the values of those parameters to use up the extraneous data. If the detail pane indicates that a field is
missing, selectively decrease the values of those parameters until all fields are present. The fields that these
parameters refer to are contiguous; therefore no intervening fields are compromised. What can make this
process tricky is that some frames may in fact have the wrong number of bytes in them. When experimenting
with parameter values, use frames which appear to be the same type and length as other frames in the decode
since this generally indicates that those frames are of valid length.
When SQ=0, things are trickier. In this case, the information object address can appear multiple times, and not
contiguously. It is technically possible to set the parameters such that there is neither extra Data nor missing fields
but the decode itself is invalid. There is no surefire approach to this.

2.2.19 Modbus Special Instructions
2.2.19.1 Modbus Register Display Format Settings
Modbus protocol messages do not provide data formatting information but simply transmit holding and input
registers as byte streams. The Modbus Register Display Settings dialog provides a method for users to define
display formats to be utilized when displaying the values in these registers.
To access this dialog:
1. Go to the Options menu on the Control window and choose Set Initial Decoder Parameters
2. Select the Modbus tab.
3. To add a new entry, fill in the fields and click the Add button. Double-clicking a setting, copies its values to
the input fields.
4. To replace a setting with a new setting created from the input fields, click the setting to replace and then
click the Modify button.
When you close a capture file, you are asked whether you want to save the current register settings into it. To
save settings independent of a specific capture file:
1. Type any string in the "Apply Template" field and click Save.
2. To restore those settings to the dialog, select the desired setting in the "Apply Template" drop down list.
New settings do not take effect in a currently opened capture file until the frame display is closed and then
reopened.
Register Display Settings
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Default Display Format_Bits
This field specifies the default display format for registers that have no user defined setting (such registers are
always assumed to be 2 bytes long). The default display format is limited to single-register display formats to
prevent implicit register range overlap and to ensure that explicitly defining a setting in which one display
format item uses multiple registers does not change the locations of subsequent default settings.

l

Station Address

The IP Address or Station Address field (its name changes to reflect the loaded decoder) is used to enter the
desired IP or station address for each setting. Enter an asterisk to specify that a setting applies to all IP or station
addresses. Station address ranges are from 0 to 248 and IP address ranges can be any valid IP Address.
l

Register Type
The Register Type field specifies the type of register, either HOLDING or INPUT.

l

Bytes Per Register
This field defaults to 2, indicating that standard Modicon registers are 2 bytes each. If you are dealing with a
third party implementation of Modbus, you may need to adjust this field to reflect the actual number of bytes
in a single register.

l

Register Start Address
Enter the address of the first register you want to specify settings for.

l

Display Format_Bits
The Display Format_Bits field specifies the desired display format. Display formats ASCII and HEX are variablelength and display a char or hex byte respectively for each byte in a register. The other display formats (INT_
16, FLOAT_32, etc) have a bit count suffix in their names and use as many registers as they need, based on the
bytes per register field. Choose a format for the specified register range.

l

Length
This field is the desired number of data items (e.g. INT_32s), not the number of registers. The number of
registers are calculated and displayed in the text description.

Example
If you want to specify Station 3's input registers 0-99 as INT_16s, you would enter 3 for the Station Address, INPUT
for the Register Type, 0 for the Start Address, 2 for Bytes Per Register, INT_16 for the Display Format and 100 for
the Length, indicating that you have 100 INT_16s starting at Input Register Address 0 where each register is 2
bytes long.

2.2.19.2 Setup For Modbus RTU and ASCII
Modbus ASCII and Modbus RTU protocols have three selections on the launcher menu. The appropriate selection
depends upon physical characteristics of your network.
If your system is running over a physical layer that is 2-wire RS-422/485, select either the Modbus RTU on 2-Wire
RS422/485 or the Modbus ASCII on 2-Wire RS422/485, depending upon which protocol your system is using. In
this case there are no special wire tapping instructions. If your system is not a 2-wire RS422/485 system, you must
select the correct launcher item based upon the following information.
There are two decodes for Modbus RTU: Modbus RTU Master and Modbus RTU Slave. Similarly, there are two
decodes for Modbus ASCII: Modbus ASCII Master and Modbus ASCII Slave. The Master and Slave refer to where in
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the circuit the analyzer is connected. The rest of this topic simply refers to Modbus Master or Modbus Slave, as
the principles are the same.
Modbus Master assumes that data from the Master is on the DTE side (i.e. master data is on the TxD pin and slave
data on the RxD pin). If the analyzer is connected to a Master device, choose the Modbus Master decode.
Modbus Slave assumes that data from the slave is on the DTE side (i.e. slave data is on the TxD pin and master data
on the RxD pin). If the analyzer is connected to any Slave device, choose the Modbus Slave decode.
The diagram below illustrates conceptually which decoder to choose. Your configuration may be different from
the diagram. The important thing is to choose Modbus Master if the master data is on the transmit line, or Modbus
Slave if the slave data is on the transmit line.
Once you have selected the correct protocol, be sure to set the Register Display Settings so your data is decoded
correctly.
If you have a custom protocol and need help connecting the analyzer to the right location, see Generic Channel
Dependent Decodes Setup.

Figure 2.29 - Conceptual Modbus decoder setup.

2.2.19.3 Setup for Modbus TCP
In order to correctly decode Modbus TCP, the software needs to know the IP Addresses of the Master and Slave
devices. The system allows the user to define any number of IP Address and Node Type combinations and save
them in a template for later use.
The Node Template function provides the capacity to create multiple templates that contain different node
assignments. This capability allows the user to maintain individual templates for each network monitored.
Applying a template containing the node assignments necessary to monitor transmissions particular to an
individual network, enhances the efficiency of the analyzer to decode data.
Select the task you wish to perform from the following:
Adding a Node Assignment
Modifying a Node Assignment
Deleting a Node Assignment
Selecting and Applying a Node Assignment Template
Adding a Node Assignment Template
Deleting a Node Assignment Template
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2.2.20 Generic Channel Dependent Decodes Setup
Channel dependent decodes are decodes for protocols where frames do not contain information about what type
of data it contains.
A common situation in which this occurs are simple master/slave circuits, where there is one master which sends
commands and a slave responds to the most recent command. In these types of protocols, there may not be any
indication that the data is in the form of a command or is a response to a command. The decodes for each are
usually different, but without a field in the data specifying which is being carried, the analyzer has no way to know
whether to use the decode for a command frame or a response frame. Usually the only way to know which
decode to use is to assume that master data is always coming from the DTE side and the slave data is always on the
DCE side (or vice versa). This often means the analyzer must be connected to the circuit in such a way that master
data is on TxD and slave data is on RxD.
These diagrams assume the two devices are a master and a slave, but they might be a host and a controller or two
PCs or any other type of device. The diagrams assume that the data from the master must be on the DTE channel
and data from the slave on the DCE channel. This may differ for your particular protocol.

Figure 2.30 - DTE device connected to DCE device.

Figure 2.31 - DTE device connected to another DTE device with a null modem cable.
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3.1 Capturing Data
Note: Data Capture is not available in Viewer mode.
1. Click the Start Capture icon

to begin capturing to a file. This icon is located on the Control, Event

Display, and Frame Display windows.
Files are placed in My Capture Files by default and have a .cfa extension. Choose Directories from the
Options menu on the Control window to change the default file location.
2. Watch the status bar on the Control window to monitor how full the file is. When the file is full, it begins to
wrap, which means the oldest data will be overwritten by new data.
3. Click the Stop icon
to temporarily stop data capture. Click the Start Capture icon again to resume
capture. Stopping capture means no data will be added to the capture file until capture is resumed, but the
previously captured date remains in the file.
4. To clear captured data, click the Clear icon
l

.

If you select Clear after selecting Stop, a dialog appears asking whether you want to save the data.
o

You can click Save File and enter a file name when prompted .

o

If you choose Do Not Save, all data will be cleared.

o

If you choose Cancel, the dialog closes with no changes.
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If you select the Clear icon while a capture is occurring, the capture stops.
o

A dialog appears asking if you want to save the capture.
n

You can select Yes and save the capture or

n

select No and close the dialog.

o

In either case, the existing capture file is cleared and a new capture file is started.

o

If you choose Cancel, the dialog closes with no changes.

To change the size of the capture file or to see how to capture to a series of files or single file, choose System
Settings from the Options menu on the Control window.

3.2 Protocol Stacks
3.2.1 Protocol Stack Wizard
The Protocol Stack wizard is where you define the
protocol stack you want the analyzer to use when
decoding frames.
To start the wizard:
1. Choose Protocol Stack from the Options
menu on the Control window or click the
Protocol Stack icon
on the Frame
Display.
2. Select a protocol stack from the list, and click
Finish. Click for information on how the
analyzer auto-traverses the protocol stack.
Most stacks are pre-defined here. If you have special
requirements and need to set up a custom stack, see
Creating and Removing a Custom Stack on page lxxvi.
1. If you select a custom stack (i.e. one that was defined by a user and not included with the analyzer), the
Remove Selected Item From List button becomes active.
2. Click the Remove Selected Item From Listbutton to remove the stack from the list. You cannot
remove stacks provided with the analyzer. If you remove a custom stack, you need to define it again in
order to get it back.
If you are changing the protocol stack for a capture file, you may need to reframe. See Reframing on page 1 for
more information.
You cannot select a stack or change an existing one for a capture file loaded into the Capture File Viewer (the
Capture File Viewer is used only for viewing capture files and cannot capture data). Protocol Stack changes can
only be made from a live session.
Note for BCSP:
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If you are using the BCSP protocol stack, you must connect the analyzer to the circuit such that the data on the DTE
line comes from the host, and data on the DCE line comes from the controller. Click here
Note for Modbus RTU:
If you are using the Modbus RTU protocol stack, you must select either Modbus RTU Master or Modbus RTU Slave
depending on where the analyzer taps into the circuit. Click here for more information.
Note for Modbus TCP:
If you are using Modbus TCP over Ethernet, you need to set up a node database giving the IP addresses for the
Master and Slave devices. Click here for more information.
Note for Data Highway Plus (DH+):
There are special hardware and software configuration instructions for setting up the DL3000 DHM device used to
tap into the Data Highway Plus network. Click here for more information.
Note for IEC 870-5-101:
You need to give the decoder information on the sizes of some fields and whether or not other fields are present.
There are all system configurable options and therefore the decoder has no way of knowing this information from
the data. Click here for more information.
Note for DeviceNet
You need to install the DeviceNet card before beginning data capture. Then you need to setup the device in the
Hardware Settings window, and optionally select any capture filters.
DeviceNet Card Installation Instructions
DeviceNet Device Setup
DeviceNet Capture Filters
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3.2.2 Creating and Removing a Custom Stack
To create a custom stack:
1. Choose Protocol Stack from the
Options menu on the Control
window or click the Protocol Stack
icon
on the Frame Display
toolbar.
2. Select Build Your Own from the list
and click Next.
3. The system displays an information
screen that may help you decide if you
need to define your own custom stack.
Defining a custom stack means that the
analyzer uses the stack for every
frame. Frames that do not conform to
the stack are decoded incorrectly.
Click Next to continue.

Select Protocols
1. Select a protocol from the list on the
left.
2. Click the right arrow button to move it
to the Protocol Decode Stack box
on the right, or double-click the
protocol to move it to the right.
3. To remove a protocol from the stack,
double-click it or select it and click the
left arrow button.
4. If you need to change the order of the
protocols in the stack, select the
protocol you want to move, and click
on the Move Up and Move Down buttons until the protocol is in the correct position.
5. The lowest layer protocol is at the top of the list, with higher layer protocols listed underneath.

Auto-traversal (Have the analyzer Determine Higher Layers)
If you need to define just a few layers of the protocol stack, and the remaining layers can be determined based on
the lower layers:
1. Click the All additional stack layers can be determined automatically button.
2. If your protocol stack is complete and there are no additional layers, click the There are no additional
stack layers button.
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3. If you select this option, the analyzer uses the stack you defined for every frame. Frames that do use this
stack are decoded incorrectly.

Save the Stack
1. Click the Add To Predefined List button.
2. Give the stack a name, and click Add.
In the future, the stack appears in the Protocol Stack List on the first screen of the Protocol Stack wizard.

Remove a Stack
1. Select it in the first screen and click Remove Selected Item From List.
2. If you remove the stack, you must to recreate it if you need to use it again.

Note: If you do not save your custom stack, it does appear in the predefined list, but applies to
the frames in the current session. However, it is discarded at the end of the session.

3.2.3 Reframing
If you need to change the protocol stack used to interpret a capture file and the framing is different in the new
stack, you need to reframe in order for the protocol decode to be correct. You can also use Reframe to frame
unframed data. The original capture file is not altered during this process.
Note: You cannot reframe from the Capture File Viewer .
To reframe your data, load your capture file, select a protocol stack, and then select Reframe from the File
menu on the Control window. Reframe is only available if the frame recognizer used to capture the data is
different from the current frame recognizer.
In addition to choosing to Reframe, you can also be prompted to Reframe by the Protocol Stack Wizard.
1. Load your capture file by choosing Open from the File menu on the Control window, and select the file
to load.
2. Select the protocol stack by choosing Protocol Stack from the Options menu on the Control window,
select the desired stack and click Finish.
3. If you selected a protocol stack that includes a frame recognizer different from the one used to capture
your data, the Protocol Stack Wizard asks you if you want to reframe your data. Choose Yes.
4. The analyzer adds frame markers to your data, puts the framed data into a new file, and opens the new
file. The original capture file is not altered.
See Unframing on page lxxvii for instructions on removing framing from data.

3.2.4 Unframing
This function removes start-of-frame and end-of-frame markers from your data. The original capture file is not
altered during this process. You cannot unframe from the Capture File Viewer (accessed by selecting Capture File
Viewer or Load Capture File to start the software and used only for viewing capture files).
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To manually unframe your data:
1. Select Unframe from the File menu on the Control window. Unframe is only available if a protocol
stack was used to capture the data and there is currently no protocol stack selected.
In addition to choosing to Unframe, you can also be prompted to Unframe by the Protocol Stack Wizard.
1. Load your capture file by choosing Open from the File menu on the Control window.
2. Select the file to load.
3. Choose Protocol Stack from the Options menu on the Control window
4. Select None from the list
5. Click Finish. The Protocol Stack Wizard asks you if you want to unframe your data and put it into a new
file.
6. Choose Yes.
The system removes the frame markers from your data, puts the unframed data into a new file, and opens the
new file. The original capture file is not altered.
See Reframing on page lxxvii for instructions on framing unframed data.

3.2.5 How the Analyzer Auto-traverses the Protocol Stack
In the course of doing service discovery, devices ask for and receive a Protocol Descriptor List defining which
protocol stacks the device supports. It also includes information on which PSM to use in L2CAP, or the channel
number for RFCOMM, or the port number for TCP or UDP. The description below talks about how the analyzer
auto-traverses from L2CAP using a dynamically assigned PSM, but the principle is the same for RFCOMM channel
numbers and TCP/UDP port numbers.
The analyzer looks for SDP Service Attribute Responses or Service Search Attribute Responses carrying protocol
descriptor lists. If the analyzer sees L2CAP listed with a PSM, it stores the PSM and the UUID for the next protocol
in the list.
After the SDP session is over, the analyzer looks at the PSM in the L2CAP Connect frames that follow. If the PSM
matches one the analyzer has stored, the analyzer stores the source channel ID and destination channel ID, and
associates those channel IDs with the PSM and UUID for the next protocol. Thereafter, when the analyzer sees
L2CAP frames using those channel IDs, it can look them up in its table and know what the next protocol is.
In order for the analyzer to be able to auto-traverse using a dynamically assigned PSM, it has to have seen the SDP
session giving the Protocol Descriptor Lists, and the subsequent L2CAP connection using the PSM and identifying
the source and channel IDs. If the analyzer misses any of this process, it is not able to auto-traverse. It stops
decoding at the L2CAP layer.
For L2CAP frames carrying a known PSM (0x0001 for SDP, for example, or 0x0003 for RFCOMM), the analyzer
looks for Connect frames and stores the PSM along with the associated source and destination channel IDs. In this
case the analyzer does not need to see the SDP process, but does need to see the L2CAP connection process,
giving the source and destination channel IDs.

3.2.6 Providing Context For Decoding When Frame Information Is Missing
There may be times when you need to provide information to the analyzer because the context for decoding a
frame is missing. For example, if the analyzer captured a response frame, but did not capture the command frame
indicating the command.
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The analyzer provides a way for you to supply the context for any frame, provided the decoder supports it. (The
decoder writer has to include support for this feature in the decoder, so not all decoders support it. Note that not
all decoders require this feature.)
If the decoder supports user-provided context, three items are active on the Options menu of the Control
window and the Frame Display window. These items are Set Initial Decoder Parameters, Automatically
Request Missing Decoding Information, and Set Subsequent Decoder Parameters. (These items are
not present if no decoder is loaded that supports this feature.)
Set Initial Decoder Parameters is used to provide required information to decoders that is not context
dependent but instead tends to be system options for the protocol.
Choose Set Initial Decoder Parameters in order to provide initial context to the analyzer for a decoder. A
dialog appears that shows the data for which you can provide information.
If you need to change this information for a particular frame :
1. Right-click on the frame in the Frame Display window
2. Choose Provide <context name>.
Alternatively, you can choose Set Subsequent Decoder Parameter from the Options menu.
3. This option brings up a dialog showing all the places where context data was overridden.
4. If you know that information is missing, you can't provide it, and you don't want to see dialogs asking for it,
un-check Automatically Request Missing Decoding Information.
5. When unchecked, the analyzer doesn't bother you with dialogs asking for frame information that you don't
have. In this situation, the analyzer decodes each frame until it cannot go further and then simply stop
decoding.

3.3 Analyzding Byte Level Data
3.3.1 Event Display
To open this window click the Event Display icon

on the Control window toolbar.

The Event Display window provides detailed information about every captured event. Events include data
bytes, data related information such as start-of-frame and end-of-frame flags, and the analyzer information, such
as when the data capture was paused. Data bytes are displayed in hex on the left side of the window, with the
corresponding ASCII character on the right.
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Figure 3.1 - Event Display
Click on an event to find out more about it. The three status lines at the bottom of the window are updated with
information such as the time the event occurred (for data bytes, the time the byte was captured), the value of the
byte in hex, decimal, octal, and binary, any errors associated with the byte, and more.
Events with errors are shown in red to make them easy to spot.
When capturing data live, the analyzer continually updates the Event Display as data is captured. Make sure the
Lock icon
is displayed on the toolbar to prevent the display from updating (Clicking on the icon again will
unlock the display). While locked, you can review your data, run searches, determine delta time intervals
between bytes, and check CRCs. To resume updating the display, click the Lock icon again.
You can have more than one Event Display open at a time. Click the Duplicate View icon

to create a

second, independent Event Display window. You can lock one copy of the Event Display and analyze your
data, while the second Event Display updates as new data is captured.
Event Display is synchronized with the Frame Display dialogs. Selecting a byte in Event Display will also
select the related frame in the Frame Display .

3.3.2 The Event Display Toolbar
Home – Brings the Control window to the front.
Open a capture file
Start Capture - Begins data capture to disk.
Sodera Only: Start Analyze- Begins data analysis..
Stop Capture - Closes a capture file and stops data capture to disk.
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Sodera Only: Stop Analyze- Stops the analysis and clears the data from the ComProbe
analyzer.
Save - Prompts user for a file name. If the user supplies a name, a .cfa file is saved.
Clear- Discards the temporary file and clears the display.
MSC Chart - Opens the Message Sequence Chart
Signal Display - Opens The Signal Display dialog.
Lock - In the Lock state, the window is locked so you can review a portion of data. Data
capture continues in the background. Clicking on the Lock icon unlocks the window.
Unlock - In the Unlock state, the screen fills in the data captured since the screen lock and
moves down to display incoming data again. Clicking on the Unlock icon locks the window.
Open Breakout Box window that provides a real-time graphical view of control signals.
Duplicate View - Creates a second Event Display window identical to the first.
Frame Display - (framed data only) Brings up a Frame Display, with the frame of the currently
selected bytes highlighted.
Display Capture Notes - Brings up the Capture Notes window where you can view or add
notes to the capture file.
Add/Modify Bookmark - Add a new or modify an existing bookmark.
Display All Bookmarks - Shows all bookmarks and lets you move between bookmarks.
Find - Search for errors, string patterns, special events and more.
Go To - Opens the Go To dialog, where you can specify which event number to go to.
CRC - Change the algorithm and seed value used to calculate CRCs. To calculate a CRC,
select a byte range, and the CRC appears in the status lines at the bottom of the Event
Display.
Mixed Sides - (Serial data only) By default, the analyzer shows data with the DTE side above
the DCE side. This is called DTE over DCE format. DTE data has a white background and
DCE data has a gray background. The analyzer can also display data in mixed side format. In
this format, the analyzer does not separate DTE data from DCE data but shows all data on
the same line as it comes in. DTE data is still shown with a white background and DCE data
with a gray background so that you can distinguish between the two. The benefit of using this
format is that more data fits onto one screen.
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Character Only - The analyzer shows both the number (hex, binary, etc.) data and the
character (ASCII, EBCDIC or BAUDOT) data on the same screen. If you do not wish to see
the hex characters, click on the Character Only button. Click again to go back to both number
and character mode.
Number Only - Controls whether the analyzer displays data in both character and number
format, or just number format. Click once to show only numeric values, and again to show
both character and numeric values.
All Events - Controls whether the analyzer shows all events in the window, or only data bytes.
Events include control signal changes and framing information.
Timestamping Options – Brings up the timestamping options window which has options for
customizing the display and capture of timestamps.

3.3.3 Opening Multiple Event Display Windows
Click the Duplicate View icon

from the Event Display toolbar to open a second Event Display window.

You can open as many Event Display windows as you like. Each Event Display is independent of the others
and can show different data, use a different radix or character set, or be frozen or live.
The Event Display windows are numbered in the title bar. If you have multiple Event Displays open, click on
the Event Display icon
on the Control window toolbar to show a list of all the Event Displays currently
open. Select a window from the list to bring it to the front.

3.3.4 Calculating CRCs or FCSs
The cyclic redundancy check (CRC) is a function on the Event Display window used to produce a checksum. The
frame check sequence (FCS) are the extra checksum characters added to a frame to detect errors.
1. Open the Event Display

window.

2. Click and drag to select the data for which you want to generate a CRC.
3. Click on the CRC icon

.

4. In the CRC dialog box, click on the down arrow to show the list
of choices for CRC algorithms. Choose an algorithm to use. Choose
CRC 32 (Ethernet). Choose CRC 32 (Ethernet) for Ethernet data or
the appropriate CRC type for serial data.
5. Enter a Seed value in hexadecimal if desired.
6. Click OK to generate the CRC. It appears in the byte information
lines at the bottom of the Event Display window. Whenever you
select a range of data, a CRC using the algorithm you selected is
calculated automatically.
"CRC!" in Ethernet data
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Ethernet network cards do not normally send the CRC with the frame to the upper layers of the system. The
hardware on the card checks that the CRC is correct and then throws it away. Frontline marks the place where the
CRC would be in the data with "CRC!". When viewing Ethernet capture files made with other programs, the CRC
may or may not be included, depending on the specifications of the capturing software/hardware.
Reversed CRCs on the Event Display with Ethernet data
The CRC calculated in the Event Display window is reversed from the CRC shown in the data. CRCs are calculated
in network data order from Most Significant Byte (MSB) to Least Significant Byte (LSB). The Ethernet specification
says to send data in host data order (LSB to MSB). Therefore the CRC as captured in the data is the reverse of the
CRC as calculated.
Example: If the CRC in the data is shown as 00 01 02 03, the Event Display calculated the CRC and show it in the
status lines as 03 02 01 00. This is correct.
Calculating CRC for interwoven data
Frontline calculates the CRC for either side of the interwoven data. Which side it calculates is determined by the
first byte selected. If the first byte is from one side, then Frontline calculates the CRC for just the bytes on that
side. If the first byte is from the other side, then Frontline calculates the CRC for just the bytes on that side.
Incorrect results with CRC16 for serial data
If you are calculating CRCs using the CRC16 algorithm and the CRCs do not match what you know they should be,
try CRC16rev. What hardware often calls CRC16 is what software calls CRC16rev.

3.3.5 Calculating Delta Times and Data Rates
1. Click on the Event Display icon

on the Control window to open the Event Display window.

2. Use the mouse to select the data you want to calculate a delta time and rate for.
3. The Event Display window displays the delta time and the data rate in the status lines at the bottom of
the window.

Figure 3.2 - Delta fields
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3.3.6 Switching Between Live Update and Review Mode
The Event Display and Frame Display windows can update to display new data during live capture, or be
frozen to allow data analysis. By default, the Event Display continually updates with new data, and the Frame
Display is locked.
1. Make sure the Lock icon
2. Click the Unlock

is active so the display is locked and unable to scroll.

icon again to resume live update.

The analyzer continues to capture data in the background while the display is locked. Upon resuming live update,
the display updates with the latest data.
You can have more than one Event Display or Frame Display window open at a time. Click the Duplicate
View icon
to open additional Event or Frame Display windows. The lock/resume function is independent on
each window. This means that you can have two Event Display windows open simultaneously, and one window
can be locked while the other continues to update.

3.3.7 Data Formats and Symbols
3.3.7.1 List of all Event Symbols
By default, the Event Display shows all eventsevents, which includes control signal changes, start and end of
frame characters and flow control changes. If you want to see only the data bytes, click on the All Events button
. Click again to display all events.
Click on a symbol, and the analyzer displays the symbol name and sometimes additional information in the status
lines at the bottom of the Event Display window. For example, clicking on a control signal change symbol
displays which signal(s) changed.
In addition to data bytes, the events shown are (in alphabetical order):
Table 3.1 - Event Symbols
Symbol

Event
Abort
Broken Frame - The frame did not end when the analyzer expected it to. This occurs most often
with protocols where the framing is indicated by a specific character, control signal change, or
other data related event.
Buffer Overflow - Indicates a buffer overflow error. A buffer overflow always causes a broken
frame.
Control Signal Change - One or more control signals changed state. Click on the symbol, and
the analyzer displays which signal(s) changed at the bottom of the Event Display window.
Data Capture Paused - The Pause icon was clicked, pausing data capture. No data is recorded
while capture is paused.
Data Capture Resumed - The Pause icon was clicked again, resuming data capture.
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Table 3.1 - Event Symbols (continued)

Symbol

Event
Dropped Frames - Some number of frames were lost. Click on the symbol, and the analyzer
displays many frames were lost at the bottom of the Event Display window.
End of Frame - Marks the end of a frame.
Flow Control Active - An event occurred which caused flow control to become active (i.e.
caused the analyzer to stop transmitting data) Events which activate flow control are signal
changes or the receipt of an XON character.
Flow Control Inactive - An event occurred which caused flow control to become inactive (i.e.
caused the analyzer to transmit data). Events which deactivate flow control are signal changes
or the receipt of an XOFF character.
Frame Recognizer Change - A lowest layer protocol was selected or removed here, causing the
frame recognizer to be turned off or on.
I/O Settings Change - A change was made in the I/O Settings window which altered the baud,
parity, or other circuit setting.
Long Break
Low Power - The battery in the ComProbe® is low.
Short Break
SPY Event (SPY Mode only) - SPY events are commands sent by the application being spied on
to the UART.
Start of Frame - Marks the start of a frame.
Begin Sync Character Strip
End Sync Character Strip
Sync Dropped
Sync Found
Sync Hunt Entered
Sync Lost
Test Device Stopped Responding - The analyzer lost contact with the ComProbe for some
reason, often because there is no power to the ComProbe.
Test Device Began Responding - The analyzer regained contact with the ComProbe.
Timestamping Disabled - Timestamping was turned off. Events following this event are not
timestamped.
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Table 3.1 - Event Symbols (continued)

Symbol

Event
Timestamping Enabled - Timestamping was turned on. Events following this event have
timestamps.
Truncated Frame- A frame that is not the same size as indicated within its protocol.
Underrun Error
Unknown Event

3.3.7.2 Switching Between Viewing All Events and Viewing Data Events
By default, the analyzer on the Event Display dialog shows all events that include:
l

Data bytes

l

Start-of-frame

l

End-of-frame characters

l

Data Captured Was Paused.

Click on the Display All Events icon

to remove the non-data events. Click again to display all events.

See List of all Event Symbols on page 1 for a list of all the special events shown in the analyzer and what they
mean.

3.3.7.3 Switching Between Hex, Decimal, Octal or Binary
On the Event Display window the analyzer displays data in Hex by default. There are several ways to change the
radix used to display data.
Go to the Format menu and select the radix you want. A check mark next to the radix indicates which set is
currently being used.

Figure 3.3 - Format Menu
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1. Right-click on the data display header labels and choose a different radix.

Figure 3.4 - Header labels, right click
2. Or right-click anywhere in the data display and select a different radix.

Figure 3.5 - Data display right click menu
If you want to see only the numerical values, click on the Numbers Only icon

on the Event Display

toolbar.

3.3.7.4 Switching Between ASCII, EBCDIC, and Baudot
On the Event Display window, the analyzer displays data in ASCII by default when you click on the Characters
Only icon
. There are several ways to change the character set used to display data.
1. Go to the Format menu and select the character set you want. A check mark next to the character set
indicates which set is currently being used.
2. With the data displayed in characters, right-click on the data panel header label to choose a different
character set.
If you want to see only characters, click on the Characters Only icon
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3.3.7.5 Viewing Only ASCII (or EBCDIC or Baudot)
On the Event Display toolbar you can choose to view data in ASCII, EBCDIC, or Baudot format only click on the
Characters Only icon
on the Event Display toolbar.
To add the numerical values back to the display click the Characters Only icon again.

3.3.7.6 Viewing Only Hex (Or Decimal or Octal or Binary)
On the Event Display toolbar you can choose to view data as numeric only. Click on the Numbers Only icon
on the Event Display toolbar.
To display the characters back to the display click the Number Only icon again.

3.3.7.7 Selecting Mixed Channel/Sides
If you want to get more data on the Event Display window, you can switch to mixed sides mode. This mode
puts all the data together on the same line. Data from one side (Slave ) is shown on a white background and data
from the other side ( Master )is shown on a gray background.
1. Click once on the Mixed Sides icon

to put the display in mixed sides mode.

2. Click again to return to side over side mode.
3. You can right click in the center of the data display window to change between mixed and side over side
modes by selecting Display Sides Together. A check mark is displayed. Click on Display Sides
Together to remove the check mark and return to side-by-side display.
4. Right click in the sides panel on the right of the data display and select Display Sides Together. A check
mark is displayed. Click on Display Sides Together to remove the check mark and return to side-byside display.
5.

3.3.7.8 Font Size
The font size can be changed on several Event Display windows. Changing the font size on one window does not
affect the font size on any other window.
To change the font size:
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1. Click on Event Display menu Options, and select Change the Font Size.

Figure 3.6 - Event Display Options menu
2. Choose a font size from the list.

Figure 3.7 - Event Display Font Size Selection
3. Click OK.

3.4 The Frame Display
To open this window
Click the Frame Display icon

on the Control window toolbar, or select Frame Display from the View

menu.
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Figure 3.8 - Frame Display with all panes active
Frame Display Panes
The Frame Display window is used to view all frame related information. It is composed of a number of
different sections or "panes", where each pane shows a different type of information about a frame.
l

xc

Summary Pane - The Summary Pane displays a one line summary of each frame for every protocol found in
the data, and can be sorted by field for every protocol. Click here for an explanation of the symbols next to the
frame numbers.
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Decode Pane - The Decode Pane displays a detailed decode of the highlighted frame. Fields selected in the
Decode Pane have the appropriate bit(s) or byte(s) selected in the Radix, Binary, Character , and Event
panes
Radix Pane - The Radix Pane displays the logical data bytes in the selected frame in either hexadecimal,
decimal or octal.
Binary Pane - The Binary Pane displays a binary representation of the logical data bytes.
Character Pane - The Character Pane displays the character representation of the logical data bytes in either
ASCII, EBCDIC or Baudot.
Event Pane - The Event Pane displays the physical data bytes in the frame, as received on the network.

By default, all panes except the Event Pane are displayed when the Frame Display is first opened.
Protocol Tabs
Protocol filter tabs are displayed in the Frame Display above the Summary pane.
l

l

l

l

These tabs are arranged in separate color-coded groups. The General group applies to all technologies. The
other groups are technology-specific.
Clicking on a protocol filter tab in the General group filters in all packets containing that protocol regardless of
each packet’s technology.
Clicking on a protocol filter tab in a technology-specific group filters in all packets containing that protocol on
that technology.
A protocol filter tab appears in the General group only if the protocol occurs in more than one of the
technology-specific tab groups.

Select the Unfiltered tab to display all packets.
There are several special tabs that appear in the Summary Pane when certain conditions are met. These tabs
appear only in the General group and apply to all technologies. The tabs are:
l

l

l

Bookmarks appear when a bookmark is first seen.
Errors appear when an error is first seen. An error is a physical error in a data byte or an error in the
protocol decode.
Info appears when a frame containing an Information field is first seen.

The tabs disappear when the capture buffer is cleared during live capture or when decoders are reloaded, even if
one of the tabs is currently selected. They subsequently reappear as the corresponding events are detected.

Comparing Frames
If you need to compare frames, you can open additional Frame Display windows by clicking on the Duplicate
View icon
. You can have as many Frame Display windows open at a time as you wish.

Frame Wrapping and Display
In order to assure that the data you are seeing in Frame Display are current, the following messages appear
describing the state of the data as it is being captured.
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All Frame Display panes except the Summary pane display "No frame selected" when the selected frame is
in the buffer (i.e. not wrapped out) but not accessible in the Summary pane. This can happen when a tab is
selected that doesn’t filter in the selected frame.
When the selected frame wraps out (regardless of whether it was accessible in the Summary pane) all Frame
Display panes except the Summary pane display "Frame wrapped out of buffer".
When the selected frame is still being captured, all Frame Display panes except the Summary pane display
"Frame incomplete".

3.4.1 Frame Display Toolbar
The buttons that appear in the Frame Display window vary according to the particular configuration of the
analyzer. For controls not available the icons will be grayed-out.
Table 3.2 - Frame Display Toolbar Icons
Icon

Description
Control – Brings the Control window to
the front.
Open File - Opens a capture file.
I/O Settings - Opens the I/O Settings
dialog.
Start Capture - Begins data capture to a
user designated file.
Sodera Only: Start Analyze- Begins data
analysis..
Stop Capture - Closes a capture file and
stops data capture to disk.
Sodera Only: Stop Analyze- Stops the
analysis and clears the data from the
ComProbe analyzer.
Save - Save the currently selected bytes
or the entire buffer to file.
Clear- Discards the temporary file and
clears the display.
Event Display – Brings the Event Display
window to the front.
Show Message Sequence Chart Message Sequence Chart (MSC)
displays information about the messages
passed between protocol layers.
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Table 3.2 - Frame Display Toolbar Icons(continued)
Icon

Description
Show Statistics - Opens Statistics dialog
Duplicate View - Creates a second Frame
Display window identical to the first.
Apply/Modify Display Filters - Opens the
Display Filter dialog.
Quick Protocol Filter - brings up a dialog
box where you can filter or hide one or
more protocol layers.
Protocol Stack - brings up the Protocol
Stack Wizard where you can change the
stack used to decode framed data
Reload Decoders - When Reload
Decoders is clicked, the plug-ins are
reset and received frames are redecoded. For example, If the first frame
occurs more than 10 minutes in the past,
the 10-minute utilization graph stays
blank until a frame from 10 minutes ago or
less is decoded.
Find - Search for errors, string patterns,
special events and more.
Display Capture Notes - Brings up the
Capture Notes window where you can
view or add notes to the capture file.
Add/Modify Bookmark - Add a new or
modify an existing bookmark.
Display All Bookmarks - Shows all
bookmarks and lets you move between
bookmarks.
Bluetooth Timeline - Opens the Bluetooth
Timeline
Coexistence View - Opens the
Coexistence View
low energy Timeline- Opens the low
energy Timeline
Extract Data - Opens the Extract Data
dialog.
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Table 3.2 - Frame Display Toolbar Icons(continued)
Icon

Description
Bluetooth low energy Packet Error Rate
Statistics Opens the Packet Error Rate
Statistics display
Bluetooth Classic Packet Error Rate
Statistics - Opens the Packet Error Rate
Statistics display.
Logic Analyzer - Opens the logic analyzer
used for logic signal and packet timing
analysis.
Signal Display - Opens The Signal
Display dialog.
Breakout Box - Opens the Breakout Box
dialog.
Audio Extraction - Opens the Audio
Extraction dialog.
Pie Chart - This icon displays a chart that
displays the number of frames with and
without errors.

Reload Decoders - When Reload Decoders is clicked, the plug-ins are reset
and received frames are re-decoded. For example, If the first frame occurs
more than 10 minutes in the past, the 10-minute utilization graph stays blank
until a frame from 10 minutes ago or less is decoded.
Filter: Text giving the filter currently in
use. If no filter is being used, the text
reads "All Frames" which means that
nothing is filtered out. To see the text of
the entire filter, place the cursor over the
text and a ToolTip pops up with the full
text of the filter.
The following icons all change how the panes are arranged on the Frame
Display. Additional layouts are listed in the View menu.
Show Default Panes - Returns the panes
to their default settings.
Show Only Summary Pane - Displays
only the Summary pane.
Shall All Panes Except Event Pane Makes the Decode pane taller and the
Summary pane narrower.
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Table 3.2 - Frame Display Toolbar Icons(continued)
Icon

Description
Toggle Display Lock - Prevents the
display from updating.
Go To Frame
First Frame - Moves to the first frame in
the buffer.
Previous Frame - Moves to the previous
frame in the buffer.
Next Frame - Moves to the next frame in
the buffer.
Last Frame - Moves to the last frame in
the buffer.
Find on Frame Display only searches the
Decode Pane for a value you enter in the
text box.
Find Previous Occurrence - Moves to the
previous occurrence of the value in the
Frame Display Find.
Find Next Occurrence - Moves to the next
occurrence of the value in the Frame
Display Find.
Cancel Current Search - Stops the
current Frame Display Find.
Summary Drop Down Box: Lists all the
protocols found in the data in the file. This
box does not list all the protocol decoders
available to the analyzer, merely the
protocols found in the data. Selecting a
protocol from the list changes the
Summary pane to display summary
information for that protocol. When a low
energy predefined Named Filter (like
Nulls and Polls) is selected, the
Summary drop-down is disabled.
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Table 3.2 - Frame Display Toolbar Icons(continued)
Icon

Description

Text with Protocol Stack: To the right of the Summary Layer box is some text
giving the protocol stack currently in use.

Note: If the frames are sorted in other than ascending frame number order, the order of the
frames in the buffer is the sorted order. Therefore the last frame in the buffer may not have the
last frame number.

3.4.2 Frame Display Status Bar
The Frame DisplayStatus bar appears at the bottom of the Frame Display. It contains the following
information:
l

l

l

Frame #s Selected: Displays the frame number or numbers of selected (highlighted) frames, and the total
number of selected frames in parentheses
Total Frames: The total number of frames in the capture buffer or capture file in real-time
Frames Filtered In: The total number of frames displayed in the filtered results from user applied filters in
real-time

3.4.3 Hiding and Revealing Protocol Layers in the Frame Display
Hiding protocol layers refers to the ability to prevent a layer from being displayed on the Decode pane. Hidden
layers remain hidden for every frame where the layer is present, and can be revealed again at any time. You can
hide as many layers as you wish.
Note: Hiding from the Frame Display affects only the data shown in the Frame Display and not any
information in any other window.
There are two ways to hide a layer.
1. Right-click on the layer in the Decode pane, and choose Hide [protocol name] Layer In All Frames.
2. Click the Set Protocol Filtering button on the Summary pane toolbar. In the Protocols to Hide box
on the right, check the protocol layer(s) you want hidden. Click OK when finished.
To reveal a hidden protocol layer:
1. Right-click anywhere in the Decode pane
2. Choose Show [protocol name] Layer from the right-click menu, or click the Set Protocol Filtering
button and un-check the layer or layers you want revealed.
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3.4.4 Physical vs. Logical Byte Display
The Event Display window and Event Pane in the Frame Display window show the physical bytes. In other
words, they show the actual data as it appeared on the circuit. The Radix, Binary and Character panes in the Frame
Display window show the logical data, or the resulting byte values after escape codes or other character altering
codes have been applied (a process called frame transformation).
As an example, bytes with a value of less than 0x20 (the 0x indicates a hexadecimal value) cannot be transmitted
in Async PPP. To get around this, a 0x7d is transmitted before the byte. The 0x7d says to take the next byte and
subtract 0x20 to obtain the true value. In this situation, the Event pane displays 0x7d 0x23, while the Radix pane
displays 0x03.

3.4.5 Sorting Frames
By default, frames are sorted in ascending numerical sequence by frame number. Click on a column header in the
Summary pane to sort the frames by that column. For example, to sort the frames by size, click on the Frame
Size column header.
An embossed triangle next to the header name indicates which column the frames are sorted by. The direction of
the triangle indicates whether the frames are in ascending or descending order, with up being ascending.
Note that it may take some time to sort large numbers of frames.

3.4.6 Frame Display - Find
Frame Display has a simple Find function that you can use to search the Decode Pane for any alpha numeric
value. This functionality is in addition to the more robust Search/Find dialog.
Frame DisplayFind is located below the toolbar on the Frame Display dialog.

Figure 3.9 - Frame Display Find text entry field
Where the more powerful Search/Find functionality searches the Decode, Binary, Radix, and Character panes
on Frame Display using TImestamps, Special Events, Bookmarks, Patterns, etc.,
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Figure 3.10 - Search/Find Dialog
Find on Frame Display only searches the Decode Pane for a value you enter in the text box.
To use Find:
1. Select the frame where you want to begin the search.
2. Enter a value in the Find text box.

Note: The text box is disabled during a live capture.
3.
Select Find Previous Occurrence
or Find Next Occurrence

to begin the search on frames prior to the frame you selected,

to begin the search on frames following the frame you selected.
The next occurrence of the value (if it is found) will be highlighted in
the Decode Pane.

4.

Select FindPrevious Occurrence or FindNext Occurrence to
continue the search.

There are several important concepts to remember with Find.
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When you enter a search string and select Enter, the search moves forward.
If you select Find Previous Occurrence, when the search reaches the first frame it will then cycle to the
last frame and continue until it reaches the frame where the search began.
Shift + F3 is a shortcut for Find Previous Occurrence.
If you select Find Next Occurrence, when the search reaches the last frame it will then cycle to the first
frame and continue until it reaches the frame where the search began.

l

F3 is a shortcut for Find Next Occurrence.

l

You cannot search while data is being captured.

l

After a capture is completed, you cannot search until Frame Display has finished decoding the frames.

l

Find is not case sensitive.

l

l

l

l

l

l

The status of the search is displayed at
the bottom of the dialog.
The search occurs only on the
protocol layer selected.
To search across all the protocols on
the Frame Display, select the
Unfiltered tab.
A drop-down list displays the search values entered during the current
session of Frame Display.
The search is cancelled when you select a different protocol tab during a
search.
You can cancel the search at any time by selecting the Cancel Current
Search
button.

3.4.7 Synchronizing the Event and Frame Displays
The Frame Display is synchronized with the Event Display. Click on a frame in the Frame Display and the
corresponding bytes is highlighted in the Event Display. Each Frame Display has its own Event Display.
As an example, here's what happens if the following sequence of events occurs.
1. Click on the Frame Display icon

in Control window toolbar to open the Frame Display.

2. Click on the Duplicate View icon

to create Frame Display #2.

3. Click on Event Display icon

in Frame Display #2. Event Display #2 opens. This Event

Display is labeled #2, even though there is no original Event Display, to indicate that it is synchronized
with Frame Display #2.
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4. Click on a frame in Frame Display #2. The corresponding bytes are highlighted in Event Display #2.
5. Click on a frame in the original Frame Display. Event Display #2 does not change.

3.4.8 Working with Multiple Frame Displays
Multiple Frame Displays are useful for comparing two frames side by side. They are also useful for comparing all
frames against a filtered subset or two filtered subsets against each other.
l

To create a second Frame Display, click the Duplicate View icon

on the Frame Display toolbar.

This creates another Frame Display window. You can have as many Frame Displays open as you wish.
Each Frame Display is given a number in the title bar to distinguish it from the others.
l

To navigate between multiple Frame Displays, click on the Frame Display icon

in the Control window

toolbar.
A drop-down list appears, listing all the currently open Frame Displays.
l

Select the one you want from the list and it comes to the front.
Note: When you create a filter in one Frame Display, that filter does not automatically
appear in the other Frame Display. You must use the Hide/Reveal feature to display a
filter created in one Frame Display in another.

Note: When you have multiple Frame Display windows open and you are capturing data, you
may receive an error message declaring that "Filtering cannot be done while receiving data
this fast." If this occurs, you may have to stop filtering until the data is captured.

3.4.9 Working with Panes on Frame Display
When the Frame Display first opens, all panes are displayed except the Event pane (To view all the panes,
select Show All Panes from the View menu).
l

The Toggle Expand Decode Pane icon

makes the decode pane longer to view lengthy decodes

better.
l

The Show Default Panes icon

l

The Show only Summary Pane icon

returns the Frame Display to its default settings.
displays on the Summary Pane.

To close a pane, right-click on the pane and select Hide This Pane from the pop-up menu, or de-select Show
[Pane Name] from the View menu.
To open a pane, right-click on the any pane and select Show Hidden Panes from the pop-up menu and select
the pane from the fly-out menu, or select Show [Pane Name] from the View menu.
To re-size a pane, place the cursor over the pane border until a double-arrow cursor appears. Click and drag on
the pane border to re-size the pane.

c
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3.4.10 Frame Display - Byte Export
The captured frames can be exported as raw bytes to a text file.
1. From the Frame Display File menu select Byte Export....

Figure 3.11 - Frame Display File menu, Byte Export
2. From the Byte Export window specify the frames to export.
l

l

All Frames exports all filtered-in frames including those scrolled off the Summary pane. Filtered-in
frames are dependent on the selected Filter tab above the Summary pane. Filtered-out frames are
not exported.
Selected Frames export is the same as All Frames export except that only frames selected in the
Summary pane will be exported.

Figure 3.12 - Byte Export dialog

Click the OK button to save the export. Clicking the Cancel button will exit Byte Export.
3. The Save As dialog will open. Select a directory location and enter a file name for the exported frames
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file.

Figure 3.13 - Save As dialog
Click on the Save button.
The exported frames are in a text file that can be opened in any standard text editing application. The header
shows the export type, the capture file name, the selected filter tab, and the number of frames. The body shows
the frame number, the timestamp in the same format shown in the Frame DisplaySummary pane, and the
frame contents as raw bytes.

Figure 3.14 - Sample Exported Frames Text File

3.4.11 Panes in the Frame Display
3.4.11.1 Summary Pane
The Summary pane

displays a one-line summary of every frame in a capture buffer or file, including frame

number, timestamp, length and basic protocol information. The protocol information included for each frame
depends on the protocol selected in the summary layer box (located directly below the main toolbar).

cii

NetDecoder Async User Manual

Chapter 3 Capture/Analyze

TELEDYNE LECROY

On a two-channel circuit, the background color of the one-line summary indicates whether the frame came from
the DTE or the DCE device. Frames with a white background come from the DTE device, frames with a gray
background come from the DCE device.
The ComProbe USB Summary pane in displays a one-line summary of every transaction in a capture buffer or
file. Whenever there is a transaction it is shown on a single line instead of showing the separate messages that
comprise the transaction. The Msg column in that case says “Transaction”.
Each message in a transaction contains a packet identifier (PID). All of the PIDs in a transaction are shown in the
transaction line.
All "IN" transactions (i.e. transactions that contain an IN token message) are shown with a purple background. All
other transactions and all non-transactions are shown with a white background. "IN" transactions have special
coloring because that is the only place where the primary data flow is from a device to the Host.
The protocol information included for each frame depends on the protocol selected in the summary layer box
(located directly below the main toolbar).
Frame numbers in red indicate errors, either physical (byte-level) or frame errors. If the error is a frame error in
the displayed protocol layer, the bytes where the error occurred is displayed in red. The Decode Pane gives
precise information as to the type of error and where it occurred.
The Summary pane is synchronized with the other panes in this window. Click on a frame in the Summary
pane, and the bytes for that frame is highlighted in the Event pane while the Decode pane displays the full
decode for that frame. Any other panes which are being viewed are updated accordingly. If you use one pane to
select a subset of the frame, then only that subset of the frame is highlighted in the other panes.
Protocol Tabs
Protocol filter tabs are displayed in the Frame Display above the Summary pane.
l

l

l

l

These tabs are arranged in separate color-coded groups. The General group applies to all technologies. The
other groups are technology-specific.
Clicking on a protocol filter tab in the General group filters in all packets containing that protocol regardless of
each packet’s technology.
Clicking on a protocol filter tab in a technology-specific group filters in all packets containing that protocol on
that technology.
A protocol filter tab appears in the General group only if the protocol occurs in more than one of the
technology-specific tab groups.

Select the Unfiltered tab to display all packets.
There are several special tabs that appear in the Summary pane when certain conditions are met. These tabs
appear only in the General group and apply to all technologies. The tabs are:
l

l

l

Bookmarks appear when a bookmark is first seen.
Errors appear when an error is first seen. An error is a physical error in a data byte or an error in the
protocol decode.
Info appears when a frame containing an Information field is first seen.

The tabs disappear when the capture buffer is cleared during live capture or when decoders are reloaded, even if
one of the tabs is currently selected. They subsequently reappear as the corresponding events are detected.
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The tabs disappear when the capture buffer is cleared during live capture or when decoders are reloaded, even if
one of the tabs is currently selected. They subsequently reappear as the corresponding events are detected.
Use the navigation icons, keyboard or mouse to move through the frames. The icons
the first and last frames in the buffer, respectively. Use the Go To icon

and

move you to

to move to a specific frame number.

Placing the mouse pointer on a summary pane header with truncated text displays a tooltip showing the full
header text.

Figure 3.15 - Summary pane (right) with Tooltip on Column 5 (Tran ID)

Sides in Bluetooth low energy
A Bluetooth low energy data connection consists of connection events, which are a series of transmissions on the
same channel. In each connection event the master transmits first, then the slave, and then the devices take turns
until the connection event is finished.
When the data connection is encrypted and the packets are successfully decrypted, the sniffer can determine
exactly who sent which packet (only non-empty, encrypted packets – empty packets are never encrypted). These
packets are labeled either ‘M’ for master or ‘S’ for slave.
When the data connection is unencrypted or when encrypted packets are not successfully decrypted by the
sniffer, the sniffer cannot distinguish the two devices’ (master and slave) packets by their content, just by the
packet timing. In those cases we label each device as side ‘1’ or ‘2’, not as master or slave. In each connection
event, packets sent by the device which transmitted first in the connection event are labeled ‘1’, and packets sent
by the device which transmitted second are labeled ‘2’.
If no packets in the connection event are missed by the sniffer, the device labeled ‘1’ is the master and the device
labeled ‘2’ is the slave. However, if we do not capture the very first packet in a connection event (i.e. the packet
sent by the master) but do capture the packet sent by the slave, we label the slave as side ‘1’ since it is the first
device we heard in the connection event. Because there is potential clock drift since the last connection event,
we cannot use the absolute timing to correct this error; there would still be cases where we get it wrong.
Therefore we always assign ‘1’ to the first packet in a connection event. So even though it is rare, there are
connection events where packets sent by the slave device are labeled ‘1’ and packets sent by the master are
labeled ‘2’.
Finally, in a noisy environment it is also possible that the sniffer does not capture packets in the middle of a
connection event. If this occurs and the sniffer cannot determine the side for the remaining packets in that
connection event, the side is labeled ‘U’ for “unknown”.
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3.4.11.2 Customizing Fields in the Summary Pane
You can modify the Summary Pane in Frame Display.
Summary pane columns can be reordered by dragging any column to a different position.
Fields from the Decode pane can be added to the summary pane by dragging any Decodepane field to the
desired location in the summary pane header. If the new field is from a different layer than the summary pane a
plus sign (+) is prepended to the field name and the layer name is added in parentheses. The same field can be
added more than once if desired, thus making it possible to put the same field at the front and back (for example)
of a long header line so that the field is visible regardless of where the header is scrolled to.
An added field can be removed from the Summary pane by selecting Remove New Column from the rightclick menu.
The default column layout (both membership and order) can be restored by selecting Restore Default
Columns from the Format or right-click menus.

Changing Column Widths
To change the width of a column:
1. Place the cursor over the right column divider until the cursor changes to a solid double arrow.
2. Click and drag the divider to the desired width.
3. To auto-size the columns, double-click on the column dividers.

Hiding Columns
To hide a column:
1. Drag the right divider of the column all the way to the left.
2. The cursor changes to a split double arrow when a hidden column is present.
3. To show the hidden column, place the cursor over the divider until it changes to a split double arrow, then
click and drag the cursor to the right.
4. The Frame Size, Timestamp, and Delta columns can be hidden by right-clicking on the header and
selecting Show Frame Size Column, Show Timestamp Column, or Show Delta Column. Follow
the same procedure to display the columns again.

Moving Columns - Changing Column Order
To move a column :
1. Click and hold on the column header
2. Drag the mouse over the header row.
3. A small white triangle indicates where the column is moved to.
4. When the triangle is in the desired location, release the mouse.

Restoring Default Column Settings
To restore columns to their default locations, their default widths, and show any hidden columns
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1. Right-click on any column header and choose Restore Default Column Widths, or select Restore
Default Column Widths from the Format menu.

3.4.11.3 Frame Symbols in the Summary Pane
Table 3.3 - Frame Symbols
Description

Symbol

A green dot means the frame was decoded successfully, and the protocol listed in the Summary
Layer drop-down box exists in the frame. No dot means the frame was decoded successfully, but the
protocol listed in the Summary Layer drop-down box does not exist in the frame.
A green circle means the frame was not fully decoded. There are several reasons why this might
happen.
l

l

One reason is that the frame compiler hasn't caught up to that frame yet. It takes some time for
the analyzer to compile and decode frames. Frame compilation also has a lower priority than other
tasks, such as capturing data. If the analyzer is busy capturing data, frame compilation may fall
behind. When the analyzer catches up, the green circle changes to either a green dot or no dot.
Another reason is if some data in the frame is context dependent and we don't have the context.
An example is a compressed header where the first frame gives the complete header, and
subsequent frames just give information on what has changed. If the analyzer does not capture the
first frame with the complete header, it cannot decode subsequent frames with partial header
information.

A magenta triangle indicates that a bookmark is associated with this frame. Any comments associated
with the bookmark appear in the column next to the bookmark symbol.

3.4.11.4 Frame Display - Right Click Filtering
In Frame Display, protocols are displayed as tabs in the Summary pane. When you select a tab, the protocol
layers are displayed. The layers vary depending on the protocol.
You can create additional protocol tabs that highlight specific layers in the Summary pane using the Filtering
Results dialog.
Note: The Filtering Results dialog is not available for all layers because the information
within those layers is not sortable, like time.
To use the Filtering Results dialog:
1. Right-click on a value in the Summary pane. For
example, the "S" for Slave under Role
2. On the drop-down list select Filter in name =
value, where name is the column name and
value is the column-value to filter. For our
example "Filter in Role = Slave" appears in the
menu.
The Filtering Results dialog appears.
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3. Enter a name for the Filter or use the default name.
4. Click OK.
A new protocol tab with the "Filter Name" you just created appears in the Summary pane.
The new tab displays data specific to the layer you selected.

3.4.11.5 Decode Pane
The Decode pane (aka detail pane)

is a post-process display that provides a detailed decode of each frame

transaction (sometimes referred to as a frame). The decode is presented in a layered format that can be
expanded and collapsed depending on which layer or layers you are most interested in. Click on the plus sign to
expand a layer. The plus sign changes to a minus sign. Click on the minus sign to collapse a layer. Select Show All
or Show Layers from the Format menu to expand or collapse all the layers. Layers retain their expanded or
collapsed state between frames.
Protocol layers can be hidden, preventing them from being
displayed on the Decode pane. Right-click on any protocol layer
and choose Hide [protocol name] from the right-click menu.
In a USB transaction, all messages that comprise the transaction
are shown together in the detail pane. The color coding that is
applied to layers when the detail pane displays a single message
is applied to both layers and messages when the detail pane displays a transaction. To keep the distinction
between layers and messages clear, each header of each message in the detail pane ends with the word
“Message” or “Messages”. The latter is used because data and handshake messages are shown as a single colorcoded entry
Each protocol layer is represented by a color, which is used to highlight the bytes that belong to that protocol
layer in the Event, Radix, Binary and Character panes. The colors are not assigned to a protocol, but are
assigned to the layer.
The Event, Radix, Binary, Character and Decode panes are all synchronized with one another. Clicking on an
element in any one of the panes highlights the corresponding element in all the other panes.
Click the Toggle Expand Decode Pane icon

to make the Decode pane taller. This allows for more of a

lengthy decode to be viewed without needing to scroll.

3.4.11.6 Radix or Hexadecimal Pane
The Radix pane displays the logical bytes in the frame in either
hexadecimal, decimal or octal. The radix can be changed from
the Format menu, or by right-clicking on the pane and
choosing Hexadecimal, Decimal or Octal.
Because the Radix pane displays the logical bytes rather than
the physical bytes, the data in the Radix pane may be different
from that in the Event pane. See Physical vs. Logical Byte Display
for more information.
Colors are used to show which protocol layer each byte belongs
to. The colors correspond to the layers listed in the Decode
pane.
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The Event, Radix, Binary, Character and Decode panes are all synchronized with one another. Clicking on an
element in any one of the panes highlights the corresponding element in all the other panes.

3.4.11.7 Character Pane
The Character pane represents the logical bytes in the frame
in ASCII, EBCDIC or Baudot. The character set can be
changed from the Format menu, or by right-clicking on the
pane and choosing the appropriate character set.
Because the Character pane displays the logical bytes rather
than the physical bytes, the data in the Character pane may
be different from that in the Event pane. See Physical vs.
Logical Byte Display for more information.
Colors are used to show which protocol layer each byte
belongs to. The colors correspond to the layers listed in the
Decode pane.
The Event, Radix, Binary, Character and Decode panes
are all synchronized with one another. Clicking on an element
in any one of the panes highlights the corresponding element in all the other panes.

3.4.11.8 Binary Pane
The Binary pane displays the logical bytes in the frame in binary.
Because the Binary pane displays the logical bytes rather than the physical bytes, the data in the Binary pane may
be different from that in the Event pane. See Physical vs. Logical Byte Display for more information.
Colors are used to show which protocol layer each byte belongs to. The colors correspond to the layers listed in
the Decode pane.
The Event, Radix, Binary, Character and Decode panes are all synchronized with one another. Clicking on an
element in any one of the panes highlights the corresponding element in all the other panes.

3.4.11.9 Event Pane
The Event pane shows the physical bytes
in the frame. You can choose between
displaying only the data events or
displaying all events by clicking the All
Events icon
.
Displaying all events means that special
events, such as Start of Frame, End of
Frame and any signal change events, are
displayed as special symbols within the
data.
The status lines at the bottom of the pane give the same information as the status lines in the Event Display
window. This includes physical data errors, control signal changes (if appropriate), and timestamps.

cviii

NetDecoder Async User Manual

Chapter 3 Capture/Analyze

TELEDYNE LECROY

Because the Event pane displays the physical bytes rather than the logical bytes, the data in the Event pane may
be different from that in the Radix, Binary and Character panes. See Physical vs. Logical Byte Display for more
information.
Colors are used to show which protocol layer each byte belongs to. The colors correspond to the layers listed in
the Decode pane.
The Event, Radix, Binary, Character and Decode panes are all synchronized with one another. Clicking on an
element in any one of the panes highlights the corresponding element in all the other panes.

3.4.11.10 Change Text Highlight Color
Whenever you select text in the Binary, Radix, or
Character panes in Frame Display, the text is displayed
with a highlight color. You can change the color of the
highlight.
1. Select Change Text Highlight Color from the
Options menu. You can also access the option by
right clicking in any of the panes.
2. Select a color from the drop-down menu.
3. Click OK.
The highlight color for the text is changed.
Select Cancel to discard any selection. Select Defaults to return the highlight color to blue.

3.4.12 Data Byte Color Notation
The color of the data in the panes specifies which layer of the protocol stack the data is from. All data from the
first layer is bright blue, the data from the second layer is green, the third layer is pink, etc. The protocol name for
each layer in the Decode pane is in the same color. Note that the colors refer to the layer, not to a specific
protocol. In some situations, a protocol may be in two different colors in two different frames, depending on
where it is in the stack. You can change the default colors for each layer.
Red is reserved for bytes or frames with errors. In the Summary pane, frame numbers in red mean there is an
error in the frame. Also, the Errors tab is displayed in red. This could be a physical error in a data byte or an error
in the protocol decode. Bytes in red in the Radix, Character, Binary and Event panes mean there is a physical
error associated with the byte.

3.4.12.1 Red Frame Numbers and Bytes
Red is reserved for bytes or frames with errors. In the Summary pane, frame numbers in red mean there is an
error in the frame. This could be a physical error in a data byte or an error in the protocol decode. Bytes in red in
the Radix, Character, Binary and Event panes mean there is a physical error associated with the byte.

3.4.12.2 Changing Protocol Layer Colors
You can differentiate different protocol layers in the Decode, Event, Radix, Binary and Character panes.
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1. Choose Select Protocol Layer Colors from the Options menu to change the colors used.
The colors for the different layers is displayed.
2. To change a color, click on the arrow next to each layer and select a new color.
3. Select OK to accept the color change and return to Frame Display.
Select Cancel to discard any selection. Select Defaults to return the highlight colors to the default settings.

Figure 3.16 - Frame Display Protocol Layer Color Selector

3.4.13 Filtering
Filtering allows the user to control the display which capture frames are displayed. Filters fall into two general
categories:
1. Display filters allow a user to look at a subset of captured data without affecting the capture content.
Frames matching the filter criteria appear in the Frame Display; frames not matching the criteria will not
appear.

3.4.13.1 Display Filters
A display filter looks at frames that have already been captured. It looks at every frame in the capture buffer and
displays those that match the filter criteria. Frames that do not match the filter criteria are not displayed. Display
filters allow a user to look at a subset of captured data without affecting the capture content. There are three
general classes of display filters:
l

Protocol Filters

l

Named Filters

l

Quick Filter

Protocol Filters
Protocol filters test for the existence of a specific single layer. The system creates a protocol filter for each
decoder that is loaded if that layer is encountered in a capture session.
There are also three special purpose filters that are treated as protocol filters:

cx
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l

All Frames with Errors

l

All Frames with Bookmarks

l

All Special Information Nodes
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Named Filters
l

l

Named filters test for anything other than simple single layer existence. Named filters can be constructed that
test for the existence of multiple layers, field values in layers, frame sizes, etc., as well as combinations of
those things. Named filters are persistent across sessions.
Named filters are user-defined. User-defined filters persist in a template file. User defined filters can be
deleted.

Quick Filters
l

Quick Filters are combinations of Protocol Filters and/or Named Filters that are displayed on the Quick Filter
tab.

l

Quick Filters cannot be saved and do not persist across sessions.

l

Quick Filters are created on the Quick Filter Dialog.

3.4.13.1.1 Creating a Display Filter
There are two steps to using a display filter. Define the filter conditions, and then apply the filter to the data set.
The system combines both filter definition and application in one dialog.
1. Click the Display Filters icon

on the Frame Display

window or select Apply/Modify

Display Filters from the Filter menu to open the Set Condition dialog box. The Set Condition dialog is
self configuring which means that when you Select each frame under Conditions the following
displayed fields depend on your selection. With each subsequent selection the dialog fields will change
depending on you selection in that field.

Figure 3.17 - Example: Set Conditions Self Configuring Based on Protocol Selection
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Figure 3.18 - Example: Set Conditions Self Configuring Based on Frame Range
2. Select Include or Exclude to add filtered data or keep out filtered data respectively.
3. Select the initial condition for the filter from the drop-down list.
4. Set the parameters for the selected condition in the fields provided. The fields that appear in the dialog
box are dependent upon the previous selection. Continue to enter the requested parameters in the fields
provided until the condition statement is complete.
5. Click OK. The system displays the Save Named Condition dialog. Provide a name for the filter condition
or accept the default name provided by the system and click OK. Prohibited characters are left bracket '[',
right bracket ']' and equal sign '='. The Set Condition dialog box closes, creates a tab on the Frame
Display with the filter name, and applies the filter.
The filter also appears in the Quick Filtering and Hiding Protocols dialog.
When a display filter is applied, a description of the filter appears to the right of the toolbar in the Frame Display
windows.
Notes:
l

l

l

The system requires naming and saving of all filters created by the user.
The OK button on the Set Condition dialog box is unavailable (grayed out) until the condition selections are
complete.
When you have multiple Frame Display windows with a display filter or filters, those filter do not automatically
appear in other Frame Display windows. You must use the Hide/Reveal feature to display a filter created in
one Frame Display in different Frame Display window.

3.4.13.1.2 Including and Excluding Radio Buttons
All filter dialog boxes contain an Include and an Exclude radio button. These buttons are mutually exclusive. The
Include/Exclude selection becomes part of the filter definition, and appears as part of the filter description
displayed to the right of the Toolbar.
Include: A filter constructed with the "Include" button selected, returns a data set that includes frames that meet
the conditions defined by the filter and omits frames that do not.
Exclude: A filter constructed with the "Exclude" button selected, returns a data set that excludes frames that
meet the conditions defined by the filter and consists of frames that do not.
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3.4.13.1.3 Named Display Filters
You can create a unique display filter by selecting a data type on the Frame Display and using a right click menu.
When you create a Name Filter, it appears in the Quick Filtering dialog, where you can use it do customize the
data you see in the Frame Display panes.
1. Select a frame in the Frame DisplaySummary Pane.
2. Right click in the one of the data columns in the Summary Pane: CRC, NESN, DS, Packet Success,
Ethertype, Source Address, etc.
3. Select Filter in (data type) = . The Filtering Results
dialog appears.
4. Enter a name for the filter
5. Select OK.
The filter you just created appears in the Named Filters section
of the Quick Filtering dialog.

3.4.13.1.4 Using Compound Display Filters
Compound filters use boolean logic to create complex and precise filters. There are three primary Boolean logic
operators: AND, OR, and NOT.
The AND operator narrows the filter, the OR operator broadens the filter, and the NOT operator excludes
conditions from the filtered results. Include parentheses in a compound filter to nest condition sets within larger
condition sets, and force the filter-processing order.
There are two steps to using a compound filter. Define the filter conditions, and then apply the filter to the data
set. The analyzer combines both filter definition and application in one dialog.
1. Click the Display Filters icon

on the Frame Display window or select Apply/Modify Display

Filters… from the filter menu to open the Set Condition dialog box.
2. Click the Advanced button on the Set Condition dialog box.
3. Select Include or Exclude radio button.
Now you can set the conditions for the filter.
4. Select the initial condition for the filter from the
combo box at the bottom of the dialog for Select
each frame.
5. Set the parameters for the selected condition in
the fields provided. The fields that appear in the
dialog box are dependent upon the previous
selection. Continue to enter the requested
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parameters in the fields provided until the conditions statement is complete.

Figure 3.19 - Two Filter Conditions Added with an AND Operator
6. Click the plus icon
Use the up

on the left side of the dialog box and repeat steps 4 and 5 for the next condition.

and down

the delete button

arrow icons on the left side of the dialog box to order your conditions, and

to delete conditions from your filter.

7. Continue adding conditions until your filter is complete.
8. Include parentheses as needed and set the boolean operators.
9. Click OK.
10. The system displays the Save Named Condition dialog. Provide a name for the filter condition or accept
the default name provided by the system and click OK.

Figure 3.20 - Save Named Filter Condition Dialog
The Set Condition dialog box closes, creates a tab on the Frame Display with the filter name, and applies the
filter.
When a display filter is applied, a description of the filter
appears to the right of the toolbar in the Frame
Display windows.
Note: The OK button on the Set Condition dialog box is unavailable (grayed out) until the
condition selections are complete.
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3.4.13.1.5 Defining Node and Conversation Filters
There are two steps to using Node and Conversation display filter. Define the filter conditions, and then apply the
filter to the data set. The analyzer combines both filter definition and application in one dialog.
1. Click the Display Filters icon

on the Frame Display window or select Apply/Modify Display

Filters… from the filter menu to open the Set Condition dialog box.
2. From the Select each frame combo box choose frames with the conversation as the initial condition.
3. Select an address type—IP, MAC, TCP/UDB—from the Typecombo box (The address type selection
populates both Address combo boxes with node address in the data set that match the type selection).
4. Select a node address from the first Address combo box.
5. Choose a direction arrow from the direction box . The left arrow filters on all frames
where the top node address is the destination, the right arrow filters on all frames
where the top node address is the source, and the double arrow filters on all frames
where the top node address is either the source or the destination.
6. If you want to filter on just one node address, skip step 7 and continue with step 8.
7. If you want to filter on traffic going between two address nodes (i.e. a conversation), select a node address
from the second Address combo box..
8. Click OK. The Set Condition dialog box closes and the analyzer applies the filter.
When a display filter is applied, a description of the filter appears to the right of the toolbar in the Frame Display
windows.
Note: The OK button is unavailable (grayed out) until the condition selections are complete.

3.4.13.1.6 The Difference Between Deleting and Hiding Display Filters
If you wish to remove a filter from the system permanently, then use the Delete procedure. However, if all you
want to do is remove a filter as a means to un-clutter the display, then use the Hide procedure.
Deleting a saved filter removes the filter from the current session and all subsequent sessions. In order to retrieve
a deleted filter, the user must recreate it using the Set Conditions dialog.
Hiding a filter merely removes the filter from the display. A hidden filter can be reapplied using the Show/Hide
procedure.
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Deleting Saved Display Filters
1. Select Delete Display Filters from the Filter
menu in the Frame Display
window to
open the Delete Named Condition dialog.
The system displays the Delete Named
Condition dialog with a list of all user defined
filters.
2. Select the filter to be deleted from the list.
3. Click the Delete button.
4. Click OK. The Delete Named Condition
dialog box closes and the system deletes the
filter.

Hiding and Revealing Display Filters
If a display filter is showing the following steps will hide
that filter but will not delete it.
1. Select Hide/Show Display
Filters… from the Filter menu on the
Frame Display
window to open
the Hide/Show Filters dialog. The
system displays the Hide/Show
Filters dialog with a list of all user
defined filters.
2. Select the filter to be hidden from the
combo box.
3. Click the Hide button. The Hide button is only showing if the selected filter is currently showing in the
Frame Display.
4. Click OK. The Hide/Show Filters dialog box closes, and the system hides the filter and removes the filter
tab from the Frame Display.
If a display filter is hidden the following steps will reveal that filter in the Frame Display.
1. Select Hide/Show Display Filters… from the Filter menu in the Frame Display

window to

open the Hide/Show Filters dialog. The system displays the Hide/Show Filters dialog with a list of all
user defined filters.
2. Select the filter to be revealed from the combo box.
3. Click the Show button.
4. Click OK. The Hide/Show Filters dialog box closes and the system reveals the filter in the Frame
Display.
You can also open the Quick Filter dialog and check the box next to the hidden filter to show or hide a display
filter.
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Figure 3.21 - Using Named Filters Section of Quick Filters to Show/Hide Filters
Note: When you have multiple Frame Display windows with a display filter or filters, those
filter do not automatically appear in other Frame Display windows. You must use the
Hide/Show dialog to display a filter created in one Frame Display in different Frame Display
window.

3.4.13.1.7 Editing Filters
Modifying a Condition in a Filter
1. Click the Display Filters icon
Display

on the Frame

window or select Apply/Modify Display

Filters… from the Filter menu to open the Set
Condition dialog box. The Set Condition dialog box
displays the current filter definition at the top of the dialog.
To display another filter, click the Open
icon, and
select the filter from the pop-up list of all the saved filters.
2. Edit the desired parameter of the condition: Because the required fields for a condition statement depend
upon previously selected parameters, the Set Condition dialog box may display additional fields that were
not present in the original filter. In the event this occurs, continue to enter the requested parameters in
the fields provided until the condition statement is complete.
3. Click OK. The system displays the Save Named Condition dialog. Ensure that the filter name is
displayed in the text box at the top of the dialog, and click OK. If you choose to create an additional filter,
then provide a new name for the filter condition or accept the default name provided by the system and
click OK.) The Set Condition dialog box closes, and the system applies the modified filter.
Note: When a display filter is applied, a description of the filter appears to the right of the
toolbar in the Frame Display windows.

Deleting a Condition in a Filter
If a display filter has two or more conditions you can delete conditions. If there is only one condition set in the
filter you must delete the filter using Delete Display Filters… from the Filters menu.
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1. Click the Display Filters icon

on the Frame Display window or select Apply/Modify Display

Filters… from the Filter menu to open the Set Condition dialog box. Click on the Advanced button to
show the condition in Boolean format. The dialog box displays the current filter definition. To display
another filter, click the Open
icon, and select the filter from the pop-up list of all the saved filters.

Figure 3.22 - Set Condition Dialog in Advanced View
2. Select the desired condition from the filter definition.
3. Click the Delete Selected Line

icon.

4. Edit the Boolean operators and parentheses as needed.
5. Click OK. The system displays the Save Named Condition dialog. Ensure that the filter name is
displayed in the text box at the top of the dialog, and click OK. (If you choose to create an additional filter,
then provide a new name for the filter condition or accept the default name provided by the system and
click OK.) The Set Condition dialog box closes, and the system applies the modified filter.
Note: When a display filter is applied, a description of the filter appears to the right of the
toolbar in the Frame Display windows.

Renaming a Display Filter
1. Select Rename Display Filters… from the Filter menu in the Frame Display

window to open

the Rename Filter dialog. The system displays the Rename Filter dialog with a list of all user defined
filters in the Filters combo box.
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Figure 3.23 - Rename Filters Dialog
2. Select the filter to be renamed from the combo box.
3. Enter a new name for the filter in the New Name box. Optionally click the Apply button and the new
name will appear in the Filters combo box and the New Name box will empty. This option allows you to
rename several filters without closing the Rename Filter dialog each time.
4. Click OK. The Rename Filter dialog box closes and the system renames the filter.

3.4.13.2 Protocol Filtering from the Frame Display
3.4.13.2.1 Quick Filtering on a Protocol Layer
On the Frame Display , click the Quick Filtering icon

or select Quick Filtering from the Filter menu.

This opens a dialog that lists all the protocols discovered so far. The protocols displayed change depending on the
data received.

Figure 3.24 - Frame Display Quick Filtering and Hiding Protocols Dialog
The box on the left is Protocols To Filter In. When you select the checkbox for a protocol in the Protocols to
Filter In, the Summary pane will only display those frames that contain data from that protocol.
If you filter on more than one protocol, the result are all frames that contain at least one of
those protocols. For example, if you filter on IP and IPX NetBIOS, you receive all frames that
contain either IP or IPX NetBIOS (or both). A Quick Filter tab then appears on the Frame
Display. Changing the filter definition on the Quick Filter dialog changes the filter applied on the Quick Filter
tab. Quick filters are persistent during the session, but are discarded when the session is closed.
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The box in the center is the Protocols To Hide. When you select the checkbox for a protocol in the Protocols
To Hide, data for that protocol will not appear in the Decode, Binary, Radix, and Character panes. The
frames containing that type data will still appear in the Summary pane, but not in the Decode, Binary, Radix,
and Character panes.
The box on the right is the Named Filters. It contains filters that you create
using the and dialogs. When you select the checkbox for the Name Filters,
a tab appears on the Summary Pane that displays the frame containing the
specific data identified in the filter. The named Filter tab remains on the
Frame Display Summary Pane unless you hide it using the
dialog.
With low energy, the Configured BT Low energy devices and
Exclude NULLS and POLLs are default named filters.
Check the small box next to the name of each protocol you want to filter in,
hide, or Named Filter to display.
Then click OK

3.4.13.2.2 Easy Protocol Filtering
There are two types of easy protocol filtering. The first method lets you filter on the protocol shown in the
Summary pane, and the second lets you filter on any protocol discovered on the network so far.

Filtering on the Summary Layer Protocol
To filter on the protocol in the Summary in the Frame Display window pane:
1. Select the tab of the desired protocol, or open the Summary combo box.
2. Select the desired protocol.
3. To filter on a different layer, just select another tab, or change the layer selection in the combo box.

Filtering on all Frames with Errors
To filter on all frames with errors:
1. Open the Frame Display

window.

2. Click the starred Quick Filter icon

or select Quick Filtering from the Filter menu

3. Check the box for All Frames With Errors in the Protocols To Filter In pane, and click OK.
4. The system creates a tab on the Frame Display labeled "Errors" that displays the results of
the All Frames With Errors filter.
Note: When you have multiple Frame Display windows open and you are capturing data, you
may receive an error message declaring that "Filtering cannot be done while receiving data
this fast." If this occurs, you may have to stop filtering until the data is captured.
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3.5 Analyze Control Signal Changes - Breakout Box
The Breakout Box window provides a real-time graphical view of control signals. The window is customizable
based on the control signals you wish to view and your preference of indicators (+/-, 1/0, T/F, arrows, and
simulated LEDs). Also included are counters showing the number of times a control signal has changed.
To open this window click the Breakout Box icon

on the Control window.

Whenever an enabled input changes state it will issue an event and be tagged with a timestamp of when the input
was interpreted by the analyzer. Digital inputs can not exceed a rate of 30 MHz. Digital inputs that occur faster
than that are not guaranteed to be interpreted correctly by the analyzer. Also, only one digital input event may
occur per active packet. All other digital input events can only be handled after the packet has completed. Digital
inputs, although guaranteed to have the correct timestamp given the previous conditions, have the possibility of
being presented out of order because they are provided randomly by the user and have no direct correlation to
the bus. It is important to note that the digital inputs are susceptible to cross-talk if they are not being actively
driven. A situation like this could occur if a digital input has been enabled, but has not been tied to a signal. Any
other nearby signal (i.e., other digital inputs or outputs) could cause the input to activate. It is recommended that
all undriven digital inputs be disabled or tied to ground.
USB: Name - Pin 1, 2, 3, and 4
ComProbe USB monitors four control signals.

Figure 3.25 - ComProbe USB Breakout Box Display
Digital inputs provide a means for users to insert events into the data stream. There are four digital inputs that can
be enabled individually.
HSU: Frontline monitors six RS-232 control signals
DTE Signals
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Figure 3.26 - ComProbe HSU Breakout Box Display
When monitoring a synchronous circuit, the analyzer also displays clock signals at the bottom of the window.
These signals rotates when clock is present, and has an X over them if clock is not detected.
3.5.1 The Breakout Box Toolbar
Table 3.4 - Breakout Box Toolbar Icons
Icon

Description
Home - brings the Control window to the front.
Reset - resets the Breakout Box window.
Lock - Locks the display. Clicking on the Lock icon, unlocks the window.
Unlock - In the Unlock state, the screen fills in the data captured since the screen lock and
moves down to display incoming data again. Clicking on the Unlock icon, locks the window.
Options - Brings up the Breakout BoxOptions window. This window allows you to change
the window refresh rate and choose which control signals to display.

3.5.2 Reading the Breakout Box Window
The Breakout Box display is divided into three main parts. The first part (to the far left of the screen) shows the
abbreviated name of the control signal being monitored. These names can be changed in the I/O Settings window
by selecting Names from the Options menu.
The second part shows the control signal counters. The counters show how many times each control signal has
changed state. This is useful in situations when signals may be changing state too rapidly to be displayed
graphically.
Below the counters are the clock indicators. The indicators rotate when clock is present, and have an X over them
when clock is not detected.
The third part of the Breakout Box shows the current states of the control signals. The indicators show the state
that the control signal is currently in, and the line graph displays the state of the signal over time. A single line
means that the signal is logically off, while a double line means that the signal is logically on. A half-height "tick"
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means that a signal has gone through one full transition (from off to on to off, or vice versa) since the analyzer last
updated the screen.
To change the indicators, hide the clock signals, or change the rate at which the analyzer updates the window,
click on the Options icon
.

3.5.3 Selecting Breakout Box Options
To access Options click the Options icon

on the Breakout Box toolbar or choose Breakout Box

options under the Options menu.
Display Signal - This box shows which control signals the analyzer monitors.
l

l

A check mark next to a control signal name indicates that the breakout box displays the status of that
control signal.
To prevent the analyzer from displaying the status of a signal, un-check the box next to it.

Display Clocks - Click to place a check mark in this box if you want the Breakout Box window to display the
clock indicators. Un-check to hide the clock indicators. (This option is only shown when in synchronous or
isochronous mode.)
Window Refresh Rate - The refresh rate is the rate at which the analyzer updates the window.
l

l

By default, the analyzer refreshes the display once every 1,000 milliseconds (one second.)
To change the rate, highlight the number in the box and enter a new number. See Performance Notes for
information on how Window Refresh Rate can affect performance.

Indicators - You can choose what type of indicators the analyzer uses.
l

l

l

The default indicators are a green "+" sign to show a logically high state, and a red "-" sign to show a
logically low state.
To change the indicators, click on the down arrow and choose a pair of indicators from the list.
As a reminder, the analyzer gives the definition of the indicators in the top part of the Breakout Box
window.

3.5.4 Viewing Historical Signal Changes
The Signal Display window provides a graphical view of control signal transitions that you can manipulate. You
can zoom in to view the state of control signals for a range of events, or zoom out to view control signal changes
over the course of an entire capture session.
To open this window click the Signal Display icon

on the Control window toolbar, or choose Signal

Display from the Window menu.
The Signal Display window does not provide a real-time view of control signal changes. It is intended to be
used as a post-process review screen. Use the Breakout Box window to view real-time control signal changes.
Note that if you bring up the Signal Display window while data is being captured, the window shows you the
state of the control signals at the time the window was opened. This is called a "snapshot" because it is a picture of
the buffer at the time the Signal Display was opened. To update the display to reflect the current state of the
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.

When you open Signal Display you will see a set of codes. For USB ComProbe II, USB, you will see Pin Codes 1, 2, 3,
and 4. These correspond to the four Digital Input Enabling Options explained in USB I/O Settings.
For all High Speed Serial Sniffing options you will see six control signals. These include:
l

RTS(Request to Send DCE Signal)

l

CTS (Clear to Send)

l

DSR (Data Set Ready

l

DTR (Data Terminal Ready)

l

CD (Carrier Data)

l

RI (Ring Indicator)

Figure 3.27 - USB Signal Display Window

Figure 3.28 - HSU Signal Display Window
When using the SST interface cards for analyzing DeviceNet traffic, the following signals are displayed:
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BP - Bus Power

l

OL - Online

l

l

l

l

l
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BW - Bus warning, either the receive or transmit error counter (incremented and decremented at various
rates according to the Bosch CAN specification) has reached 128.
BO - Bus off, either the receive or transmit error counter has reached 255 and the CAN chip has been forced
offline.
RO - Receive buffer overrun, one or more messages has been lost due to a full queue in the on-card firmware.
ML - Message lost, one or more messages has been lost due to a slow interrupt response by the on-card
firmware.
ER - Error, one or more CAN error frames has been detected.
Note: The messages received by NetDecoder are still correct when the ER flag shows some
activity, as re-transmission is automatic and only error-free frames result in a receive interrupt
from the CAN controller.

3.5.4.1 Signal Display Toolbar
Table 3.5 - Signal Display Toolbar
Icon

Description
Home - brings the Control window to the front.
Take New Snapshot - Takes a new "picture" of the capture buffer. If you are capturing data
when you open the Signal Display window, the window shows only the state of the control
signals that were in the buffer when the window was opened. Click this button to update the
window with the contents of the current buffer.
Zoom In - "Zooms in" on the signal display. How much you zoom in is determined by your
selection in the Signals menu. You can zoom in by a factor of 2, 4, or 8.
Zoom Out - Reverse of Zoom In.
Zoom to Selection - Zooms to show only the region highlighted on the screen. If the
highlighted area contains few events, the Signal Display window may also display
additional events in order to fill up the screen.
Display Entire Buffer - Zooms all the way out to display the contents of the entire buffer in
the window.
Find - Opens the Control Signal change window.
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Table 3.5 - Signal Display Toolbar (continued)

Icon

Description
Snap to Nearest Change - Moves the cursor to the nearest signal change whenever you
click on the line graphics in the window. Find the line for the control signal whose changes
you want to see. Click on that line, and the analyzer moves to the nearest signal change for
that control signal. You can also highlight a range, and the analyzer snaps to the 2 nearest
changes on either side of the range.
Timestamping Options - Opens the Timestamping Options window, where you can change
the timestamping resolution and how timestamps are displayed.

3.5.4.2 Reading the Signal Display
Control signal changes are displayed in a graphical format. On the left side of the screen is a list of the signals
currently being displayed, and to the right of each name is a line displaying the state of the signal over time. A
single line means that the signal was logically off, while a double line means that the signal was logically on. Dotted
lines are used for signals that were not present at the time of capture. For example, if you are monitoring a circuit
that does not use CD, that line appears as a dotted line in the control signal display.
The four information lines at the bottom of the window tell you what events are being shown in the window, and
where you are in relation to the buffer as a whole.
l

l

l

l

Current Snapshot: The first line tells you what event numbers are in the current snapshot, the total number
of events, and the amount of time that passed between the first event in the snapshot and the last event
(called Delta).
Current Visible: The second line gives the same information about the events that are currently visible in
the window. Because you can zoom in and out, often the events being shown in the window are not the same
as the number of events in the current snapshot.
Currently Selected: The third line gives the same information for the currently selected events. You can
highlight a range of events by clicking at any point on the graphical display and dragging the mouse to the left
or the right. The third line shows information for the selected range.
Selected Time: The fourth and last line shows the exact timestamps of the first and last bytes in the currently
selected range. Note that this does not tell you the timestamp for the entire snapshot or the events displayed
in the window, just the highlighted events. The raw timestamp value is the number of 100-nanosecond
intervals since the beginning of January 1, 1601. This is standard Windows time.

A single mouse click places the cursor in the window. The analyzer highlights all sixfour signal changes in one
color, and uses a different color to specify the control signal line clicked on. You can highlight a range by clicking
and dragging the mouse to the right or left. You can also use the arrow keys to move the cursor to the right or left.
The Signal Display window is synchronized with other windows in the analyzer. A range highlighted in the Signal
Display window is also highlighted in the Event Display and Frame Display windows.
The Snap to Nearest Change icon

lets you place the cursor on the signal change you want to look at

without needing to click on exactly the right spot. Find the line corresponding to the control signal you want to
look at. Click on the line, and the analyzer moves the cursor to the nearest change. If you highlight a range, the
analyzer "snaps to" the nearest changes on either side. This feature is active when the Snap To button is pressed,
and inactive when the button is not pressed.
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Use the Zoom In and Zoom Out buttons to increase and decrease the magnification of the window. The
analyzer changes the magnification by a factor of 2, 4 or 8, depending on the option selected in the Signals menu.
If you want to see a range in greater detail, highlight the range you want to view and click on the Zoom to
Selection icon
. The analyzer zooms in to show only that range in the window. If the range is small, the
analyzer may add additional events to fill up the window. To view the entire snapshot in the window, click on the
Display Entire Buffer icon
.
Note that if you bring up the Signal Display window while data is being captured, the window shows you the
state of the control signals at the time the window was opened. To update the display, use the New Snapshot icon
.

3.5.4.3 Selecting Signal Display Options
To access Signal Display Options Click the Signal Display icon

on the Control window toolbar. From the

Options menu, select Signal Display Options.
To choose which control signals to display in the Signal Display window:
l

Click on a box to check or un-check it the control signal name.

l

A check mark next to a control signal name means that the signal is displayed.

Figure 3.29 - USB Signal Display Options

Figure 3.30 - HSU Signal Display Options
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3.6 Statistics Window
The Statistics window supplies basic information about the data on the network. When reviewing a capture file,
the Statistics window shows a summary of the data in the file.

Figure 3.31 - Statistics Window
To open the Statistics window, click the Statistics icon

on the Control window toolbar, or choose

Statistics from the View menu on the Control window.
The analyzer monitors the network and collects statistics all the time, even when data is not actively being
captured. Activate the Lock icon
to stop the window from updating. Click the Unlock icon
again to
resume updating. The analyzer continues to monitor network traffic while the Statistics window is locked, so
you may see the numbers jump right after updating has resumed, reflecting all the statistics that were gathered
while the window was locked.
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Statistics Window Menus
Table 3.6 - Statistics Window Menus
Menu
Edit

View

Selection

Description

Copy All To
Clipboard

Copies all collected statistics to the Windows clipboard.

Notes

Opes the notes dialog for recording comments on a capture file. Only
available when view a capture file.

Copy Utilization To
Clipboard

Copies the channel utilization statistics to the Windows clipboard.

Copy Octets/Sec To
Clipboard

Copies throughput rate statistics to the Windows clipboard.

Copy Data To
Clipboard

Copies data statistics to the Windows clipboard.

Copy Errors To
Clipboard

Copies channel parity and framing errors to the Windows Clipboard.

Copy Buffer To
Clipboard

Copies the current buffer data to the Windows clipboard

Control Window
Event Display
Frame Display
Signal Display

When checked will open the window or Statistics Window bar. When
not checked, the window or bar is closed.

Breakout Box
Toolbar
Status Bar

Graph

Toggle Display Lock

When checked, the displayed statistics will stop updating, although
data is still being captured. Unchecking will resume statistics
updating.

Reset

Available during live capture. Resets all displayed statistics and
restarts the calculations.

Graph Errors...

Opens the Errors HSU window.

Options I/O Settings...
Set Timestamping
Format

Performs the same function as the control Window Options Menu, I/O
Settings
Opens the Timestamping Options window that allows for changing the
resolution of the timestamps.

Change the Font Size Opens a pop-up with font size selections.
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Table 3.6 - Statistics Window Menus (continued)

Menu

Selection

Description

Window Close Window

Closes the Statistics Window

ComProbe Protocol
Analysis System
Statistics

Clicking on these selections will change the focus from the Statistics
Window to the selected window.

Errors
Help

Help Topics

Opens the ComProbe Help window.

About ComProbe
Protocol Analysis
System

Provides a pop-up showing the version and release information,
Frontline contact information, and copyright information.

Support on the Web

Opens a browser to fte.com technical support page.

Statistics Window Toolbar
Table 3.7 - Statistics Window Toolbar Icons
Icon

Description
Changes the focus to the Control
Window
Reset the statistics tables
Display Lock/Unlock
Timestamp Format

3.6.1 Session, Resettable and Capture File Tabs
The Session and Resettable tabs are parts of the Statistics window.
Information about all data collected since the analyzer was started is shown in the Session tab. The Session tab
cannot be reset; in this sense, it is like the odometer on a car. The odometer on a car shows you all the miles
driven since the car was built, and the Session tab shows you all the data collected since the analyzer was started.
If you think of the Session tab as the odometer, then the Resettable tab is the trip odometer. It can be reset, and
allows you to record statistics for a new "trip". In this way you can effectively start a new session without having to
restart the analyzer.
The Capture File tab shows information on the data that is currently in the capture.
Occasionally some of the statistics read n/a, for Not Available. This happens for various reasons. For example,
many of the items on the Capture File tab become not available (n/a) if the buffer becomes full and wraps. When
this happens, the analyzer can no longer provide accurate statistics for the data in the file, because some of the
data that the statistics are based on has been lost.

cxxx

NetDecoder Async User Manual

Chapter 3 Capture/Analyze

TELEDYNE LECROY

3.6.2 Copying Statistics To The Clipboard
To copy the information from an individual table to the clipboard (where it can be pasted into any application),
1. Choose the name of the table from the Edit menu.
2. To copy the contents of all the tables, choose Copy All to Clipboard.

3.6.3 Statistics Graphs
Open the Statistics window and click on the picture of a graph

on the table header, or choose the graph

name from the Graph menu on the Statistics window.
The Frame Sizes Graph window has Session, Resettable and Buffer tabs that correspond to the tabs on the
Statistics window. Each tab shows the data that corresponds to the appropriate tab on the Statistics window.
The Frame Sizes Graph window displays the number of frames of each length in either a pie chart or bar graph
format. Click the Pie icon
to display a pie chart, and click the Bar icon
to display a bar graph.
For networks with more than one side, the analyzer displays one graph for each side. To view the aggregate of all
sides, click the Aggregate icon
.

3.6.3.1 Viewing Percentages or Values
On the Statistics window you can view data expressed as a percentage.
1. Open the Statistics window
2. Select the graph to display.
On the graph window,
3. Click the Percentages icon

to view data expressed as a percentage.

4. Click the Percentages icon again to view the actual number of items of each type.
5. Click the Show Data Grid icon

to view both the number and percentage of the total for each item.

The analyzer places a grid in the legend.

3.6.3.2 Changing the Graph Refresh Rate
The graphs window refreshes once every second.
To change the refresh rate:
1. Click the Options icon

on the Errors dialog.

2. Enter a new refresh rate in milliseconds in the Time Interval (ms) text box.
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3.6.3.3 Printing Graphs
1. Click the Print icon

to print the graph. The analyzer prints exactly what is shown on the window.

3.6.4 Session Tab Tables
The Statistics dialog Session tab contains tables that display information about the current capture session.
Table 3.8 - Frames per Second Table Fields
Description

Field
Current

The current number of frames per second

Average The average number of frames per second for the current session
Peak

Table 3.9 - Characters per Second Table Fields
Description

Field
Baud

The highest number of frames per second.

The current baud rate.
A baud rate is the number of times per second a signal in a communications channel changes.

Current

The current number of characters per second.

Average The average number of characters per second for the current session
Peak

The highest number of characters per second.

Table 3.10 - Utilization Table Fields
Description

Field
Current

The current number of bits per second divided by the maximum speed of the network,
expressed as a percentage.

Average The average number of bits per second divided by the maximum speed of the network,
expressed as a percentage.
Peak

The highest recorded utilization.

Field

Table 3.11 - Data Table Fields
Description

Data The amount of data captured by the analyzer.
Data information varies depending on the type of data in the capture.
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Table 3.12 - Buffer Information Table Fields
Description

Field
Driver Buffer
Overflow

The number of times the analyzer lost frames because it could not retrieve them from the
driver buffer fast enough.

Field

Table 3.13 - Errors Table Fields
Description

Errors The number of errors seen on the
network.
To graph, click the bar graph
the Errors table header.

icon on

3.6.5 About DH+ Statistics
The Frontline DH+ product includes powerful statistical analysis capabilities. Easily accessible and up to date
statistical data provides the user with valuable information when starting up, surveying, benchmarking, and
troubleshooting DH+ networks.
DH+ statistics runs automatically when a capture file is loaded or when a live capture is performed and cannot be
turned off. All of its dialogs can be brought down, however.
Note: Driver buffer overflows and UART overruns during live capture cause data loss that can
result in some invalid frames. This can affect the values shown in DH+ statistics. To prevent
driver buffer overflows, try increasing "Driver Receive Buffer Size in Operating System
Pages" in the Control window Options menu: System Settings > Advanced. To prevent
UART overruns, try running on a faster machine. Driver buffer overflows and UART overruns
are also displayed on the regular Statistics screen, accessible from the Control window
Statistics

3.6.5.1 Starting DH+ Statistics
DH+ Statistics is started from the NetDecoder application. DH+ Stats should launch automatically when the
application is started. However, if it does not start automatically, then follow the steps below.
Launch NetDecoder Protocol Analyzer for DH+, and perform the following:
1. From the File menu on the Control window., open the desired capture file
2. The system should display the DH+ Overview dialog.
3. If the dialog does not appear, then open the View menu on the Control window.
4. Select DH+ Statistics.
3.6.5.2 About the Statistics Overview Dialog
The DH+ Statistics Overview screen displays key information pertaining to the overall health of the network in
tabular format, as well as an Active Devices grid that identifies all the devices currently on the network.
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The three table displays on the overview screen provide the user with current statistical information on Top
Talkers, Top Conversations and Token Rotation Times. The overview screen affords the user easy access to
detailed information on individual devices, graphs of statistical data, and statistics on Network Bytes Sent,
Transactions Summary, and a Network Event Log. The Overview dialog is the main dialog. All other dialogs are
reached either directly or indirectly from this dialog.
DH+ Statistics provides powerful network monitoring capabilities. For this reason, the Overview dialog displays
statistical data updated in real-time, as do all dialogs in DH+ Statistics.
The Active Devices grid appears in the upper-left corner of the dialog. This simplifies network monitoring by
allowing the user to drag the Overview dialog to the lower right-hand corner of the computer screen hiding all
but the Active Devices grid and the Synopsis information.

Figure 3.32 - DH+ Statistics Overview dialog.

3.6.5.2.1 Active Devices Grid
The Active Devices grid appears on the Statistics Overview dialog. This grid is a color-coded 8 x 8 grid that shows
the current status of each device. Clicking on a device square in the grid brings up the Device Transactions dialog
for that device. A colored square is used for conditions where the device is or has been present. A triangle in the
upper-right corner of a square is used for conditions where the device may never have been present.
The Active Devices Grid color code is as follows:
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l

Gray: Device never present

l

Green: Device present and OK

l

Yellow: Device present with at least one error

l

Red: Device absent (dropped off bus)

l

Blue: Device present, previously dropped off bus (supercedes yellow)

l

Black: (Optional) Device has not reappeared after grid reset

TELEDYNE LECROY

l

Cyan Triangle: A long-responder takes between 5 seconds and 60 seconds to respond

l

Orange Triangle: A non-responder takes more than 60 seconds to respond or no immediate ACK/NAK

Yellow Grid Errors
A device can have the following "condition yellow" errors:
l

Sent NAK to a Command or Reply.

l

Had missing or truncated field in a frame.

l

Sent a Token, Solicit, Command, or Reply but wasn't the token holder.

l

Sent ACK or NAK but hadn't received a Command or Reply.

l

Sent to an invalid (out of range) device number.

l

Sent to itself.

3.6.5.2.1.1 Device Transactions Dialog
The Device Transactions dialog shows transaction statistics for a selected device.
Access this dialog by clicking on the desired device number in the Active Devices grid on the Overview dialog.
A transaction is a sequence of messages consisting of a Command followed by a Reply, with an ACK or NAK after
each one, as follows:
1. Device A sends a Command to device B.
2. Device B sends an ACK or NAK to device A.
3. If device B sent an ACK, it then sends a Reply to device A.
4. Device A sends an ACK or NAK to device B.
The Device Transactions dialog provides detailed statistics on all traffic to and from the selected device. This
dialog lists the conversation types on the left side, and displays the statistics for each in the adjacent table. The list
items contain both the message type (Commands, Replies, ACKS, NAKS) and the associated action (Sent to,
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Received from). In addition, the table contains statistics on device response times. Response time statistics used in
conjunction with statistics from other devices assist in identifying worst-case conditions.
The top table displays statistics for traffic originating from the selected device. Conversely, the bottom table
displays statistics for traffic originated by other devices and directed toward the selected device.
On a well-behaved network with no errors, the numbers of Commands, Command ACKs, Replies, and Reply ACKs
are all equal. These numbers can be unequal in the table due to many factors, including transmission noise, partial
token rotations discarded by DH+ Stats (this is normal behavior), un-captured frames (frames that occurred before
or after the capture session), frames missed by DH+ Stats, and absent devices. To determine whether network or
device errors have occurred, consult either the Network Event Log or the Active Devices grid (look for a device
box that is yellow, red, or blue, or has an orange/cyan triangle in the upper right corner).
Minimum, maximum, and average response times are displayed at the bottom of each table. A response time is
the amount of time between a Command and its Reply. Commands and Replies are tied together by looking for
equal transaction numbers in the PCCC layer. Negative response times and response times that exceed 10
seconds are discarded (the former is an error and the latter is assumed to be an error). In the minimum and
maximum fields, the Command and Reply frame numbers can be displayed by checking the “Show frame
numbers” checkbox.
The device number is displayed in the header and in each corner of the dialog to enable easy identification of
each dialog when multiple device dialogs overlap each other on the screen.
The top table of the Device Transactions dialog shows statistics for transactions which begin when the device
specified in the dialog header receives Commands from a device specified at the top of a table column.
Table 3.14 - Received Transactions
Transaction
(row)
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Description

Recvd Cmds

Commands that the header device received from a column
device.

Sent Cmd ACKs

ACKs that the header device sent to a column device in response
to a Command from the column device.

Sent Cmd NAKs

NAKs that the header device sent to a column device in response
to a Command from the column device.

Sent Replies

Replies that the header device sent to a column device.

Recvd Reply
ACKs

ACKs that the header device received from a column device in
response to a Reply from the header device.

Recvd Reply
NAKs

NAKs that the header device received from a column device in
response to a Reply from the header device.

Min Response
Time

Minimum response time

Max Response
Time

Maximum response time

Avg Response
Time

Average response time

No Reply Within
60 Secs

Number of occurrences of no reply within 60 seconds
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The bottom table of the Device Transactions dialog shows statistics for transactions which begin when the device
specified in the dialog header sends Commands to a device specified at the top of a table column.
Table 3.15 - Sent Transactions
Row

Description

Sent Cmds

Commands that the header device sent to a column device.

Recvd Cmd ACKs

ACKs that the header device received from a column device in
response to a Command from the header device.

Recvd Cmd NAKs

NAKs that the header device received from a column device in
response to a Command from the header device.

Recvd Replies

Replies that the header device received from a column device.

Sent Reply ACKs

ACKs that the header device sent to a column device in
response to a Reply from the column device.

Sent Reply NAKs

NAKs that the header device sent to a column device in
response to a Reply from the column device.

Min Response
Time

Minimum response time

Max Response
Time

Maximum response time

Avg Response
Time

Average response time

No Reply Within
60 Secs

Number of occurrences of no reply within 60 seconds

The drop down menu provides selections to display the data as:
l

Message Count

l

Message Count Percentage (Percentage of the total number of messages)

l

Byte Count

l

Byte Count Percentage (Percentage of the total number of bytes)

Clicking the Apply settings to all transaction dialogs button applies the selection in the drop down box to
the Transaction Summary dialog.

3.6.5.2.2 Active Devices Grid Buttons
These buttons, located to the right of the Active Devices Grid on the DH+ Statistics Overview window
activate the following displays:
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Table 3.16 - Active Devices Grid Buttons
Description

Button

Displays the help topic for the Active Devices Grid
Displays the Network Bytes Sent dialog
Displays the Transactions Summary dialog
Displays the Network Event Log dialog
With the exception of the grid, numbers of devices that have never been present are enclosed in double
parentheses, and numbers of devices that are currently absent but have been present are enclosed in single
parentheses.
Note: Driver buffer overflows and UART overruns (both shown on the regular Statistics
screen, reachable via the Control window View menu Statistics selection) during live capture
cause data loss that can result in some invalid frames. This can affect the values shown in
DH+ Stats. To prevent driver buffer overflows, try increasing Driver Receive Buffer Size in
Operating System Pages in the Advanced in the "Control Window System Settings menu.
To prevent UART overruns, try running on a faster machine. For further assistance please
contact Technical Support.
3.6.5.2.3 Status
Status appears just below the Synopsis.
Status can display the following:
Remark

Table 3.17 - DH+ Statistics Status Remarks
Description

Capturing to
file

Displayed during a live capture to file

Done
capturing to
file

Displayed when a live capture to file finishes

Reading
capture file

Displayed when the capture file is first opened, before displaying any statistics

Reading
capture file
(n%)

Displayed when there are statistics displayed for one or more frames. This indicates
how much of the capture file has been processed by the plug in

Loading stats
file

Displayed while a statistics file is being loaded

Stats file
Displayed when a statistics file is fully loaded. The “n%” is the percentage of the capture
loaded (n% of file’s frames that were sent to DH+ Stats (some of which may have been missed by
capture)
DH+ Stats).
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Table 3.17 - DH+ Statistics Status Remarks (continued)
Description

Unable to load Displayed when a statistics file cannot be loaded. Usually caused by an obsolete version
number contained in the statistics file.
stats file
Exiting

Displayed when DH+ Stats is being terminated. This status usually appears for just an
instant.

3.6.5.2.4 Top Talkers Chart
The Top Talkers chart appears in the top right portion of the DH+ Statistics Overview dialog.
l

l

The Top Talkers display sorts the device list by Byte Count , allowing the user to identify which devices use
most of the available network bandwidth.
The calculated statistics displayed in the Top Talkers table include data only from Command and Reply
messages, and does not include data from required protocol messages (ACK, NAK, Token and Solicit).

Selecting the More button displays the Top Talkers Dialog, which displays both a graph and a table.

3.6.5.2.5 Top Conversations Chart
The Top Conversations information table appears in the middle right portion of the DH+ Statistics Overview
dialog.
l

l

The Top Conversations statistic sorts the device list by Byte Count, allowing the user to quickly identify
which pair of devices generate the most traffic on the network.
The statistics displayed in the Top Conversations table includes data only from Command and
Reply messages, and does not include data from required protocol messages (ACK, NAK, Token and Solicit).

Selecting the More button displays the Top Conversations Dialog which displays both a graph and a table.

3.6.5.2.6 Token Rotations Summary Chart
The Token Rotation Summary information table appears across the bottom portion of the DH+ Statistics
Overview dialog. This table contains information about the Token Rotation Times, including minimum, maximum,
average and current values. Token Rotation Times directly relate to network performance. The values in the
summary table are an indicator of system throughput and performance. DH+ Statistics calculates and displays
actual response times on the individual Device Transaction dialog as well as the Transaction Summary dialog.
The measured Token Rotation Time for each of the four indicators (minimum, maximum, average, and current)
appears in the Duration column. Typically, a complete Token Rotation starts when a Token passes from a higher
device ID number to a lower device ID number. Then it passes up through incrementing device ID numbers.
When the highest active ID numbered device obtains the Token and passes it to a lower device ID number, the
Token Rotation ends and the next one begins.
Selecting the More button displays the Token Rotations dialog which displays both a graph and a table.
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3.6.5.2.6.1 Device Token Rotations Dialog
The Device Token Rotation dialog is accessed by clicking on the Rotations button in a Device Transactions dialog.
The Device Token Rotation dialog displays minimum, maximum, average, and total values for the selected device
against the following parameters:
l

duration token held

l

total Bytes sent per token rotation (this is all bytes from all messages)

l

Command Bytes Sent Per Token Rotation

l

Reply Bytes Sent Per Token Rotation

For the minimum and maximum values, the Date and Time of Occurrence and the Frame range are also
displayed against each of the above parameters. The frame range begins with the frame in which the specified
device receives the token, and ends with the frame in which the specified device sends the token to another
device. This means that the last frame of a given token rotation and the first frame of the next token rotation are
the same frame. The device number is displayed in the header and in each corner of the dialog to enable easy
identification of each dialog when multiple device dialogs overlap each other on the screen. Pressing the
Transactions button returns to the Device Transactions dialog.
Note: The Duration Token Held field is negative (and is discarded) when the same device
receives the token, then sends it, then receives it again within what appears to be a single
token rotation (when this happens it is typically due to missing frames). Since DH+ Stats
simply saves the time-stamp each time and subtracts the receive time-stamp from the send
time-stamp, the result is negative (and is discarded).

3.6.5.2.7 Network Throughput
DH+ “Message” frames carry PCCC payload. The “Message” frames are either ‘Commands’ or ‘Replies’.
Throughput for a single frame is defined as the ratio of the actual number of data bytes (PCCC payload plus any
Data layer) that constitute either the Command or Reply to the total number of bytes sent in the frame. In other
words, the throughput is a measure of the overhead involved in transferring data over a DH+ network. If the
throughput is high, then it implies that the control messaging overhead is low.
NetDecoder displays the throughput value for all frames seen in the most recent second. Let’s look at an example
to get a better idea of how the NetDecoder software computes this value.
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Figure 3.33 - DH+ in the Frame Display, example
In this screenshot, Frame 219 is a Reply from Node 40 to a Command from Node 1. Notice that the actual Reply
part of the PCCC layer is only 12 bytes. But the total length of Frame 219 is 26 bytes. So the throughput for this
single frame is 12/26 = 46.15%.
The NetDecoder software keeps a running tally of the total bytes and actual data bytes in every frame it
encounters. These values are used to compute the throughput for the most recent second.
3.6.5.2.8 Setting Display Options
Display Options selections affect how statistics data is displayed by DH+ Statistics, not how it is stored.
To access the Display Options dialog:
1. Select Options from the Options menu on the Overview dialog, and the system displays the DH+
Options dialog
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Figure 3.34 - DH+ Options dialog
2. Add or remove the desired display options using the check boxes
3. Click the OK button to apply the display options
The Display Options dialog closes, and applies the selected options

Display Options definitions
Optons

DH+ Display Options
Description

Default

Display Unchecked Statistical data is often displayed in tabular format. DH+ Statistics stores a value
a blank
for each cell in these tables. If there is no value for a particular cell, then the
instead
system stores a value of zero. Some tables may contain many cells with a zero
of a zero
value, and when these tables are displayed, they may appear cluttered and hard
value
to read. Selecting this option changes the table displays to hide zeros in the cells
that contain only a zero value.
Show a
Checked
blank
instead
of a zero
value in
CSV file

This option hides the zeros in cells that contain a zero value in a CSV file in the
same way that the "Display a blank instead of a zero value" does in the tables.

Display
reset
devices
in black

This option affects the Active Devices grid display. DH+ Statistics is equipped
with a means to reset all of the colors displayed in the active devices grid to Gray.
This option allows the user to reset previously active devices to display in black
instead of gray. This separates those devices from the ones in the grid that were
never active.

Checked

3.6.5.3 Network Statistics
3.6.5.3.1 Busy Tokens Dialog
To access the Busy Tokens dialog, select Busy Tokens from the View menu in the Overview dialog.
The Busy Tokens dialog shows busy token data in both a graph and a table.
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Figure 3.35 - DH+ Overview Busy Tokens dialog
The graph displays the percentage of busy and unused tokens for the active devices in stacked bars, mauve for
Busy, white for Unused.
The table displays:
l

Device Identifier

l

Percentage of busy tokens

l

Number of busy tokens

l

Number of unused tokens

l

Total tokens

3.6.5.3.2 Network Bytes Sent Dialog
To access the Network Bytes Sent dialog, select Network Bytes Sent from the View menu or select the
Network button from the Overview dialog.
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Figure 3.36 - DH+ Overview Network Bytes Sent dialog
The Network Bytes Sent dialog is simple and comprehensive. It shows the number of bytes sent by each device,
by message type, including unknown messages. The value in the Total column of the Total row is the same
number displayed in the Byte Count field of the Overview dialog.
The device numbers are displayed at the top of each column.
The Totals Only button displays the Network Bytes Sent Totals dialog.

3.6.5.3.3 Network Bytes Sent Totals Dialog
To access the Network Bytes Sent Totals dialog, select Network Bytes Sent Totals from the View menu in
the Overview dialog, or click on the Totals Only button on the Network Bytes Sentdialog.

cxliv
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DH+ Overview Network Bytes Sent dialog
The Network Bytes Sent Totals dialog is a copy of the Total column of the Network Bytes Sent dialog. The
Devices button displays the Network Bytes Sent dialog.
DH+ Statistics uses the size of the frame as it appears on the DH+ wire to compute Byte Count. This is equivalent to
the size of the Frontline software physical frame minus one byte.

3.6.5.3.4 Network Event Log Dialog
To access the Network Event Log dialog, click on the Log button or select Network Event Log from the View
menu in the Overview dialog.
The Network Event Log dialog displays a breakdown of various network events that are automatically logged.
This information provides additional details about the health of the network. This log stores the most recent 2000
events. Checkbox selections at the bottom of the dialog determine which events the system logs.

Events
The system logs the following events:
Event

Table 3.18 - Network Event Log Events
Description

Color and Shape

Event

Description

Color and Shape in Grid

Appeared

Device appeared for the first time

Green square

Dropped off bus

Device dropped off the bus

Red square

Reappeared

Device reappeared after dropping
off the bus

Blue square (supercedes a yellow
square)
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Table 3.18 - Network Event Log Events (continued)
Description
Color and Shape

Sent NAK to a Command or Reply

Device sent a NAK immediately
Yellow square
after receiving a Command or Reply

Had missing or truncated field in a
frame.

Device had one or more decode
errors.

Yellow square

Token/Solicit/Command/Reply sent Device sent a token, solicit,
Yellow square
but not by token holder
Command, or Reply but was not the
most recent device to be sent the
token.
Sent ACK or NAK but hadn't
received Command or Reply

Device sent an ACK or NAK, but the
previous message on the wire was
not a Command or Reply that was
sent to that device.

Sent to an invalid (out of range)
device number

Device sent a message with a
Yellow square
destination device number that was
not in the range 00..77 octal.

Sent from an invalid (out of range)
device number

A source device number in a
message was not in the range
00..77 octal.

n/a

Sent to itself

The source and destination device
numbers in a message were the
same.

Yellow square

Long Responder - (reply took
longer than 5 seconds)

Device was the destination of a
Command and immediately sent
ACK but the reply took between 5
and 60 seconds

Cyan triangle in upper-right-corner
of square

Non-Responder - (no reply within
60 seconds)

A non-responder takes more than
60 seconds to respond or does not
respond at all

Orange triangle in upper-rightcorner of square

Non-Responder - (no ACK or NAK)

Device was the destination of a
Command and didn't send an ACK
or NAK

Yellow square

Gap in frame sequence numbers

One or more frames are missing as n/a
determined by noting a gap in the
frame sequence numbers. Detailed
info is shown in the “Missing and
Excluded Frames” dialog.

Duration between frames exceeds
0.5 seconds

Bytes are assumed to be missing
because the duration between two
adjacent frames exceeded 0.5
seconds. Detailed info is shown in
the “Missing and Excluded Frames”
dialog.
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Table Columns
l

l

l

l

l

l

Each table column is sorted in each direction by clicking on the column header.
When any column except the first (Seq) is sorted, the first column is used as a secondary sort key so that the
seq nums are also sorted within each range of equal fields in the sorted column.
When writing to the CSV file, the current sort order is used.
While a device is absent, Non-Responder events for that device are condensed (logged only once with a count
range, with all other fields set to the first event in the range).
All future occurrences of an event are logged if the corresponding event checkbox is checked, and excluded if
the corresponding event checkbox is unchecked.
Sequence number gaps indicate excluded or condensed events.

Table columns are as follows:
Network Event Log Columns
Description

Column
Seq

Event sequence number, starting at 1. Every event receives a sequence number, even events that
are not logged (due to being excluded or condensed).

Dev

Device number

Event

Event description

Count

Number of occurrences of that combination of Event, Dev, and Msg Dev (device numbers that
appear in the Event field are ignored). This is shown as a range for condensed events.

Frame

Frame number where event occurred.

Rotation

Token rotation number where event occurred. In the case of a gap in the frame sequence
numbers or more than 0.5 seconds between frames, the token rotation is excluded and its
number is shown in parentheses. Note that the next included token rotation has the same
number (i.e. excluding a token rotation does not result in a gap in the token rotation numbers).

Timestamp Time of occurrence
Msg Dev

Number of device that sent a Command or Reply. Set only when the event is "Non-Responder...".

Msg Frame Frame number of a Command or Reply. Set only when the event is "Non-Responder ...".

3.6.5.3.5 Top Talkers Dialog
The Top Talkers dialog displays statistics on bandwidth usage by device.
You access the Top Talkers dialog by clicking on the More button located above the Top Talkers table on the
Overview dialog, or by selecting Top Talkers from the View menu on the Overview dialog.
The graph displays Command and Reply byte count sent by a single device in byte count order. All devices that
have ever been present on the bus appear in the graph, regardless of whether they sent any Command or Reply
messages. Graph bars display the byte count percentage at the top of each bar.
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The table displays device Command and Reply byte count, percentage of total Command and Reply bytes on
the network, Command and Reply message count, percentage of total Command Reply message count, and
average length. The table sorts the device list by Byte Count, allowing the user to identify which devices use
most of the available network bandwidth.
The calculated statistics displayed in the Top Talkers table and graph only includes data from Command and
Reply messages, and does not include data from required network Protocol messages (ACK, NAK, Token and
Solicit).
Top Talkers Column Headings:
DH+ Overview Top Talkers Columns
Column

Description

Dev Num

Device address in octal

Byte Count*

Number of Command and Reply bytes sent by a
device

%Bytes

Percentage of all network Command and Reply
bytes sent by a device

Msg Count

Number of Command and Reply messages sent by
a device

%Msgs

Percentage of all network Command and Reply
messages sent by a device

Avg Len

Average Length of Command and Reply messages
sent by a device

* DH+ Statistics uses the size of the frame as it appears on the DH+ wire to compute Byte Count. This is
equivalent to the size of the Frontline software physical frame minus one byte.

3.6.5.3.6 Top Listeners Dialog
Access the Top Listeners dialog by selecting Top Listeners from the View menu on the Overview dialog.
The graph displays Command and Replybyte count received by a single device in byte count order. All devices that
have ever been present on the bus appear in the graph, regardless of whether they received any Command or
Reply messages. Graph bars display the byte count percentage at the top of each bar.
The table displays device Command and Reply byte count, percentage of total Command and Reply bytes on the
network, Command and Reply message count, percentage of total Command Reply message count, and average
length. The table sorts the device list by Byte Count .
The calculated statistics displayed in the Top Listeners table and graph includes only data from Command and
Reply messages, and does not include data from required network protocol messages (ACK, NAK, Token and
Solicit).
Top Listeners Column Headings:
DH+ OverviewTop Listeners Columns
Column
Dev Num

cxlviii

Description
Device address in octal
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DH+ OverviewTop Listeners Columns (continued)
Column
Description
Byte Count*

Number of Command and Reply bytes received by a
device

%Bytes

Percentage of all network Command and Reply
bytes received by a device

Msg Count

Number of Command and Reply messages
received by a device

%Msgs

Percentage of all network Command and Reply
messages received by a device

Avg Len

Average Length of Command and Reply messages
received by a device

* DH+ Statistics uses the size of the frame as it appears on the DH+ wire to compute Byte Count. This is
equivalent to the size of the Frontline software physical frame minus one byte.

3.6.5.3.7 Top Conversations Dialog
The Top Conversations dialog displays conversation statistics.
Access the Top Conversations dialog by clicking on the More button located above the Top Conversations
table on the Overview dialog, or by selecting Top Conversations from the View menu on the Overview dialog.
A “conversation” consists of Command and Reply messages sent between two specific devices. The graph shows
command and reply byte count for each pair of devices sorted first by byte count and then by device pair. All
device pairs are shown for all devices that appeared on the bus, regardless of whether the devices in the pair
communicated with each other.
The scale across the bottom of the graph identifies the device pair using their two digit octal number identifiers,
and the scale up the side of the graph lists the byte count. Each bar provides a graphic representation of its
associated device pair's byte count usage with respect to other device pairs on the network, and the percentage
of total byte usage by each device pair appears on each bar.
The table below the graph sorts the device list by Byte Count. The statistics displayed in the table includes only
data from device-controlled command and reply messages, and does not include data from required protocol
messages (ACK, NAK, Token and Solicit).
Top Conversations Column Headings include:
DH+ OverviewTop Conversations Columns
Column
Description
Dev Num

Device pair addresses in octal

Byte Count*

Number of Command and Reply bytes sent
between a device pair

%Bytes

Percentage of all network Command and Reply
bytes sent between a device pair

Msg Count

Number of Command and Reply messages sent
between a device pair
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DH+ OverviewTop Conversations Columns (continued)
Column
Description

%Msgs

Percentage of all network Command and Reply
messages sent between a device pair

Avg Len

Average Length of Command and Reply messages
sent between a device pair

* DH+ Statistics uses the size of the frame as it appears on the DH+ wire to compute Byte Count. This is
equivalent to the size of the Frontline software physical frame minus one byte.

3.6.5.3.8 Transactions Summary Dialog
Access the Transactions Summary dialog by clicking the Transactions button on the Overview dialog or
selecting Transactions Summary from the View menu on the Overview dialog. This dialog lists a breakdown
of the Command and Reply transactions as well as response times for each device on the network.
On a well-behaved network with no errors, the numbers of Commands, Command ACKs, Replies, and Reply ACKs
are all equal. These numbers can be unequal in the table due to many factors, including transmission noise, partial
token rotations discarded by DH+ Stats (this is normal behavior), un-captured frames (frames that occurred before
or after the capture session), frames missed by DH+ Stats, and absent devices. To determine whether network or
device errors have occurred, consult either the Network Event Log or the Active Devices grid (look for a device
box that is yellow, red, or blue, or has a red triangle in the upper right corner).
Response time statistics reflect network throughput and assist with identifying worst-case conditions.
The top table of the Transactions Summary dialog shows statistics for transactions which begin when other devices
receive Commands from a device specified at the top of a table column.
Row

cl

Table 3.19 - DH+ Receive Commands Transaction Summary Rows
Description

Recvd Cmds

Commands that other devices received from a column device.

Sent Cmd ACKs

ACKs that other devices sent to a column device in response to a Command from the
column device.

Sent Cmd NAKs

NAKs that other devices sent to a column device in response to a Command from the
column device.

Sent Replies

Replies that other devices sent to a column device.

Recvd Reply ACKs

ACKs that other devices received from a column device in response to a Reply from
other devices.

Recvd Reply NAKs

NAKs that other devices received from a column device in response to a Reply from
other devices.

Min Response Time

Minimum response time

Max Response Time

Maximum response time

Avg Response Time

Average response time

No Reply Within 60
Secs

Number of occurrences of no reply within 60 seconds
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The bottom table of the Transactions Summary dialog shows statistics for transactions which begin when other
devices send Commands to a device specified at the top of a table column.
Row

Table 3.20 - DH+ Sent Commands Transaction Summary Rows
Description

Sent Cmds

Number of commands received

Recvd Cmd ACKs

ACKs that other devices received from a column device in response to a Command
from the other device.

Recvd Cmd NAKs

NAKs that other devices received from a column device in response to a Command
from the other device.

Recvd Replies

Replies that other devices received from a column device.

Sent Reply ACKs

ACKs that other devices sent to a column device in response to a Reply from the
column device.

Sent Reply NAKs

NAKs that other devices sent to a column device in response to a Reply from the
column device.

Min Response Time Minimum response time
Max Response
Time

Maximum response time

Avg Response
Time

Average response time

No Reply Within 60
Secs

Number of occurrences of no reply within 60 seconds

Clicking the Show Frame Numbers check box adds the frame numbers to the Minimum Response Time
and Maximum Response Time associated with this data in both tables.
The drop down menu provides selections to display the data as:
l

Message Count

l

Message Count Percentage (Percentage of the total number of messages)

l

Byte Count

l

Byte Count Percentage (Percentage of the total number of bytes)

Clicking the Apply settings to all transaction dialogs button applies the selection in the drop down box to
the individual Device Transaction dialogs.

3.6.5.3.9 Token Rotations Dialog
You access the Token Rotations dialog by clicking on the More button located above the Token Rotations
table on the Overview dialog, or by selecting Token Rotations from the View menu on the Overview dialog.
The Token Rotations dialog displays the values of the last 2000 maximum and the last 2000 minimum Token
Rotation Times, and is limited to 4000 total entries. If no more than 4000 token rotations are processed, then
all are shown.
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The table shows a sequence number (where the first token rotation is number 1), the token rotation, duration,
the date and time of occurrence, and the number of the first frame in the token rotation. The graph shows token
rotation durations in order of occurrence. These values identify the best and worst case Token Rotation Times.
Token Rotation Times directly affect the throughput capabilities of the network.

Sorting
The table can be sorted by sequence number or token rotation duration in ascending or descending order.
Whenever the sorting method is changed, the table automatically scrolls back to the top. Choose the sorting
method from the drop down field just above the table display. The graph, however, cannot be sorted.

Scrolling
When the table or graph scroll bar slider is at the top or leftmost it stays there while additional events accumulate
in the log, otherwise it is adjusted as necessary so that the first displayed entry retains its position. If that entry is
removed (because it is no longer one of the 2000 max or 2000 min durations), then an adjacent entry takes its
place on the display.

Graph Points
The number of points in the graph is selectable in multiples of 10 from 10 to 300. Click the up and down arrows
in the Max Points field to change the number of points displayed in the graph.

Selecting Entries
Selecting an entry in the graph automatically selects the corresponding entry in the table and vice versa ,
regardless of how the data is sorted in the table. Use the Ctrl and Shift keys to select contiguous and noncontiguous entries. When a graph entry is selected and the corresponding entry is not already visible in the table,
the selected entry is highlighted and scrolled to the top of the table. When a table entry is selected and the
corresponding entry is not already visible in the graph, the selected entry is highlighted and scrolled to the middle
of the graph.

Y-Axis Max
The “Y-Axis Max” field sets the height of the y-axis and is provided primarily to allow the user to deal with the
degenerate case of the entire network pausing for a long time. When that happens, the single token rotation
duration that includes the time that the network was paused can dwarf the other token rotation durations to the
point of near-invisibility. Setting the y-axis height to an appropriate value pushes the outlier(s) past the top of the
graph while placing the rest of the values below the top of the graph. Checking the Auto box causes the y-axis
height to be adjusted dynamically such that the height of the largest token rotation duration is 95-99% of the
height of the graph (regardless of whether that token rotation duration is currently visible on the graph). The Auto
box is checked by default.
The Token Rotations Summary displays minimum, maximum, average, and current values against the
following parameters:
l

Duration (the token rotation duration time)

l

Date and Time of Occurrence (of token rotation)

l

Frame (the number of the first frame in the token rotation)

l

Busy (the number of busy tokens)

l

%Busy (the percentage of busy tokens)
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The following parameters display "Message Count", or "Byte Count" depending upon the selection made in the
Messages drop down box located just above the Token Rotations Summary table.
l

Token

l

Solicits

l

Commands

l

Replies

l

ACKs

l

NAKs

3.6.5.4 Statistics Files
The statistics file contains all of the stats data in binary format. It has the base name of the capture file and the
extension “sts”, and is located in the same directory as the capture file. It is created automatically when a capture
file is opened or when a live capture is begun, and is updated every 10 seconds while frames are being received
and once more when frames stop being received. It’s closed after each update so that it persists after a system
crash.
When a capture file is opened, the associated stats file is loaded if it exists. Displaying a stats file results in the
exact same stats data being displayed that were displayed when either the capture file was closed or live mode
was exited, except that the Status field on the Overview dialog says “Stats file loaded” instead of “Done reading
capture file”.
Each stats file contains the version number of DH+ Stats that created it followed by the version number of the
stats file itself.
A stats file that reflects only part of the capture file results when the capture file is closed before DH+ Stats has
received all of its frames. When such a stats file is loaded, the Status field on the Overview dialog indicates what
percentage of the capture file is reflected by the stats file.
Currently, DH+ Stats does not verify that the stats file was derived from the capture file. Because of this, it’s
possible for the capture file and stats file to get out of sync if one or the other is copied from somewhere else. In
that case, the stats file can be recreated by selecting “Recreate Stats File” from the Overview dialog File menu.
When capturing to a buffer, the stats file is named “DhPlusStats-yyyy-mm-dd_HHMMSS.sts”, where yyyy = year,
mm = month, dd = day, HH = hours (00..23), MM = minutes, and SS = seconds (this is, incidentally, the same format
used in Frontline for capture to series). The only way to load such a stats file is to rename an arbitrary capture file
to the same name as the stats file but with a “cfa” extension and open it. Clearly this is a very bad way to do it as it
creates a bogus capture file and also defeats the Frontline model of all screens pertaining to the open capture file,
but it’s all that’s available until DH+ Stats API is augmented. It does, however, make it possible for a user to view a
stats file that may have been many days or weeks in the creating. Capturing to a file is a far better approach since
both the stats file and the capture file are created.
When a wrapping capture is performed, Frontline stops sending frames to DH+ Stats as soon as the next frame for
DH+ Stats is overwritten by the frame compiler. At some point this probably changes so that Frontline instead
sends the most recent frame, but even then large numbers of frames is not seen by DH+ Stats.

3.6.5.4.1 CSV Files
You can create a CSV file from the Statistics window.
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1. Open the File menu on the Overview dialog
2. Selecting Make CSV File.
DHPlus Statistics creates an Excel spreadsheet file and displays the Save As dialog. The CSV file contains all of the
tabulated information from all dialogs in DHPlus Statistics for the current file. The contents of tables that have a
selector box are displayed separately for each possible entry in the selector box with the exception of the Token
Rotations dialog where only Ascending Sequence and Descending Duration are displayed. Depending on
the amount of statistical data generated, the Excel spreadsheet may contain tens of thousands of rows.
Note: This menu entry is not available while capturing live data, reading a capture file, or
loading a statistics file.
3.6.5.4.2 Backward Compatibility
All statistics files from later versions are backward compatible. Statistics files produced by earlier versions can be
read by any subsequent versions. If DH+ Stats has a version number later than the statistics file, the system
displays a screen that lists the differences.

3.6.6 CC-Link Dashboard
The CC-Link ComProbe is an option in the Frontline NetDecoder software that allows you to capture and analyze
CC-Link protocol messages.
Once messages are captured using CC-Link, you can use the CC-Link Dashboard which provides a graphical
overview of the CC-Link network health.

Figure 3.37 - CC-Link Dashboard
There are two main features to the dashboard: The Active Devices Grid and the Error Log. Select these links to
learn more about each
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3.6.6.1 CC-Link Active Devices Grid
The Active Devices on Network grid shows all 64 nodes on a CC-Link network with each node represented by
a numbered square on the grid.

CC-Link Devices Grid on the left
The squares are color coded to indicate the state of the node. The coded states include: Click on each node state
to learn more.
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Table 3.21 - CC-Link Devices Grid Color Codes

Color
Code

Description
Grey: Node Not Present on the network
In this example we see only one connected node, with all other nodes grayed out indicating that
they are absent from the network.

Green: A Connected Node operating normally without errors.
The image below shows all the nodes present, with the nodes in green operating normally, with
no error
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Table 3.21 - CC-Link Devices Grid Color Codes (continued)
Color
Code

Description
Light Green: An Occupied Station within a Previous Node.
CC-Link supports the concept of Occupied Stations, in which a single node on the network can
be considered to have multiple stations.
In the image below, Node 4 is an Occupied Station. This means that Node 3 is configured to
have two occupied stations: Node 3 and Node 4. Similarly, Nodes 5, 7, 9, 11, 13, 20, 22, 24, 26,
28, and 30 have two occupied Stations.

When you look at the same information in Frame Display in the image below, you can see that
in Frame 6 that Node 3 has two occupied stations. This means that Node 4 is actually an
occupied station in Node 3. Therefore, after a response from Node 3 in Frame 6, the Master then
polls Node 5 and not Node 4. In Frame 8, Node 5 responds and there is information that it also
occupies two stations. This implies that Node 6 is an occupied station.
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Table 3.21 - CC-Link Devices Grid Color Codes (continued)

Color
Code
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Description
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Table 3.21 - CC-Link Devices Grid Color Codes (continued)
Color
Code

Description
Red: Disconnected Node
If a node that is working properly gets disconnected for any reason, then the Dashboard shows
the node marked in red.
In the image below, Node 61 was pulled out of the network. The Dashboard marks the node in
red and the Error Log shows the exact Frame number at which the Master is retrying to poll the
node 61. The Error Log shows, the Frame number, the node and the error event that happened
on that frame.

When you look at the same information in Frame Display in the image below, you can see that
in Frame 6 that Node 3 has two occupied stations. This means that Node 4 is actually an
occupied station in Node 3. Therefore, after a response from Node 3 in Frame 6, the Master then
polls Node 5 and not Node 4. In Frame 8, Node 5 responds and there is information that it also
occupies two stations. This implies that Node 6 is an occupied station.
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Table 3.21 - CC-Link Devices Grid Color Codes (continued)

Color
Code

Description

Orange: Node with a Watch Dog Timer Error
When a Slave node responds to a Master’s Poll request, the response frame contains a Station
Information (ST1) byte. The first bit of the ST1 byte indicates a Watchdog Timer error. If a node
sends a frame with this bit set, then the node is marked in orange and error is logged in the error
list.
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Table 3.21 - CC-Link Devices Grid Color Codes (continued)
Color
Code

Description
Yellow: Node with a System Fault
When a Slave node responds to a Master’s Poll request, the response frame contains a Station
Information (ST1) byte. Apart from the Watchdog Timer bit and the Cyclic Transmission flag,
this field contains five bits that provide information on the node’s status. These fields include:
1. Switch Change Detection
2. Parameter Receive
3. Refresh Receive
4. Unit Error/Invalid Number of Points
5. Fuse Status
If any of these 5 flag bits are enabled, then the node is flagged as having a System Fault.
The image below shows Nodes 50 and 52 in System Fault. The Error Log lists the exact frame
number that has the error and the actual error. In this case, both Nodes 50 and Node 52 were
responding with a ‘Parameter Receive’ error.

If you look at Node 52 in Frame Display in the image below, Frame 1988 (which is listed in the
Error Log above) shows that the ‘Parameter Receive’ bit in the ST1 field is set to ‘Not
Received’. Therefore, Node 52 is tagged as having a System Fault.
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Table 3.21 - CC-Link Devices Grid Color Codes (continued)

Color
Code
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Description
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Table 3.21 - CC-Link Devices Grid Color Codes (continued)
Color
Code

Description
Blue: Node operating correctly but had a previous error.
There are occasions when a node can have an error and then recover. If this occurs, the
correctly operating node is first displayed in Green. When it has a System Fault, it goes to
Yellow state. When the node recovers, it goes to Blue state.
In the image below Node 50 is tagged as having a Previous Error.

If you look at Frame Display in the image below, you can see that Frame 4846 is the last frame
where Node 50 has a Parameter Error.
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Table 3.21 - CC-Link Devices Grid Color Codes (continued)

Color
Code

Description

Following the example through, in the Frame Display image below you can see that in Frame
4952 the Parameter Receive Status is "Completed". Node 50 no longer has a Parameter Error.
That is why Node 50 is shown as a

Previous Error in the Active Devices on Network grid.

3.7 Introduction - Transmit
The Transmit tool is an application used to send Ethernet or Serial data to test and/or verify network integrity.
On product installation, the installer creates a folder on the windows desktop labeled Frontline [Product Name].
1. Double-click the Frontline [Product Name] desktop folder.
This opens a standard Windows file folder window.
Note: Note: You can also access this dialog by
selecting Start > All Programs > Frontline [Product
Name] (Version #) > [Product Name
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2. Double-click on Transmit Data and the application opens.

Transmit dialog
There are two options for sending the data by clicking on the tabs: Ethernet or Serial.

3.7.1 Serial
The Serial tab in the Transmit tool is used to configure and send serial data that can be used for testing and
verifying serial communication networks.
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Transmit dialog with Serial tab active.

Configuration
The Configuration area displays the current cable configuration. Click here to see how to view/change the
configuration.

I/O Configuration
The I/O Configuration area displays the current I/O configuration. Click here to see how to view/change the
configuration.

Data to Transmit
In this section you select what type of data to transmit, either a File or a String.
1. Select the File radio button.
2. Select the browse button for File to locate the capture file (.cfa) file that contains the data you want to
send.
OR
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1. Select the String radio button.
2. Enter a string in the text box.
Note: Clicking the arrow button

displays the last 15 strings

Control Signal States
Next to the String text box are check boxes for changing control signal states. You are able
to change control signals only for the device which you are emulating selected in the I/O
Settings Operating Mode.

Table 3.22 - IO Settings
Operating Modes
Mode
Control States
Source DTE RTS
DTR
Source DCE CTS
DSR
CD
RI
To change a control signal, click on the box. A check mark means that the signal is high, while an empty box means
that the signal is low.
Note: The available boxes will change depending on whether Source DTE or Source DCE is
selected for the Operating mode on the I/O Configuration.

Transmit
You have to select one of three options to determine how many times the data is translated.
l

Select Transmit Once to transmit the data one time.

l

Select Times to Transmit and enter a numeric value in the text box to transmit the data X number of times.

l

Select Transmit Continuously to transmit the data continuously until you select the Stop button.
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Delays/Bursts
Data Delay:
Data Delay inserts a delay between each transmission of a string or a file.
1. Type a value in the box to tell the analyzer how long to set the delay
2. Click on the down arrow to choose a time increment of milliseconds, seconds or minutes. A delay of 0
(zero) means that the analyzer does not insert a delay.
Example: A delay of 40 seconds causes the analyzer to transmit the string, wait 40 seconds, and transmit the string
again. This pattern repeats until either the string has been transmitted the specified number of times, or the user
chooses to stop transmitting.

Burst Delay
Burst Delay inserts a delay between each transmission of the transmit buffer. The Max Burst Size on page clxviii
effectively sets the size of the transmit buffer. The analyzer fills the buffer with data up to the Max Burst Size,
and sends the data. If a Burst Delay is set, the analyzer pauses the length of the delay, before filling up the
transmit buffer again and repeating the process.
To set the Burst Delay,
1. Set the delay by typing in the length of the delay in the Burst Delay text box
2. Choose a time increment of milliseconds, seconds or minutes from the pull-down menu.
Example: You want to send 1000 bytes, wait 2 minutes, and repeat the pattern. Type in 1000 in the Burst Size
text box, and set the Data Delay to 2 minutes. The analyzer sends 1000 bytes, using as many repetitions of the
string or file as necessary to achieve the correct number of bytes, wait 2 minutes and send the string again.
Example: You want to send a 1000 byte file continuously, and insert a 5 second delay between each transmission
of the file. However, you also want to send the file in increments of 400 bytes each, with a ten second delay
between each group of 400 bytes. To set this up, you would set your Max Burst Size to 400, your Data Delay
to 5 seconds, and your Burst Delay to 10 seconds.
The analyzer would send 400 bytes, wait 10 seconds, send 400 bytes, wait 10 seconds, send 200 bytes, wait 5
seconds (because the end of the file has been reached), and repeat the process until transmission was paused or
stopped.

Max Burst Size
Max Burst Size allows you to control how many bytes are put into the transmit buffer at a time.
1. Type how many bytes to send in the Max Burst Size text box.
Example: Assume that the transmit buffer can hold up to 1000 bytes. If the Max Burst Size is set to 1000, the
analyzer would fill up the buffer with 1000 bytes and then send the 1000 bytes. However, if you want to send only
500 bytes at one time, you would set the Max Burst Size to 500. The analyzer would put only 500 bytes into the
transmit buffer before sending them, even though the buffer could hold up to 1000 bytes.
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Start, Pause, or Stop
l

l

l

When you are ready to send the data, select Start.
Select Pause to stop the data transfer. Select Pause again to continue at the data point where the transfer
was stopped.
Select Stop to stop the data transfer. After you select Stop, selecting Start begins the transfer again from the
beginning.

3.7.2 Serial Configuration Settings
The Configuration Settings dialog appears when you select Modify on the Serial tab. You set the cable and
cardware configuration from this dialog.

Serial Configuration Settings dialog

Cable Configuration
Option

Cable Configuration Options
Description

Use
Select this radio button if you want to transmit the data through an FTS cable.
FTS
Cables If you select this option, you can optionally choose to activate the Notify If Auto Detect of
Cables Fails. With this option selected, the tool automatically displays a message if no
cable is detected. You can also select Detect Now at any time to determine if the cables are
properly configured. A message box displays the status of the cables.
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Cable Configuration Options (Continued)
Description

Option

Source Select this radio button if you want to transmit the data directly through a serial port
DTE,
connection to a PC.
No
FTS
Cables

Hardware Configuration
Once you select the Cable Configuration, you need to complete the Hardware Configuration settings on the
right side of the dialog.
Table 3.23 - Hardware Configuration Options
Cable Configuration Setting Available Hardware Configuration Options
Use FTS Cables

Use this serial device

Source DTE, No FTS Cables Use this serial device
and this serial device
Select OK to close the dialog.

3.7.3 I/O Settings
The I/O Settings dialog appears when you select Modify I/0 on the Serial tab. You set the Operating Mode and
communication variables from this dialog.
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Serial I/O Settings dialog

Operating Mode
Select Source DTE or Source DCE from the Operating Mode drop-down list. Depending on the source
selected either the operating parameter DTE or DCE row is activated. The operating parameters are identical
for each option and are listed in the following table.
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DTE/DCE Operating Mode Parameters
Parameter
Selection
Baud

300
600
1200
2400
9600 (default)
14400
19200
38400
57600
115200
230400
460800
921600

Parity

None (default)
Odd
Even
Mark
Space

Length

5 bits
6 bits
7 bits
8 bits (default)

Stop

1 bit (default
1.5 bits
2 bits

The parameter defaults are Baud/9600, Parity/None, Length/8 bits, and Stop/1 bit that are automatically selected
when an Operating Mode is selected.
Once the Operating Mode and parameters are selected, click the OK button to close the dialog.

3.7.4 Transmitting Files
The analyzer transmits files as is. For example, if you transmit a text file, the analyzer sends the text characters, but
also sends any formatting instructions such as carriage returns, tab characters, etc., as their hex equivalents.
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One of the files that you can use to transmit the data is an FTS capture file. The capture file, extension .cfa, is
created using the FTS application. To transmit the data in a FTS capture file, you first need to export it to a binary
format. The analyzer capture files are in a special format, and if you transmit a the analyzer capture file in its
native format, what you see bears no resemblance to the data you want to transmit.
If you want to transmit the data in an analyzer capture file, you need to convert the file to a generic format using
the Export function in the FTS application. See Transmitting FTS Capture Files for more information.

3.7.4.1 Converting FTS Capture Files
One of the files that you can use to transmit data is a Frontline Test System (FTS) capture file. The capture file,
extension .cfa, is a proprietary file type created using the FTS application.
To use a .cfa file in the Transmit tool, it first has to be converted to a binary format. You can't do this from the
Transmit tool. You must open an FTS application to export and convert the .cfa file before using it with the
Transmit tool.
Once you have opened the FTS application:
1. Open the capture file containing the data you want to transmit.
2. On the Control window, choose Export Events from the File menu.
3. Choose Binary Output.
4. In the Available Fields box, choose Char/Event Name.
5. Click the Move One Item Right button (looks like ">") to add it to the Displayed Fields box. Remove
any other fields in the Displayed Fields box.
6. Choose a filename in the Export box. The default file name is the name of your capture file, followed by
the word "Events" (to distinguish it from a Frame export), with a .bin extension.
7. By default the file is saved in the same directory as the original capture file. Click on the Browse button to
save your file to another location.
8. If you want to transmit just DTE data or DCE data, be sure to filter out the side you do not want. Also, you
probably want to filter out Special Events.
9. Click Export.
The result is a .bin file, which you can use in the Transmit tool.

3.7.5 String Formats
Note that any of the formats below can be combined. It is legal to transmit the ASCII string ABC$65$30, for
example.

Entering Normal Text Characters
The system sends your string in whatever character set you are currently using. To change the character set, go to
the Data menu in the Control Window, and choose a character set.
Examples:
To send the string "qwerty", you would type qwerty.
To send the string "hello, world", you would type hello, world.
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Entering Characters in Hex
To transmit in hex, type a $ in front of your two digit byte. The $ symbol tells the analyzer that you are sending in
hex. If you want to send more than one hex byte, you have to type the $ symbol in front of each byte.
You must have a two digit hex number after the $ for the analyzer to interpret the bytes as hex properly.
Otherwise, the analyzer interprets the characters as if they belonged to a character set. For example, if you want
to send an ASCII NUL, which is hex 00, and you type $0, the analyzer sends hex 24 followed by hex 30. The $
symbol is hex 24 in ASCII, and zero is hex 30. To send a hex 00, you must type $00.
Example:
To send hex 31 00 97, you would type $31$00$97.

Entering Control Characters
The ^ symbol is used to specify that what follows is a control character. You can transmit the control characters
l

Ctrl-A through Ctrl-Z,

l

Ctrl-@,

l

Ctrl-[,

l

Ctrl-\,

l

Ctrl-],

l

and Ctrl--.

For example, ^A sends Ctrl-A ($01) and ^@ sends ASCII NUL ($00).

The Escape Character
The \ is the escape character. It is used when transmitting special characters, in order to specify that the next
character should be taken literally. These special characters are: $^&*()\. For example, to put an * in a string,
enter \*. To transmit a \, enter \\.

Specifying a Range of Characters
You can also send a range of characters by placing two periods between your first and last characters. For
example, A..I generates the string ABCDEFGHI. It is important to note that A..I in ASCII is very different from A..I in
EBCDIC. In ASCII, A..I is equivalent to $41..$49, while in EBCDIC A..I is equivalent to $C1..$C9. It is also legal to
specify a descending range. For example, I..A generates IHGFEDCBA.

Sub-expressions
Sub-expressions are enclosed in (). The parentheses are not part of the sub-expression and are not transmitted.
For example, (ABC) yields ABC. Sub-expressions are useful because you can specify a repeat count for them using
the *. For example (ABC)*3 yields ABCABCABC.

Entering Baudot Characters
Since Baudot is only 5 bits it includes two shift characters. Shift In ($1F) means interpret all following characters as
letters; Shift Out ($1B) means interpret all following characters as figures (punctuation, numbers, control codes,
etc). When the analyzer is activated it assumes the letters mode. The shift characters are captured in the buffer
just as other bytes. In source mode the analyzer automatically supplies the shift characters to the string you enter.
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For example, if you are in letter mode and enter the string 12AB, the analyzer sends $1B (Shift Out), $17 (1), $13
(2), $1F (Shift In), $03 (A), $19 (B).
Note: When you use hex notation to input a Baudot string, the analyzer does not insert shift
characters.
More Examples
Enter

To Generate

\\\$\^\(\)\*

\$^()*

\$.ABC.

$.ABC.

(ABC)*3\9

ABCABCABC9

($6b..$68)*2

kjihkjih

(A(BC)*2)*3

ABCBCABCBCABCBC

Aa..iZ

AabcdefghiZ
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Chapter 4 Search/Find
4.1 Find
Capturing and decoding data within the ComProbe analyzer produces a wealth of information for analysis. This
mass of information by itself, however, is just that, a mass of information. There has to be ways to manage the
information. ComProbe software provides a number of different methods for making the data more accessible.
One of these methods is Find.

Figure 4.1 - Find Dialog
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Find, as the name suggests, is a comprehensive search function that allows users to search for strings or patterns
in the data or in the frame decode. You can search for errors, control signal changes, bookmarks, special events,
time, and more. Once the information is located, you can easily move to every instance of the Find results.

4.1.1 Searching within Decodes
Searching within decodes lets you to do a string search on the data in the Decode Pane of the Frame Display
window.
To access the search within decodes function:
1. Open a capture file, or capture some data to search.
2. Open the Event Display
3. Click on the Find icon

or Frame Display

window.

or choose Find from the Edit menu.

4. Click on the Decode tab of the Find dialog.
Note: The tabs displayed on the Find dialog depend on the product you are running and the
content of the capture file you are viewing.

Figure 4.2 - Find Decode Tab Search for String
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Figure 4.3 - Find Decode Tab Side Restriction
There are several options for error searching on the Decoder tab.
l

l

Search For String in Decoder allows you to enter a string in the text box. You can use characters, hex or
binary digits, wildcards or a combination of any of the formats when entering your string. Every time you type
in a search string, the analyzer saves the search. The next time you open Find, the drop-down list will contain
your search parameters.
Search for All Errors finds frame errors as well as frames with byte-level errors (such as parity or CRC
errors).

l

Search for Frame Errors Only finds frame specific errors, such as frame check errors.

l

Search for Information Frame only searches information frames.
1. Enter the search string.
2. Check Ignore Case to do a case-insensitive search.
3. When you have specified the time interval you want to use, click on the Find Next or Find Previous
buttons to start the search from the current event.

The result of the search is displayed in the Decode pane in Frame Display.
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Side Restrictions - Side Restriction means that the analyzer
looks for a pattern coming wholly from the DTE or DCE side. If you
choose to search without regard for data origin, the analyzer looks
for a pattern coming from one or both sides. For example, if you
choose to search for the pattern ABC and you choose to search
without regard for data origin, the analyzer finds all three instances
of ABC shown here.
The first pattern, with the A and the C coming from the DTE device
and the B coming from the DCE is a good example of how using a
side restriction differs from searching without regard to data origin.
While searching without regard for data origin finds all three
patterns, searching using a side restriction never finds the first
pattern, because it does not come wholly from one side or the
other.
If you choose to search for the pattern ABC, and you restrict the
search to just the DTE side, the analyzer finds the following pattern:
In this example, the analyzer finds only the second pattern
(highlighted above) because we restricted the search to just the
DTE side. The first pattern doesn't qualify because it is split between
the DTE and DCE sides, and the third pattern, though whole, comes
from just the DCE side.
If we choose both the DTE and the DCE sides in the above example,
then the analyzer finds the second pattern followed by the third
pattern, but not the first pattern. This is because each side has one
instance in which the whole pattern can be found. The analyzer
completely searches the DTE side first, followed by the DCE side.
Note: Side Restriction is available for pattern and error searching.
1. Select one of the two options.
2. Select DTE, DCE, or both.
3. When you made your selections, click on the Find Next or Find Previous buttons to start the search
from the current event.
The result of the search is displayed in the Decode pane in Frame Display.

4.1.2 Searching by Pattern
Search by Pattern lets you perform a traditional string search. You can combine any of the formats when
entering your string, and your search can include wildcards. You can search one or both sides of a circuit
containing interwoven data such as serial communication.
To access the search by pattern function:
1. Open a capture file, or capture some data to search.
2. Open the Event Display

clxxx

or Frame Display

window.
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or choose Find from the Edit menu.

4. Click on the Pattern tab of the Find dialog.
Note: The tabs displayed on the Find dialog depend on the product you are running and the
content of the capture file you are viewing.

Figure 4.4 - Find Pattern Tab

Figure 4.5 - Find Pattern Tab Side Restrictions
Pattern allows you to enter a string in the text box. You can use characters, hex or binary digits, control
characters, wildcards or a combination of any of the formats when entering your string. Every time you type in a
search string, the ComProbe analyzer saves the search. The next time you open Find, the drop-down list will
contain your search parameters.
1. Enter the search pattern.
2. Check Ignore Case to do a case-insensitive search.

NetDecoder Async User Manual

clxxxi

TELEDYNE LECROY

Chapter 4 Search/Find

3. When you have specified the pattern you want to use, click on the Find Next or Find Previous buttons
to start the search from the current event.
The result of the search is displayed in the in Frame Display and Event Display.
Refer to Searching by Decode on page clxxviii for information on Side Restrictions

4.1.3 Searching by Time
Searching with Time allows you search on timestamps on the data in Frame Display and Event Display
window.
To access the search by time function:
1. Open a capture file, or capture some data to search.
2. Open the Event Display
3. Click on the Find icon

or Frame Display

window.

or choose Find from the Edit menu.

4. Click on the Time tab of the Find dialog.

Note: The tabs displayed on the Find dialog depend on the product you are running and the
content of the capture file you are viewing.

Figure 4.6 - Find by Time tab
The analyzer can search by time in several different ways.
Search for Absolute/Relative timestamp.
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Absolute - An absolute timestamp search means that the analyzer searches for an event at the exact date and
time specified. If no event is found at that time, the analyzer goes to the nearest event either before or after
the selected time, based on the "Go to the timestamp" selection.
Relative - A relative search means that the analyzer begins searching from whatever event you are currently
on, and search for the next event a specific amount of time away.
1. Select Absolute or Relative
2. Select the date and time using the drop-down lists for Month, Year, Day, Hour, Minute, Second,
1/10000000.
Note: Month and Year are not available if you select Relative.
3. When you have specified the time interval you want to use, click on the Go To, Move Forward or Move
Backward buttons to start the search from the current event.
Note: When you select Absolute as Search for, Go To is available. When you
select Relative as Search for, Move Forward or Move Backwardis available.

Go to the timestamp: On or before/ On or after
The analyzer searches for an event that matches the time specified. If no event is found at the time specified, the
analyzer goes to the nearest event either before or after the specified time. Choose whether to have the analyzer
go to the nearest event before the specified time or after the specified time by clicking the appropriate radio
button in the Go to the timestamp box.
If you are searching forward in the buffer, you usually want to choose the On or After option. If you choose the
On or Before option, it may be that the analyzer finishes the search and not move from the current byte, if that
byte happens to be the closest match.
When you select Absolute as Search for, the radio buttons are On or before the specified time or On or
after the specified time. When you select Relative as Search for, the radio buttons are On or before the
specified time relative to the first selected item or On or after the specified time relative to the last
selected item.
1. Select On or before the specified time or On or after the specified time.
2. When you have specified the time interval you want to use, click on the Go To, Move Forward or Move
Backward buttons to start the search from the current event.
When you select Absolute as Search for, Go To is available. When you select Relative as Search for,
Move Forward or Move Backwardis available.
There are a couple of other concepts to understand in respect to searching with timestamps.
l

The analyzer skips some special events that do not have timestamps, such as frame markers. Data events that
do not have timestamps because timestamping was turned off either before or during capture are also
skipped.
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Timestamping can be turned on and off while data is being captured. As a result, the capture buffer may have
some data with a timestamp, and some data without. When doing a search by timestamp, the analyzer ignores
all data without a timestamp.
The raw timestamp value is the number of 100-nanosecond intervals since the beginning of January 1, 1601.
This is standard Windows time.

4.1.4 Using Go To
Searching with Go To allows you to go to a particular frame or event, or to move through the data X number of
events or frames at a time. You can move either forward or backwards through the data.
To access the Go To function:
1. Open a capture file, or capture some data to search.
2. Open the Event Display
3. Click on the Find icon

or Frame Display

window.

or choose Find from the Edit menu.

4. Click on the Go To tab of the Find dialog.
5. The system displays the Find dialog with the Go To tab selected.
Note: The tabs displayed on the Find dialog depend on the product you are running and the
content of the capture file you are viewing.

Figure 4.7 - Find Go To tab
To go to a particular frame :
1. Select the Frame Number radio button
2. Type the frame number in the box.
3. Click the Go To button.
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4. To move forward or backward a set number of frames, type in the number of frames you want to move
5. Then click the Move Forward or Move Back button.
To go to a particular event :
1. Select the Data Event Number or All Events Number radio button.
2. Type the number of the event in the box.
3. Click the Go To button.
4. To move forward or backwards through the data, type in the number of events that you want to move
each time.
5. Then click on the Move Forward or Move Backward button.
6. For example, to move forward 10 events, type the number 10 in the box, and then click on Move
Forward. Each time you click on Move Forward, Frontline moves forward 10 events.
See Event Numbering for why the Data Event Number and All Events Number may be different. As a
general rule, if you have the Show All Events icon
depressed on the Event Display window or Frame
DisplayEvent pane, choose All Events Number. If the Show All Events button is up, choose Data Event
Number.

4.1.5 Searching for Special Events
Frontline inserts or marks events other than data bytes in the data stream. For example, the analyzer inserts startof-frame and end-of-frame markers into framed data, marking where each frame begins and ends. If a hardware
error occurs, the analyzer shows this using a special event marker. You can use Find to locate single or multiple
special events.
To access the search for special events function:
1. Open a capture file, or capture some data to search.
2. Open the Event Display
3. Click on the Find icon

or Frame Display

window.

or choose Find from the Edit menu.

4. Click on the Special Events tab of the Find dialog.
Note: The tabs displayed on the Find dialog depend on the product you are running and
the content of the capture file you are viewing.
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Figure 4.8 - Find Special Events tab
5. Check the event or events you want to look for in the list of special events. Use Check All or Uncheck
All buttons to make your selections more efficient.
6. Click Find Next and Find Previous to move to the next instance of the event.
Not all special events are relevant to all types of data. For example, control signal changes are relevant only to
serial data and not to Ethernet data.
For a list of all special events and their meanings, see List of all Event Symbols on page 1.

4.1.6 Searching by Signal
Searching with Signal allows you to search for changes in control signal states for one or more control signals. You
can also search for a specific state involving one or more control signals, with the option to ignore those control
signals whose states you don’t care about.
The analyzer takes the current selected byte as its initial condition when running searches that rely on finding
events where control signals changed.
To access the search by time function:
1. Open a capture file, or capture some data to search.
2. Open the Event Display
3. Click on the Find icon

or Frame Display

window.

or choose Find from the Edit menu.

4. Click on the Signal tab of the Find dialog.
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Note: The tabs displayed on the Find dialog depend on the product you are running and the
content of the capture file you are viewing.

Figure 4.9 - Find Signal tab.
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Figure 4.10 - Find Signal Tab

You will choose one qualifier—Searching for event where, then choose one or more control signals
Control Signals
The section with the check boxes allows you to specify which control signals the analyzer should pay attention to
when doing the search. The analyzer pays attention to any control signal with a check mark.
l

Click on a box to place a check mark next to a control signal

l

Click again to uncheck the box

l

By default, the analyzer searches all control signals, which means all boxes start out checked.

For example, if you are only interested in finding changes in RTS and CTS, you would check those two boxes
and uncheck all the other boxes. This tells the analyzer to look only at the RTS and CTS lines when running the
search. The other signals are ignored.
The control signals types include:
l

USB - Pin 1

l

USB - Pin 2

l

USB - Pin 3

l

USB - Pin 4

or
l

RS232 - Request to Send (RTS)

l

RS232 - Clear to Send (CTS)

l

RS232 - Data Set Ready (DSR)

l

RS232 - Data Terminal Ready (DTR)

l

RS232 - Carrier Detect (CD)

l

RS232 - Ring Indicator (RI).

Click here to learn more about the Breakout Box and Pins 1 - 4.
Searching for event where:
l

l

The first three options are all fairly similar, and are described together. These options are searching for an
event where:
o

One or more control signals changed

o

One or more control signals changed from off to on

o

One or more control signals changed from on to off

Searching for an event where one or more signals changed means that the analyzer looks at every control
signal that you checked, and see if any one of those signals changed state at any time.
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If you want to look at just one control signal:
n

Check the box for the signal.

n

Uncheck all the other boxes.

n

Choose to search for an event where one or more signals changed.

n

The analyzer notes the state of the selected signal at the point in the buffer where the cursor is,
search the buffer, and stop when it finds an event where RTS changed state.

n

If the end of the buffer is reached before an event is found, the analyzer tells you that no matches
were found.

Searching for events where control signals changed state from off to on, or vice versa, is most useful if the
signals are usually in one state, and you want to search for occasions where they changed state.
For example:

l

o

If DTR is supposed to be on all the time but you suspect that DTR is being dropped

o

Tell the analyzer to look only at DTR by checking the DTR box and unchecking the others

o

Do a search for where one or more control signals changed from on to off.

o

The analyzer would search the DTR signal and stop at the first event where DTR dropped from on to off.

Searching for an Exact State
To search for an exact state means that the analyzer finds events that match exactly the state of the control
signals that you specify.
o

First, choose to search for an event where your choices exactly describe the state.

o

This changes the normal check boxes to a series of radio buttons labeled On, Off and Don’t Care for
each control signal.

o

Choose which state you want each control signal to be in.

o

Choose Don’t Care to have the analyzer ignore the state of a control signal.

o

When you click Find Next, the analyzer searches for an event that exactly matches the conditions
selected, beginning from the currently selected event.

o

If the end of the buffer is reached before a match is found, the analyzer asks you if you want to
continue searching from the beginning.

o

If you want to be sure to search the entire buffer, place your cursor on the first event in the buffer.

o

Select one of the four radio buttons to choose the condition that must be met in the search

o

Select one or more of the checkboxes for Pin 1, 2, 3, or 4.

o

Click Find Next to locate the next occurrence of the search criteria or Find Previous to locate an
earlier occurrence of the search criteria.
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4.1.7 Searching for Data Errors
The analyzer can search for several types of data errors. Searching for data error sallows you to choose which
errors you want to search for and whether to search the DTE or DCE data or both. Bytes with errors are shown in
red in the Event Display window, making it easy to find errors visually when looking through the data.
To access the search by time function:
1. Open a capture file, or capture some data to search.
2. Open the Event Display
3. Click on the Find icon

or Frame Display

window.

or choose Find from the Edit menu.

4. Click on the Errors tab of the Find dialog.
Note: The tabs displayed on the Find dialog depend on the product you are running and the
content of the capture file you are viewing.

Figure 4.11 - Find Error tab.
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Searching for event where
The first three options are all fairly similar, and are described together. These options are searching for an event
where:
l

one or more error conditions changed

l

one or more error conditions occurred

l

one or more error conditions were off (i.e. no errors occurred)

Selecting Which Errors to Search
The section with the check boxes allows you to choose which errors the analyzer should look for. Click on a box
to check or un-check it.
If you want to search only for overrun errors
l

check the box if shown

l

un-check the other boxes.

To search for all types of errors
l

check all boxes

The most common search is looking for a few scattered errors in otherwise clean data.
To do this type of search:
l

choose to Search for an event where one or more error conditions occurred

l

choose which errors to look for

l

By default, the analyzer looks for all types of errors.

In contrast, searching for an event where one or more error conditions were off means that the analyzer looks for
an event where the errors were not present.
For example, if you have data that is full of framing errors, and you know that somewhere in your 20 megabyte
capture file the framing got straightened out, you could choose to search for an event where one or more error
conditions were off, and choose to search only for framing. The analyzer searches the file, and finds the point at
which framing errors stopped occurring.
Searching for an event where the error conditions changed means that the analyzer searches the data and stop at
every point where the error condition changed from on to off, or off to on.
For example, if you have data where sometimes the framing is wrong and sometimes right, you would choose to
search framing errors where the error condition changed. This first takes you to the point where the framing
errors stopped occurring. When you click Find Next, the analyzer stops at the point when the errors began
occurring again. Clicking Find Previous will search backwards from the current postion.
The analyzer takes the current selected byte as its initial condition when running searches that rely on finding
events where error conditions changed. The analyzer searches until it finds an event where error conditions
changed or it reaches the end of the buffer, at which point the analyzer tells you that there are no more events
found in the buffer. If you are searching for an exact match, the analyzer asks you if you want to continue
searching from the beginning of the buffer.
Searching for Exact Error Conditions
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To search for an exact state means that the
analyzer finds events that exactly match the
error conditions that you specify.
l

l

l

Select the This exactly describes the
state radio button.
This changes the normal check boxes to a
series of radio buttons labeled On, Off
and Don’t Care for each error.
o

On means that the error occurred

o

Off means that the error did not
occur

o

Don’t Care means that the analyzer
ignores that error condition.

Select the appropriate state for each type of error.

Example:
If you need to find an event where just an overrun error occurred, but not any other type of error, you would
choose overrun error to be On, and set all other errors to Off. This causes the analyzer to look for an event where
only an overrun error occurred.
If you want to look for events where overrun errors occurred, and other errors may have also occurred but it
really doesn’t matter if they did or not, choose overrun to be On, and set the others to Don’t Care. The analyzer
ignores any other type of error, and find events where overrun errors occurred.
To find the next error, click the Find Next button. To find an error that occurred earlier in the buffer to where you
are, click the Find Previous button.

4.1.8 Changing Where the Search Lands
When doing a search in the analyzer, the byte or bytes matching the search criteria are highlighted in the Event
Display. The first selected byte appears on the third line of the display.
To change the line on which the first selected byte appears:

1.

Open fts.ini (located in the C:\User\Public\Public Documents\Frontline Test
Equipment\)

2. Go to the [CVEventDisplay] section
3. Change the value for SelectionOffset.
4. If you want the selection to land on the top line of the display, change the SelectionOffset to 0 (zero).

4.2 Bookmarks
Bookmarks are electronic sticky notes that you attach to frames of interest so they can be easily found later. In
Frame Display bookmarked frames appear with a magenta triangle icon next to them.
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Figure 4.12 - Bookmarked Frame (3) in the Frame Display
In the Event Display bookmarks appear as a dashed line around the start of frame
marker.
Bookmarks are easy to create and maintain, and are a very valuable tool for data analysis.
When you create or modify a bookmark, you have up to 84 characters to explain a
problem, leave yourself a reminder, leave someone else a reminder, etc. Once you create a bookmark it will be
saved with the rest of the data in the .cfa file. When you open a .cfa file, the bookmarks are available to you.
Once you have created a bookmark, you can use the Find function or other navigation methods to locate and
move among them.

4.2.1 Adding, Modifying or Deleting a Bookmark
You can add, modify, or delete a bookmarks from Frame Display and Event Display
Add:
1. Select the frame or event you want to bookmark.
2. There are three ways to access the Add Bookmark dialog.
a. Select Add or Modify Bookmark from the Bookmarks menu on the Frame Display and
Event Display,
b. Select the Add or Modify Bookmark

icon on one of the toolbars, or

c. Right-click on the frame/event and choosing Add Bookmark….
3. In the dialog box, add a comment (up to 84 characters) in the text box to identify the bookmark.
4. Click OK.
Once you create a bookmark it will be saved with the rest of the data in the .cfa file. When you open a .cfa file, the
bookmarks are available to you.
Modify
1. Select the frame or event with the bookmark to be edited.
2. There are three ways to access the Add/Modfy Bookmark dialog.
a. Select Add or Modify Bookmark from the Bookmarks menu on the Frame Display and
Event Display'
b. Select the Add or Modify Bookmark

icon on one of the toolbars, or

c. Right-click on the frame/event and choosing Modify Bookmark… on the selection.
3. Change the comment in the dialog box
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4. Click OK. The edited bookmark will be saved as a part of the .cfa file.
5. You can also select Display All Bookmarks

from the Frame Display and Event Display toolbar

or the Bookmarks menu. the Find window will open on the Bookmark tab. Select the bookmark you
want to modify and click the Modify… button. Change the comment in the dialog box, and click OK.
Delete
1. Select the frame or event with the bookmark to be deleted.
2. There are three ways to access the Add/Modfy Bookmark dialog.
a. Select Add or Modify Bookmark from the Bookmarks menu on the Frame Display and
Event Display,
b. Select the Add or Modify Bookmark

icon on one of the toolbars, or

c. Right-click on the frame/event and choosing Modify Bookmark… on the selection.
3. Click on the Delete button. The bookmark will be deleted.
4. You can also select Display All Bookmarks

from the Frame Display and Event Display toolbar

or the Bookmarks menu. the Find window will open on the Bookmark tab. Select the bookmark you
want to delete and click the Delete button.

4.2.2 Displaying All and Moving Between Bookmarks
There are three ways to move between bookmarks.
1. Press the F2 key to move to the next frame or event with a bookmark.
2. Select Go to Next Bookmark from the Bookmarks menu.
3. Click the Display All Bookmarks icon
. Select the bookmark you want to move to and click the Go To
button, or simply double-click on the bookmark. Click the Move Forward and Move Back buttons to cycle
through the bookmarks.
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Figure 4.13 - Find Window Bookmark tab Used to Move Around With Bookmarks
To delete a bookmark, select it and click the Delete button.
To modify a bookmark, select it and click the Modify button.
Click Remove All to delete all the bookmarks.
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5.1 Saving Your Data
You can save all or part of the data that you have captured. You can also load a previously saved capture file, and
save a portion of that file to another file. This feature is useful if someone else needs to see only a portion of the
data in your capture file.
On the Control window toolbar you can set up to capture a single file. Click here to see those settings.
There are two ways to save portions or all of the data collected during a data capture. Click here to see how to
capture data to disk.

5.1.1 Saving the Entire Capture File
This option is only available when you select Single File from the Capture Mode on System Settings.Click
here to learn more about selecting Save options from System Settings.
1. If you are capturing data, click on the Stop Capture
file while it is being captured.
2. Open the Event Display
3. Click the Save

or Frame Display

icon to stop data capture. You cannot save data to

window.

icon, or select Save from the File menu.
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Figure 5.1 - Windows Save dialog
4. Type a file name in the File name box at the bottom of the screen.
5. Browse to select a specific directory. Otherwise your file is saved in the default capture file directory.
6. When you are finished, click OK.

5.1.2 Saving the Entire Capture File with Save Selection
1. If you are capturing data, click on the Stop icon

to stop data capture. You cannot save data to file while

it is being captured.
2. Open the Event Display

or Frame Display

window.

3. Right click in the data
4. Select Save Selection or Save As from the right click
menu.
5. Click on the radio button labeled Entire File.
6. Choose to save Events or Frames . Choosing to save
Events saves the entire contents of the capture file.
Choosing to save Frames does not save all events in the
capture file.
7. Type a file name in the As box at the bottom of the screen.
Click the Browse icon to browse to a specific directory.
Otherwise your file is saved in the default capture file
directory.
8. When you are finished, click OK.
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5.1.3 Saving a Portion of a Capture File
1. If you are capturing data, click on the Stop icon

to pause data capture. You cannot save data to a file

while it is being captured.
2. Open the Event Display

or Frame Display

window, depending on whether you want to

specify a range in bytes or in frames.
3. Select the portion of the data that you want to save. Click and drag to select data, or click on the first item,
move to the last item and Shift+Click to select the entire range, or use the Shift key with the keyboard
arrows or the navigation icons in the Frame Display toolbar. If the range you want to save is too large to
select, note the numbers of the first and last item in the range.
4. Right click in the data
5. Select Save Selection or Save As from the right click
menu
6. Click on the radio button labeled Selection. If you selected
a range, make sure the starting and ending numbers are
correct. To specify a range, type the numbers of the first
and last items in the range in the boxes.
7. Select either Events or Frames to indicate whether the
numbers are event or frame numbers.
8. Type a file name in the As box at the bottom of the screen.
Click the Browse icon to browse to a specific directory.
Otherwise your file is saved in the default capture file
directory.
9. Click OK when you are finished.

5.2 Confirm Capture File (CFA) Changes
This dialog appears when you close a capture file after changing the Notes, the protocol stack, or bookmarks. The
dialog lists information that was added or changed and allows you to select which information to save, and
whether to save it to the current file or to a new one.
Changes made to the file appear in a list in the left pane. You can click on each item to see details in the right pane
about what was changed for each item. You simply check the boxes next to the changes you want to keep. Once
you decide what changes to keep, select one of the following:
l

Save To This File – Saves the changes you have made to the current capture file.

l

Save As – Saves the changes to a new file.

l

Cancel the Close Operation – Closes the file and returns you back to the display. No changes are saved.

l

Discard Changes – Closes the file without saving any of the changes made to the notes, bookmarks, or
protocol stack.
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5.3 Adding Comments to a Capture File
The Notes feature allows you to add comments to a CFA file. These comments can be used for many purposes.
For example, you can list the setup used to create the capture file, record why the file is useful to keep, or include
notes to another person detailing which frames to look at and why. (Bookmarks are another useful way to record
information about individual frames.)
To open the Notes window :
1. Click the Show Notes icon
as the Event Display

. This icon is present on the toolbars of the Frame Display

, as well

. Notes can be selected from the Edit menu on one of these windows.

2. Type your comments in the large edit box on the Notes window. The Cut, Copy, Paste features are
supported from Edit menu and the toolbar
are all supported from Edit menu and the toolbar
3. Click the thumbtack icon

when text is selected. Undo and Redo features
at the current cursor location.

to keep the Notes window on top of any other windows.

4. When you're done adding comments, close the window.
5. When you close the capture file, you are asked to confirm the changes to the capture file. See Confirming
Capture File (CFA) Changes for more information.

5.4 Loading and Importing Capture Files

5.4.1 Loading a Capture File
From the Control Window:
1. Go to the File menu.
2. Choose a file from the recently used file list.
3. If the file is not in the File menu list, select Open Capture File from the File menu or simply click on the
Open icon

on the toolbar.

4. Capture files have a .cfa extension. Browse if necessary to find your capture file.
5. Click on your file, and then click Open.

5.4.2 Importing Capture Files
1. From the Control window

, go to the File menu and select Open Capture File or click on the Open

icon on the toolbar.
2. Left of the File name text box, select from the drop-down list Supported File Types box to All
Importable File Types or All Supported File Types (*.cfa, *.log, *.txt, *.csv, *.cap). Select the file
and click Open.
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The analyzer automatically converts the file to the analyzer's format while keeping the original file in its original
format. You can save the file in the analyzer's format, close the file without saving it in the analyzer's format, or
have the analyzer automatically save the file in the analyzer's format (see the System Settings to set this option).
All of these options keep your original file untouched.
When you first open the file, the analyzer brings up the Protocol Stack window and ask you what protocol
decodes, if any, you want to use. You must choose a protocol decode at this point for the analyzer to decode the
data in the file. If you open a file without using any decodes, and decide later that you want to apply a decode,
choose Reframe from the File menu on the Control window.
At present, the analyzer supports the following file types:
l

l

Frontline Serialtest* Async and Serialtest ComProbe® for DOS – requires the .byt for data and the .tim for
timestamps (see note on importing DOS timestamps).
Greenleaf ViewComm* 3.0 for DOS - requires the .byt for data and the .tim for timestamps (see note on
importing DOS timestamps).

l

Frontline Ethertest* for DOS – requires 3 files: filename.cap, filename.ca0 and filename.ca1.

l

Sniffer Type 1 – supports files with the .enc extension. Does not support Sniffer files with a .cap extension.

l

l

l

l

Snoop or Sun Snoop – files with a .cap extension based on RFC 1761. For file format, see
http://www.faqs.org/rfcs/rfc1761.html.
Shomiti Surveyor files in Snoop format – files with a .cap extension. For file format, contact Technical Support.
CATC Merlin - files with a .csv extension. Files must be exported with a specific format. See File Format for
Merlin Files for information.
CATC Chief - files with a .txt extension.

5.5 Printing

5.5.1 Printing from the Frame Display/HTML Export
The Frame Display Print dialog and the Frame Display HTML Export are very similar. This topic discusses
both dialogs.

Frame Display Print
The Frame Display Print feature provides the user with the option to print the capture buffer or the current
selection. The maximum file size, however, that can be exported is 1000 frames.
When Print Preview is selected, the output displays in a browser print preview window, where the user can
select from the standard print options. The output file format is in html, and uses the Microsoft Web Browser
Control print options for background colors and images.
Print Background Colors Using Internet Explorer
1. Open the Tools menu on the browser menu bar
2. Select “Internet Options…” menu entry.
3. Click Advanced tab.
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4. Check “Print background colors and images” under the Printing section
5. Click the Apply button, then click OK

Configure the Print File Range in the Frame Display Print Dialog
Selecting more than one frame in the Frame Display window defaults the radio button in the Frame Display Print
dialog to Selection and allows the user to choose the All radio button. When only one frame is selected, the All
radio button in the Frame Display Print dialog is selected.

How to Print Frame Display Data
1. Select Print or Print Preview from the File menu on the Frame Display window to display the Frame
Display Print dialog. Select Print if you just want to print your data to your default printer. Select Print
Preview if you want access to printer options.
2. Choose to include the Summary pane (check the box) in the print output. The Summary pane appears at
the beginning of the printed output in tabular format. If you select All layers in the Detail Section, the
Data Bytes option becomes available.
3. In the Detail Section, choose to exclude—No decode section—the decode from the Detail pane in
the Frame Display, or include All Layers or Selected Layers Only. If you choose to include selected
layers, then select (click on and highlight) the layers from the list box.
4. Click on selected layers in the list to de-select, or click the Reset Selected Layers button to de-select all
selected layers.

Figure 5.2 - Frame Display Print Dialog
5. Select the range of frames to include All or Selection in the Frame Range section of the Frame
Display Print dialog.
Choosing All prints up to 1000 frames from the buffer.
Choosing Selection prints only the frames you select in the Frame Display window.
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6. Selecting the Delete File deletes the temporary html file that was used during printing
7. Click the OK button.

Frame Display Print Preview
The Frame DisplayPrint Preview feature provides the user with the option to export the capture buffer to an
.html file. The maximum file size, however, that can be exported is 1000 frames.
If you chose Print Preview, the system displays your data in a browser print preview display with options for
printing such as page orientation and paper size. You can also use your Printer Preferences dialog to make some
of these selections. When printing your data, the analyzer creates an html file and prints the path to the file at the
bottom of the page. This file can be opened in your browser, however, it may appear different than the printed
version.
1. Select Print Preview from the File menu on the Frame Display window to display the Frame Display
Print Preview.

Figure 5.3 - Frame Display Print Preview Dialog

2. From this point the procedure is the same as steps 2 through 5 in "How to Print Frame Display Data" above.
3. Click the OK button, and after a brief wait a browser window will appear.

5.5.2 Printing from the Event Display
The Event Display Print feature provides the user with the option to print either the entire capture buffer or the
current selection. When Print Preview is selected, the output displays in a browser print preview window where
the user can select from the standard print options. The output file format is in html, and uses the Microsoft Web
Browser Control print options for background colors and images (see below).
Print Background Colors Using Internet Explorer
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1. Open the Tools menu on the browser menu bar
2. Select “Internet Options…” menu entry.
3. Click Advanced tab.
4. Check “Print background colors and images” under the Printing section
5. Click the Apply button, then click OK
The Event Display Print feature uses the current format of the Event Display as specified by the user.
See About Event Display for an explanation on formatting the Event Display prior to initiating the print feature.
Configure the Print File Range in the Event Display Print dialog
Selecting more than one event in the Event Display window defaults the radio button in the Event Display
Print dialog to Selection and allows the user to choose the All radio button. When only one event is selected ,
the All radio button in the Event Display Print dialog is selected.

How to Print Event Display Data to a Browser
1. Select Print or Print Preview from the File menu on the Event Display window to display the Event
Display Print dialog. Select Print if you just want to print your data to your default printer. Select Print
Preview if you want preview the print in your browser.
2. Select the range of events to include from either All or Selection in the Event Range section . Choosing
All prints all of the events in the capture file or buffer. Choosing Selection prints only the selected events
in the Event Display window.
Note: In order to prevent a Print crash, you cannot select All if there are more than
100,000 events in the capture buffer.

Note: See "Configure the Print File Range in the Event Display Print Dialog" above for
an explanation of these selections

Figure 5.4 - Event Display Print Dialog
3. Click the OK button.
If you chose Print Preview, the system displays your data in a browser print preview display with options for
printing such as page orientation and paper size. You can also use your Printer Preferences dialog to make some
of these selections. When printing your data, the analyzer creates an html file and prints the path to the file at the
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bottom of the page. This file can be opened in your browser, however, it may appear different than the printed
version.

5.5.3 Print Preview
Print Preview gives a preview of how the data looks printed. You can scroll through the pages and zoom in on the
data to get a closer look. The line of buttons across the top of the window controls the functions of the window.
To open the Print Preview window:
1. Choose Print Preview from the File menu in any window that supports printing.
2. Choose to include the Summary Pane (check the box) in the print output. The summary Pane appears at
the beginning of the printed output in tabular format. If you select All layers in the Detail Section, the Data
Bytes option becomes available.
3. In the Detail Section, choose to exclude the decode from the Detail Pane in the Frame Display, or include
All Layers or Selected Layers Only. If you choose to include selected layers, then select (click on and
highlight) the layers from the list box. Click on selected layers in the list to de-select, or click the Reset
button to de-select all selected layers.
Note: Decode layers printout expanded regardless of the state of the Detail Pane in the
Frame Display at the time of the request to print. This can produce a print output
consisting of hundreds of pages or more. We recommend that you use Print Preview to
determine the number of pages in your print output prior to printing.

4. Select the range of frames to include All or Selection in the Frame Range section of the Frame
Display Print dialog.
Choosing All prints all of the frames in the capture file or buffer. If there are more than 1000 frames in
the capture file or buffer, All will not be available.
Choosing Selection prints only the selected frames in the Frame Display window.
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Note: See Configure the Print File Range in the Frame Display Print Dialog above for
an explanation of these selections.

Note: Selecting the Delete File deletes the temporary html file that was used during
printing..
5. Click the OK button.
You can print directly from the Print Preview window.
l

Next Page shows you how the next page in your data looks

l

Prev Page takes you back to the previous page.

l

l

l

l

Two Page changes the display to show two pages of data. When in the Two Page display, the button toggles
to One Page. Click on the One Page button to return to viewing one page.
Zoom In and Zoom Out allow you to change the magnification of the pages. Click on Zoom In to increase
the magnification, and on Zoom Out to decrease the magnification. When you have reached the limit in
either direction, the buttons is grayed out.
You can also zoom in and out by clicking on the page itself. When the cursor looks like a magnifying glass, you
can click on the page to increase the magnification. When you have reached the top level of magnification, the
cursor changes back to an arrow. Click on the page to return to normal magnification.
Click on the Close button to return to the regular display.

5.6 Exporting

5.6.1 Frame Display Export
You can dump the contents of the Summary pane on the Frame Display into a Comma Separated File (.csv).
To access this feature:
1. Right click on the Summary pane or open the Frame DisplayFile menu.
2. Select the Export… menu item.
3. Select a storage location and enter a File name.
4. Select Save.

5.6.2 Exporting a File with Event Display Export
With the Event Display Export dialog you can export the contents of the Event Display dialog as a test (.txt),
CSV (.csv.), HTML (.htm), or Binary File (.bin). You also have the option of exporting the entire capture buffer or
just the current selection of the Event Display dialog.
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Figure 5.5 - Event Display Export Example: .csv file.
How to Export Event Display Data to a File
1. Select Export Events from the File menu on the Event Display window to display the Event Display
Export dialog.
2. Enter a file path and name, or click the browser button to display the Windows Save As dialog and
navigate to the desired storage location.
3. Select a file type from the Save as type: drop-down List Menu on the Event Display Export dialog.
Select from among the following file formats:
Text File (*.txt)
CSV File (*.csv)
HTML File (*.html)
Binary File (*.bin)
4. Select the range of events to include in the file from either All or Selection in the Event Range section
of the Event Display Export dialog.
l

l

Selecting more than one event in the Event Display window defaults the radio button in the Event
Display Export dialog to Selection and allows the user to choose the All radio button.
When only one event is selected (something must be selected), the All radio button in the Event
Display Export dialog is selected by default.

5. Next you need to select the Side variable for serial communications.
l

Side is used to determine whether you want to export data from Data Communications Equipment
(DCE), Data Terminal Equipment (DTE) or both.

l

Side is used to determine whether you want to export data from the Host, Function/Control, or Both.

l

Choose DCE, DTEHost, Function\Control or Both to determine how you want to export the data.
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5. Choose DCE, DTEHost, Function\Control or Both to determine how you want to export the data.
6. Choose whether you want to display multiple events or single events per row.
Events Per Row: You can choose to display Multiple Events Per Row, but this method contains no
timestamps. If you select One Event Per Row, you can display timestamps. multiple events or single
events per row.
Note: The raw timestamp value is the number of 100-nanosecond intervals since the
beginning of January 1, 1601. This is standard Windows time.
.
Timestamp
Delta
Event Number
Byte Number
Frame Number
Type
Hex
Dec
Oct
Bin
Side
ASCII | 7-bit ASCII | EBCDIC | Baudot
RTS
CTS
DSR
DTR
CD
RI
UART Overrun
Parity Error
Framing Error
7. If you select .csv as the file type, choose whether you want to hide/display Preambles or Column
Headings in the exported file
8. Click Save. The Event Display Export file is saved to the locations you specified in File name.
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Figure 5.6 - Example: .csv Event Display Export, Excel spreadsheet

5.6.2.1 Export Filter Out
You can filter out data you don't want or need in your text file.
(This option is available only for serial data.) In the Filter Out box, choose which side to filter out: the DTE data,
the DCE data or neither side (don't filter any data.) For example, if you choose the radio button for DTE data, the
DTE data would be filtered out of your export file and the file would contain only the DCE data.
You can also filter out Special Events (which is everything that is not a data byte, such as control signal changes and
Set I/O events), Non-printable characters or both. If you choose to filter out Special Events, your export file would
contain only the data bytes. Filtering out the non-printable characters means that your export file would contain
only special events and data bytes classified as printable. In ASCII, printable characters are those with hex values
between $20 and $7e.

5.6.2.2 Exporting Baudot
When exporting Baudot, you need to be able to determine the state of the shift character. In a text export, the
state of the shift bit can be determined by the data in the Character field. When letters is active, the character
field shows letters and vice versa.
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6.1 System Settings
Open the System Settings window by choosing System Settings from the Options menu on the Control
window. To enable a setting, click in the box next to the setting to place a checkmark in the box. To disable a
setting, click in the box to remove the checkmark. When viewing a capture file, settings related to data capture
are grayed out.
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Single File

Figure 6.1 - System Settings Single File Mode
This option allows the analyzer to capture data to a file. Each time you capture the file you must provide a file
name. The size of each file cannot larger than the number given in File Size (in K). The name of each file is the
name you give it in the Name box followed by the date and time. The date and time are when the series was
opened.
l

Restart Capturing After Saving or Clearing Capture File
If the Automatically Restart feature is enabled, the analyzer restarts capture to the file immediately after the
file is closed.

l

Wrap File
When enabled, the analyzer wraps the file when it becomes full. The oldest events are moved out of the file
to make room for new events. Any events moved out of the file are lost. When disabled, the analyzer stops
capture when the file becomes full. Either reset the file or close your capture file to continue.

l

File Size: The size of the file will depend of the available hard disk space.
1. Click the Min button to see/set the minimum acceptable value for the file size.
2. Click the Max button to see/set the maximum acceptable value for the file size.
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You can accept these values, or you can enter a unique file size.
But if you try to close the dialog after entering a value greater
than the maximum or less than the minimum, you will see the
following dialog.

l

Start up
Opens the Program Start up Options window. Start up options let you choose whether to start data capture
immediately on opening the analyzer.

l

Advanced
Opens the Advanced System Options window. The Advanced Settings should only be changed on advice of
technical support.

6.1.1 System Settings - Disabled/Enabled Options
Some of the System Settings options are disabled depending upon the status of the data capture session.
l

l

l

As the default, all the options on the System Settings dialog are enabled.
Once the user begins to capture data by selecting the Start Capture button, some of the options on the System
Settings dialog are disabled until the user stops data capture and either saves or erases the captured data.
The user can go into the Startup options and Advanced system options on the System Settings dialog and
make changes to the settings at any time.

6.1.2 Changing Default File Locations
The analyzer saves user files in specific locations by default. Capture files are placed in the My Capture Files
directory and configurations are put in My Configurations. These locations are set at installation.
Follow the steps below to change the default locations.
1. Choose Directories from the Options menu on the Control window to open the File Locations
window.
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Figure 6.2 - File Locations dialog
2. Select the default location you wish to change.
3. Click Modify.
4. Browse to a new location.

Figure 6.3 - File Locations Browse dialog
5. Click OK.
6. Click OK when finished.

ccxiv

NetDecoder Async User Manual

Chapter 6 Information

TELEDYNE LECROY

If a user sets the My Decoders directory such that it is up-directory from an installation path, multiple instances of
a personality entry may be detected, which causes a failure when trying to launch Frontline. For example, if an
Frontline product is installed at C:\Users\Public\Public Documents\Frontline Test Equipment\My Decoders\ then
"My Decoders" cannot be set to any of the following:
l

C:\ My Decoders\

l

C:\Users\ My Decoders\

l

C:\Users\\Public\My Decoders\

l

C:\Users\Public\Public Documents\My Decoders\

l

or to any directory that already exists in the path C:\Users\Public\Public Documents\Frontline Test
Equipment\My Decoders\

Default Capture File Folder Checkbox
If the Use Last Opened Folder for Capture Files checkbox is checked, then the system automatically
changes the default location for saving capture files each time you open a file from or save a file to a new location.
For example, let's say the default location for saving capture files is Drive A > Folder A. Now you select the Use
Last Opened Folder for Capture Files checkbox. The next time, however, you open a capture file from a
different location, Folder B > Removable Flash Drive for example. Now when you save the capture file, it will be
saved to Folder B > Removable Flash Drive. Also, all subsequent files will be saved to that location. This remains
true until you open a file from or save a file to a different location.
There is one caveat to this scenario, however. Let's say you have selected Use Last Opened Folder for
Capture Files and opened a file from a location other than the default directory. All subsequent capture files
will be saved to that location. Suppose, however, the next time you want to save a capture file, the new file
location is not available because the directory structure has changed: a folder has been moved, a drive has been
reassigned, a flash drive has been disconnected, etc. In the case of a "lost" directory structure, subsequent
capture files will be saved to the default location. ComProbe software will always try to save a file to the folder
where the last file was opened from or saved to, if Use Last Opened Folder for Capture Files is checked. If,
however, the location is not accessible, files are saved to the default directory that is set at installation.
If the checkbox is unchecked, then the system always defaults to the directory listed in the File Locations dialog.

6.1.3 Selecting Start Up Options
To open this window:
1. Choose System Settings from the Options menu on the Control

window.

2. On the System Settings window, click the Start Up button.
3. Choose one of the options to determine if the analyzer starts data capture immediately on starting up or
not.
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Figure 6.4 - Start Up Options dialog
l

Don't start capturing immediately - This is the default setting. The analyzer begins monitoring data but
does not begin capturing data until clicking the Start Capture
icon on the Control, Event Display or
Frame Display windows.

l

Start capturing to a file immediately - When the analyzer starts up, it immediately opens a capture file
and begins data capture to it. This is the equivalent of clicking theStart Capture
icon. The file is given a
name based on the settings for capturing to a file or series of files in the System Settings window.

l

Start capturing immediately to the following file: - Enter a file name in the box below this option. When
the analyzer starts up, it immediately begins data capture to that file. If the file already exists, the data in it is
overwritten.

6.1.4 Side Names
The Side Names dialog is used to change the names of objects and events that appear in various displays. The
Side Names dialog will change depending on the sniffing technology in use at the time the software was loaded.
Changes to the Names are used throughout the program.

Figure 6.5 - Example: Side Names Where "Slave" and "Master" are current
1. To open the Side Names dialog, choose Side Names… from the Options menu on the Control
window.
2. To change a name, click on the name given in the Current Names column, and then click again to modify
the name (a slow double-click).
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3. Select OK to initiate the changes. The changes that have been made will not fully take effect for any views
already open. Closing and reopening the views will cause the name change to take effect.
4. To restore the default values, click the Set Defaults button.

6.1.5 Timestamping Options
The Timestamping Options window allows you to enable or disable timestamping, and change the resolution of
the timestamps for both capture and display purposes.
To open this window:
Choose Set Timestamp Format… from the Options menu on the Frame Display and Event Display window or
click on the Timestamping Option
icon in the Event Display toolbar. The Timestamping Options window
will open.

Figure 6.6 - Timestamping Options dialog

Enabling/Disabling Timestamp
To enable timestamping click to make a check appear in the check box Store Timestamps (This time takes
effect immediately). Removing the check will disable timestamping.

Changing the Timestamp Resolution
This option affects the resolution of the timestamp stored in the capture file. The default timestamp is 10
milliseconds. This value is determined by the operating system and is the smallest "normal" resolutions possible.
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Note: The raw timestamp value is the number of 100-nanosecond intervals since the
beginning of January 1, 1601. This is standard Windows time.
It is also possible to use "high resolution"
timestamping. High resolution timestamp
values are marked by an asterisk as high
resolution in the drop down list. To change
timestamping resolutions:
1. Go to the Capture Options section
of the window.
2. Change the resolution listed in the
Storage Resolution box.
Note: If you change the resolution,
you need to exit the analyzer and restart in order for the change to take effect.

Performance Issues with High Resolution Timestamp
There are two things to be aware of when using high resolution timestamps. The first is that high resolution
timestamps take up more space in the capture file because more bits are required to store the timestamp. Also,
more timestamps need to be stored than at normal resolutions. The second issue is that using high resolution
timestamping may affect performance on slower machines
For example, if 10 bytes of data are captured in 10 milliseconds at a rate of 1 byte per millisecond, and the
timestamp resolution is 10 milliseconds, then only one timestamp needs to be stored for the 10 bytes of data. If
the resolution is 1 millisecond, then 10 timestamps need to be stored, one for each byte of data. If you have two
capture files, both of the same size, but one was captured using normal resolution timestamping and the other
using high resolution, the normal resolution file has more data events in it, because less room is used to store
timestamps.
You can increase the size of your capture file in the System Settings.

Switching Between Relative and Absolute Time
With Timestamping you can choose to employ Relative Time or Absolute time.
1. Choose System Settings from the Options menu on the Control window, and click the
Timestamping Options button, or click the click the Timestamping Options icon
from the
Event Display

window.

2. Go to the Display Options section at the bottom of the window and find the Display Relative
Timestamps checkbox.
3. Check the box to switch the display to relative timestamps. Remove the check to return to absolute
timestamps.
Note: The options in this section affect only how the timestamps are displayed on the screen,
not how the timestamps are recorded in the capture file.
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Display Raw Timestamp Value shows the timestamp as the total time in hundred nanoseconds from a
specific point in time.
Display Relative Timestamps shows the timestamp as the amount of time that has passed since the first
byte was captured. It works just like a stop watch in that the timestamp for the first byte is 0:00:00.0000 and
all subsequent timestamps increment from there. The timestamp is recorded as the actual time, so you can
flip back and forth between relative and actual time as needed.
Selecting both values displays the total time in nanoseconds from the start of the capture as opposed to a
specific point in time.
Selecting neither value displays the actual chronological time.

When you select Display Relative Timestamp you can set the number of digits to display using the up or down
arrows on the numeric list.

Displaying Fractions of a Second
1. Choose System Settings from the Options menu on the Control

window, and click the

Timestamping Options button, or click the click the Timestamping Options icon
the Event Display

or Statistics

from either

window.

2. Go to the Display Options section at the bottom of the window, and find the Number of Digits to
Display box.
3. Click on the arrows to change the number. You can display between 0 and 6 digits to the right of the
decimal point.
6.1.5.1 Converting Timestamps
Serialtest for DOS uses a timebase of Pacific Standard Time during non daylight savings time hours and Pacific
Daylight Time during daylight savings time hours. The analyzer always uses Greenwich Mean Time (also known as
Universal Time Coordinates).
When importing a Serialtest for DOS file, the analyzer must determine if the file was recorded during daylight
savings time or not before converting the timestamps. Because the rules for determining this can change, it is
possible for the analyzer to convert the timestamps incorrectly, resulting in timestamps that are off by one hour.
Note: The raw timestamp value is the number of 100-nanosecond intervals since the
beginning of January 1, 1601. This is standard Windows time.

6.2 Technical Information
The following information is provided to assist you in troubleshooting data capture problems.

6.2.1 Asynchronous Serial Performance Notes

As a software-based product, the speed of your computer’s processor affects Frontline’s performance. Overrun
errors and buffer overflows are indicators that Frontline is unable to keep up with the data. The information
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below describes what happens to the data as it comes in the port, what the two types of errors mean, and how
various aspects of Frontline affect performance. Also included are suggestions on how to improve performance.
Data captured by the serial port first goes into the buffer of the UART chip of the serial port. The UART generates
an interrupt, which tells the Frontline driver to check the port. The driver takes the data from the UART and
counts each byte as they are put into the driver’s own buffer. The driver tells Frontline that data is ready to be
processed. Frontline takes the data from the driver’s buffer and puts the data into the capture buffer.
Overrun errors occur when the data in the buffer of the UART is not retrieved before new data comes in. In this
case, Frontline knows that it has lost information, but it does not know how much. Frontline indicates overrun
errors in the Event Display screen by marking a byte near the overrun in red. You can search for overrun errors
using the Find feature.
Driver buffer overflow errors occur when the data in the buffer of the driver is not retrieved before new data
comes in. Since the driver counts the bytes as it retrieves them from the UART, it not only knows that it has lost
data, it also knows how much. Buffer overflows are indicated in the Event Display screen by a plus sign within a
circle. Clicking on the buffer overflow symbol shows how many events have been lost. The Statistics window is a
good place to check for buffer overflow errors.
Both overrun errors and buffer overflows indicate that data is coming in too quickly for Frontline to process.
There are several things that you can do to try and solve this problem.
l

l

l

l

l

l

ccxx

In the Hardware Settings window, select Use Windows Device Manager Settings. This means that Windows
does not generate an interrupt every time a byte comes in, but rather waits until several bytes have
accumulated in the UART buffer before telling Frontline to retrieve them. This increases performance at the
cost of timestamp accuracy, since all the bytes in a group have the same timestamp regardless of when they
actually arrived at the UART. Some control signal changes may also be lost.
Frontline’s number one priority is capturing data; updating windows is secondary. However, updating
windows still takes a certain amount of processor time, and may cause Frontline to lose data while the
window is being updated. Some windows require more processing time than others, because the information
being displayed in them is constantly changing. Refrain from displaying data live in the Event Display and
Frame Display windows. Try closing the Breakout Box and Statistics windows. Frontline can capture data with
no windows other than the Control window open.
Increase the value of the window refresh rate for any windows you have open while capturing data. This
decreases the frequency of window updates, leaving more time for capturing data. Changing the refresh rate
can be done from the Options screen in each window.
If you suspect or know that your circuit has control signals that are changing very rapidly, go to the Hardware
Settings window and choose to Disable Control Signal Interrupts. This prevents Frontline from capturing
control signal changes on an interrupt basis, giving more time for capturing byte data. (You can use the
counters in the Breakout Box to help determine if a control signal is changing quickly.) Frontline still notes the
state of the control signals whenever a byte is captured. You must restart Frontline for this change to take
effect.
Close all other programs that are working while Frontline is running. Refrain from doing searches in the Event
Display window or other processor intensive activities while Frontline is capturing data.
Timestamping takes up processor time, primarily not in timestamping the data, but in writing the timestamp to
the buffer or file. Try turning off timestamping from the Timestamping Options window.
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Change the size of the driver buffer. This value is changed from the Advanced System Settings. Go to the
Control Window and choose System Settings from the Options menu. Click on the Advanced button. Find the
value labeled Driver Receive Buffer Size in Operating System Pages. Take the value listed there and double it.

NOTE: This procedure might help buffer overflow errors, but does not help overrun errors.

l

Slow down the speed of the communications circuit, if possible.

If you are still experiencing overruns and/or buffer overflows after trying all of the above options, then you may
need to use a faster PC.

6.2.2 Progress Bars
The analyzer uses progress bars to indicate the progress of a number of different processes. Some progress bars
(such as the filtering progress bar) remain visible, while others are hidden.
The title on the progress bar indicates the process underway.

6.2.3 Event Numbering
This section provides information about how events are numbered when they are first captured and how this
affects the display windows in the analyzer. The information in this section applies to frame numbering as well.
When the analyzer captures an event, it gives the event a number. If the event is a data byte event, it receives a
byte number in addition to an event number. There are usually more events than bytes, with the result is that a
byte might be listed as Event 10 of 16 when viewing all events, and Byte 8 of 11 when viewing only the data bytes.
The numbers assigned to events that are wrapped out of the buffer are not reassigned. In other words, when
event number 1 is wrapped out of the buffer, event number 2 is not renumbered to event 1. This means that the
first event in the buffer may be listed as event 11520 of 16334, because events 1-11519 have been wrapped out
of the buffer. Since row numbers refer to the event numbers, they work the same way. In the above example,
the first row would be listed as 2d00 (which is hex for 11520.)
The advantage of not renumbering events is that you can save a portion of a capture file, send it to a colleague,
and tell your colleague to look at a particular event. Since the events are not renumbered, your colleague’s file
use the same event numbers that your file does.

6.2.4 Ring Indicator
The following information applies when operating the analyzer in Spy mode or Source DTE, No FTS Cables
mode. When using the cables supplied with the analyzer to capture or source data, Ring Indicator (RI) is routed to
a different pin which generates interrupts normally.
There is a special case involving Ring Indicator and computers with 8250 UARTs or UARTs from that family where
the state of RI may not be captured accurately. Normally when a control signal changes state from high to low or
low to high, an interrupt is generated by the UART, and the analyzer goes to see what has changed and record it.
Ring Indicator works a little differently. An interrupt is generated when RI changes from high to low, but not when
RI changes from low to high. If Ring Indicator changes from low to high, the analyzer does not know that RI has
changed state until another event occurs that generates an interrupt. This is simply the way the UART works, and
is not a deficiency in the analyzer software.
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To minimize the chance of missing a Ring Indicator change, the analyzer polls the UART every millisecond to see if
RI has changed. It is still possible for the analyzer to miss a Ring Indicator change if RI and only RI changes state
more than once per millisecond.
UARTs in the 8250 family include 8250s, 16450s, 16550s and 16550 variants. If you have any questions about the
behavior of your UART and Ring Indicator, please contact technical support.

6.2.5 RS-232 Pin-outs
Pin

Table 6.1 - 25-Pin Connector Pins
Name

Abbreviation

1

Frame Ground

FG

2

Transmit Data

TxD

3

Receive Data

RxD

4

Request To Send

RTS

5

Clear to Send

CTS

6

Data Set Ready

DSR

7

Signal Ground

GND

8

Carrier Detect

CD or DCD

20

Data Terminal Read

DTR

22

Ring Indicator

RI

Pin

Table 6.2 - 9-Pin Connector Pins
Name

Abbreviation

1

Carrier Detect

CD or DCD

2

Receive Data

RxD

3

Transmit Data

TxD

4

Data Terminal Ready

DTR

5

Signal Ground

GND

6

Data Set Ready

DSR

7

Request To Send

RTS

8

Clear To Send

CTS

9

Ring Indicator

RI

6.2.6 Userful Character Tables
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6.2.6.1 ASCII Codes

6.2.6.2 Baudot Codes
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6.2.6.3 EBCDIC Codes

6.2.6.4 Communication Control Characters
Listed below in alphabetical order are the expanded text meanings for common ANSI communication control
characters, and two-character system abbreviation for each one. Some abbreviations have forward slash
characters between the two letters. This is to differentiate the abbreviations for a control character from a hex
number. For example, the abbreviation for Form Feed is listed as F/F, to differentiate it from the hex number FF.
Table 6.3 - Communications Control Characters
Abbreviation

Control Character

Text

AK

ACK

Acknowledge

BL

BEL

Bell

BS

BS

Backspace

CN

CAN

Cancel

CR

CR

Carriage Return

D/1-4

DC1-4

Device Control 1-4

D/E

DEL

Delete

DL

DLE

Data Link Escape

EM

EM

End of Medium

EQ

ENQ

Enquiry

ET

EOT

End of Transmission

E/C

ESC

Escape

E/B

ETB

End of Transmission Block

EX

ETX

End of Text

F/F

FF

Form Feed
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Table 6.3 - Communications Control Characters(continued)
Abbreviation

Control Character

Text

FS

FS

File Separator

GS

GS

Group Separator

HT

HT

Horizontal Tabulation

LF

LF

Line Feed

NK

NAK

Negative Acknowledge

NU

NUL

Null

RS

RS

Record Separator

SI

SI

Shift In

SO

SO

Shift Out

SH

SOH

Start of Heading

SX

STX

Start of Text

SB

SUB

Substitute

SY

SYN

Synchronous Idle

US

US

Unit Separator

VT

VT

Vertical Tabulation

6.3 DecoderScript Overview
The main purpose of this manual is to describe DecoderScript™, the language used in writing decoders.
DecoderScript allows you to create new decoders or modify existing decoders to expand the functionality of your
ComProbe protocol analyzer. DecoderScript displays protocol data, checks the values of fields, validates
checksums, converts and combines field values for convenient presentation. Decoders can also be augmented
with custom C++-coded functions, called "methods", to extend data formatting, validation, transformations, and so
on.
A decoder defines field-by-field how a protocol message can be taken apart and displayed. The core of each
"decoder" is a program that defines how the protocol data is broken up into fields and displayed in the Frame
Display window of the analyzer software.
This manual provides instruction on how to create and use custom decoders. When reading the manual for the
first time, we encourage you to read the chapters in sequence. The chapters are organized in such a way to
introduce you to DecoderScript writing step- by- step.
Screenshots of the ComProbe protocol analyzer have been included in the manual to illustrate what you see on
your own screen as you develop decoders. But you should be aware for various reasons, the examples may be
slightly different from the ones that you create. The differences could be the result of configuration differences or
because you are running a newer version of the program. Do not worry if an icon seems to be missing, a font is
different, or even if the entire color scheme appears to have changed. The examples are still valid.
Examples of decoders, methods, and frame recognizers are included in this manual. You can cut and paste from
these examples to create your own decoders.
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These files are installed in the FTE directory of the system Common Files directory. The readme file in the root
directory of the protocol analyzer installation contains a complete list of included files. Most files are located in My
Decoders and My Methods.
We will be updating our web site with new and updated utilities, etc, on a regular basis and we urge decoder
writers to check there occasionally.

Contacting Frontline Technical Support
Technical support is available in several ways. The online help system provides answers to many user related
questions. Frontline's website has documentation on common problems, as well as software upgrades and utilities
to use with our products.
On the Web: http://fte.com/support/supportrequest.aspx
Email:

tech_support@fte.com

If you need to talk to a technical support representative about your NetDecoderAsync, support is available
between 9 am and 5 pm, U.S. Eastern Time zone, and between 9 am and 5 pm, Pacific Time zone, on Monday
through Friday. Technical support is not available on U.S. national holidays.
Phone: +1 (434) 984-4500
Fax:

+1 (434) 984-4505

Instructional Videos
Teledyne LeCroy provides a series of videos to assist the user and may answer your questions. These videos can
be accessed at fte.com/support/videos.aspx. On this web page use the Video Filters sidebar to select
instructional videos for your product.
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